Jump to content

Web Clipper not working in Safari 11


Recommended Posts

Evernote Clipper has stopped working in Safari 11 on the Mac. (Actually it's v. 11.1)  I click the Clipper button and nothing happens. I've had to switch to Chrome to make it work but much prefer to use Safari. Has anyone found a fix for this?

Link to comment
  • 3 weeks later...
  • 1 month later...

My apologies to Evernote. The issue was my understanding of how Safari 11.1 worked.

I haven't worked out why but the default window in my Safari is Private. With the Privacy setting checked in the preferences. I was unchecking these setting but the Private Window was still causing the problem. 

By opening a regular window and using the unchecked settings in Privacy the Web Clipper functioned fine. Often I had to refresh the page I was clipping and check in Manage Website Data that the Evernote cookie was present.

I also found that deleting the regular window and re-checking the Privacy setting does not automatically remove all cookies. You need to delete them under Manage Website Data. This gets back to the higher security settings of Safari.



Link to comment
  • 2 weeks later...
Guest okramar

I was having the issue with the "enable cookies" pop up box, and no ability to use the web clipper. Fixed it by unchecking "prevent cross-site tracking" in the Safari privacy settings.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...