Jump to content

EverNote, title of note problem

Recommended Posts

I experience the following problem with clippings.io and Evernote.

I have my Kindle highlights in clippings.io. Clippings.io has an export feature to Evernote.
The highlights are exported to EverNote and everythings seems OK (see screenshot).

But when I use them in another program, I get problems with the titles of the pages going missing. F.r. in OneNote for my notebooks, I import it with the EverNote Importer from Microsoft.

In OneNote the titles of the pages are missing (see screenshot).
When I add a note with title manually and import it, the title of the page appears.

I think it has something to do with the format of the title in the export process of clippings.io.
But the code to get the title of the page be created from the books title seems to be OK:

var book = new Note


NotebookGuid = _notebookGuid,

Title = bookTitle,

Attributes =

new NoteAttributes


SourceURL = "http://www.clippings.io",

SourceApplication = "http://www.clippings.io",

Source = "http://www.clippings.io",

Author = "http://www.clippings.io"


Content = bookText


Can anyone help?

Best, Adrian

EverNote Page With Title.JPG

OneNote Import Page Without Title.JPG

Link to comment
  • Level 5*

Hi.  It seems like the problem here is not with Evernote,  but with either the format of the Clippings.io output or the way in which that code is interpreted by OneNote through the importer.  Have you tried those companies' support links?  I can't help you with this,  and I don't know of anyone who might unless they're using exactly the same process and have already found a work-around. 

You could contact Evernote Support directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

Link to comment

Yes, I have contacted Microsoft and Clippings.io besides my contact with You.

The question here is totally Evernote related.

What are the "formatting options" for the page title?
The title that seems to be created by clippings.io seems to be missing properties a "normal title" has.

Because normally created page titles (by hand) get exported without problems.
End even if I alter a Clippings.io created title manually in Evernote the problem persists.

To the "naked eye" the page titles look the same in Evernote, but they are not.
What properties are tied to the page title which could be inspected?

Link to comment

Thx for the tipp. I have done so.

This is the title of one page that was created from clippings.io, where the title gets lost:.
<note><title>Zeit: Der Stoff, aus dem das Leben ist. Eine Gebrauchsanleitung (German Edition)_</title><content><![CDATA[<!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd">

And this is the one from the note manually added.
<note><title>Testtitel der Testnotiz</title><content><![CDATA[<?xml version="1.0" encoding="UTF-8"?>, where the title dos NOT get lost.
<!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd">

As You see, there is a difference. But is this difference the cause of the title getting lost?


Link to comment
  • Level 5*
37 minutes ago, adrian142 said:

As You see, there is a difference. But is this difference the cause of the title getting lost?

Interesting...  I'm not sure whether a few characters is enough to cause that much trouble,  but I guess if they're in the wrong place on one or other of those notes it could be a problem.  This is one I think you need to kick upstairs to the Evernote support team.  If you're a paying customer you can reach out to Support directly on https://help.evernote.com/hc/requests/new or tweet them via https://twitter.com/evernotehelps 

You may want to send this nugget on to the other teams as well to see if you can get a response...

Link to comment
  • 1 year later...

Missing Evernote to OneNote Title issue SOLVED

Had same issue. I solved it with manual XML edit.

I noticed that some XML tags on those with no title was different (missing some XML, which set the encoding, which I think is the issue).

So, I did the following:

1) export from Evernote the notes you want to migrate.

2) open the enex file in textedit on Mac

3) do a manual find/replace in textedit on Mac, replacing the seemingly "faulty" tag <![CDATA[<!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd"> with <![CDATA[<?xml version="1.0" encoding="UTF-8" standalone="no"?><!DOCTYPE en-note SYSTEM "http://xml.evernote.com/pub/enml2.dtd"><en-note>.

4) Save the file in textedit

4) Open the OneNote import tool.

5) Re-run the import with the OneNote import tool, selecting the newly saved file  (with the find/replace carried out).

FYI, the Evernote export order appears to be by last modified, most recent first.

Evernote team, this appears to be your (export) issue, not Microsoft's import issue. 


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...