Jump to content

Reporting a Bug: allowed password length inconsistent with login methods

Recommended Posts

It looks like I found a bug in the various login methods provided by Evernote.  I tried to contact support but as a basic customer it doesn't look like there's even a way to report bugs anymore without upgrading to chat or send an email.

The password reset page allows for a password with a maximum length of 64 characters.  I chose a 64-character password and everything worked fine.  I then tried to connect my Android Evernote app using the new credentials and it wouldn't work at all.  I went back to the website and logged out/in again and had the same issue.  Neither login method worked anymore.

I used the "forgot password" method to reset my password to something 40 characters long and now everything works.  I'd check your backend limitations (database), front-end limitations (app login fields, website login fields), and website password reset fields to make sure that they're all working with the same assumptions for maximum password length.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...