Jump to content

Skitch 2.7.2 "Screen Snap" not working on OSX 10.9.2


Bryce_F

Recommended Posts

Skitch used to work fine until I bought a new Macbook Pro last month.  Now the draggable "Screen Snap" (aka Crosshair Snapshot) tool does nothing.  Clicking the button does absolutely nothing (other than the button press animation).  All of the other snapshot tools work fine, just not Screen Snap.

 

Skitch and "Screen Snap" used to work just fine on my old Macbook Pro (which also ran Mavericks).  But on my current MBP computer, it has never worked.  Skitch was one of the first pieces of software I installed on the new computer, so Skitch seems to be broken on a vanilla OSX installation.  I've tried uninstalling and reinstalling to no avail.

 

My current system:

Retina display, 15-inch (2880 x 1800), late 2013

OSX 10.9.2 (13C64)

Graphics:  NVIDIA GeForce GT 750M 2048 MB

Memory:  16GB DDR3, 1600MHz

 

 

Thanks,

Bryce

Link to post

Welcome to the Forum Bryce.  Sorry to hear you are having difficulty with Skitch.  Your new MBP looks like a Beast!

 

With that in mind, I suggest a Support Ticket.  They may need to make an adjustment with the software to be compatible with the Beast you bought.  If I understand things correctly, Evernote purchased Skitch, so the Skitch people may not have known to make certain changes in the software for it to work on newer hardware/software like what you have.  I don't know for sure, but that is my guess.  I am running Late 2012 MBP Retina and it works fine as it did for you on your old MBP.

 

Support:  https://evernote.com/contact/support

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...