Jump to content

(Archived) iPhone favorites in flightmode not readable

Recommended Posts

If you mark a note as a "Favorite", it should be readable offline when you click on it in the Favorites list. What type of notes are you testing with? Does this happen with plain text notes, or are you looking at something bigger like a PDF, etc.?

Link to comment
If you mark a note as a "Favorite", it should be readable offline when you click on it in the Favorites list. What type of notes are you testing with? Does this happen with plain text notes, or are you looking at something bigger like a PDF, etc.?

No, while before this worked for me, it appears to be broken in the most recent client.

Notes that have been favorited are not available if I disable networking. It doesn't seem to matter what kind of note, though if it was the last note loaded when I disabled networking, it remains loaded (seemingly like just like any other 'cached' note).

The following error occurs:

Error communicating with the Evernote servers:

NSURLErrorDomain (-1001)

Link to comment

Could you all let us know what network carriers you are using? It appears that this may be specific to certain networks, because we don't see this problem here with US AT&T.

If any of you are a bit technical, it would also be useful to get more detailed error logs from the Console on the device. This would require you to install the iPhone Configuration Utility 1.1 and then use this to get the Console from the device when you are reproducing the error.

http://support.apple.com/downloads/iPho ... or_Windows

http://support.apple.com/downloads/iPho ... r_Mac_OS_X

Link to comment

Yes, I should have clarified that, unlike the OP, this was a problem on my Touch, and so it seemed like something "broke" the capability to store notes locally in the latest version of the client (rather than anything to do with airplane mode specifically). The spinning symbol in the interface makes it seem that the client is trying to access the network even for notes that have been marked as favorite.

Link to comment

Could you check the full version of the iPhone app on your device? It's at the bottom of the "Account" screen.

The latest should be 1.5.1. We fixed a bug in this release which may be related, so if you're on something older (e.g. 1.5), you'll need to upgrade.


Link to comment
I had the problem while running 1.5.1.

Oddly, I was able to favorite a different note today and it loaded fine even with the network disabled. So, now I'm simply confused. :?

I just had the same problem.

I wasn't able to do it, now I am.


Link to comment
  • 2 weeks later...

I've been having the same problem in the last few days. Until the latest iPhone app udate 1.5.1 (39928), I was able to view every "favorites" when I was offline. Since the update, when I try to view my notes when my iPhone is offline, the little wheel spins for a long time and then I get an error message like the one in the image above, telling me: "Error communicating with the Evernote servers: NSURLErrorDomain (-1001)"

I'm in Canada and my carrier is Rogers but again, the "favorites" feature was working fine until the most recent update, so I really doubt it has anything to do with my carrier.

Link to comment

I'm having the same problem for the last few weeks. I made all of my notes favourites, so I could read them offline, now I can't read any of my notes. I get the "Error communicating with the Evernote servers: NSURLErrorDomain (-1001)" error message.

On one occasion in the last month, I could read my notes, but every other effort failed.

I can read the notes perfectly on my iMac.

My carrier is O2 Ireland.

Essentially Evernote iPhone is useless to me at present. I hope you can find and fix the problem as soon as possible.



Link to comment

I am having the same problem. I have a first gen iPhone, and I'm in the US with carrier AT&T. I have version 1.5.1 of Evernote on the iPhone. This happened to me a lot during the Christmas shopping season when I was using Evernote to store Christmas lists for my family and was in stores where cell phone reception was spotty or not available. I would click on a text note in the favorites list and get the spinning wheel and eventually the "Error communicating with the Evernote servers: NSURLErrorDomain (-1001)" error. The note would not display - only the title. Very annoying!

I can reproduce this right now by putting the iPhone into Airplane Mode and trying to access a Favorites note.

Link to comment

I have the same problem. I want to use Evernote as a replacement for the iPod Touch's notepad, but I can't be connected to a network all the time. I need to be able to view my Evernotes in an offline mode. Please make this feature work. I'll even pay for the app.

Link to comment

I'm also in the US with AT&T as my carrier, and have encountered this problem.

Most recently, I ran into this issue at Macworld Expo this week. The bulk of the convention is underground, thus with dodgy carrier service availability. I tried tapping on one of my (supposedly offline) favorite notes where I tracked convention information. But all I got was the note's title, an empty details region (which shouldn't be blank), and the spinning throbber.

I have yet to get the error message which others have seen. But perhaps I've been too impatient -- I usually switch to another app after waiting for about 30 seconds to 1 minute.

I've also managed to reproduce this when in Airplane mode with WiFi off.

A "workaround" I've used is to view the note with network access. Using my example at Macworld, while using their free Wifi, I tapped on my note from the Notes tab rather than the Favorites tab. In that case, the note contents did appear; in fact, they continued to appear when I tapped the note from Favorites thereafter. However, this doesn't solve the crucial issue of note access when there's neither WiFi nor carrier service available.

I'm also running Evernote 1.5.1 on an iPhone 3G running OS 2.2. Fwiw, I'm also on the paid Premium service. At first I wondered if the always-on secure connection with Premium was the cause, but I doubt it since others here with free accounts also encounter this problem.

Link to comment

Weird - trying this now I can't replicate it. With all wireless turned off, I can read all the favorites - I do get a warning to change to turn off airplane mode or use wi-fi but just clicking OK and not doing anything else allows me to access all notes in favorites - nothing missing. I'm in New York on AT&T. Premium user.



Link to comment
  • 1 year later...

I've seen that problem a few times on the iPhone (typically when I *really* needed my notes) with the favorites and also as a premium user.

Recently I had the same problem on the iPad :(

When the connection to the Evernote server is uncertain (bad connection, roaming set to off, or the server is down) the app often gets into a very bad mode of spinning this hourglass wheel forever, showing no preview icons (should be still loaded) or even showing title and preview but then a blank page as the note content.

I wish I could control the synching manually (push a button to synch, otherwise use the offline notes).

I'm quite unhappy with Evernote on my iPhone and iPad. I'm forced to pay for premium just to be able to work on my notes offline, and exactly that is still not working properly :?


Link to comment
  • 10 months later...


This topic is now archived and is closed to further replies.

  • Create New...