Jump to content
  • 0

Erratic Checkboxes using [ ]


Andrew R

Idea

I used to love using [ ] to add checkboxes in notes but the feature is so erratic now.

Example, using a completely blank note:

  • Type "erratic"
  • Move cursor in front of erratic and type "[ ] " to insert a checkbox.
  • Checkbox inserted and a line break added for no reason
  • Move cursor in front of "erratic" and hit delete.   Line break goes away but the list is now unstable.  Hit enter again and the "c" is removed from the end of erratic, when the cursor was nowhere near it.

For bonus points if you do this in any sort of table, then you can't get rid of the extra line break at all.

So basically can't add checkboxes to existing lines of text without causing issues.

 

Link to post

2 replies to this idea

Recommended Posts

  • 0
  • Level 5*
On 11/18/2016 at 0:06 PM, Andrew R said:

Example, using a completely blank note:

  • Type "erratic"
  • Move cursor in front of erratic and type "[ ] " to insert a checkbox.
  • Checkbox inserted and a line break added for no reason
  • Move cursor in front of "erratic" and hit delete.   Line break goes away but the list is now unstable.  Hit enter again and the "c" is removed from the end of erratic, when the cursor was nowhere near it.

 

You don't say which version of Evernote you are running.

I'm running Evernote 6.9.2 (454158) on macOS 10.11.4, and find that this works fine:

  • Use ⌘⇧T to insert a checkbox instead of "[ ]"

I have turned off (unchecked) the "Auto Format" option in Preferences > Formatting because I have found it unreliable, and more of a nuisance than anything else.  Everything that can be done using this pseudo markdown can be done with shortcut keys, buttons, and/or menu.

  • Like 1
Link to post
  • 0
14 hours ago, JMichaelTX said:

You don't say which version of Evernote you are running.

I'm running Evernote 6.9.2 (454158) on macOS 10.11.4, and find that this works fine:

  • Use ⌘⇧T to insert a checkbox instead of "[ ]"

I have turned off (unchecked) the "Auto Format" option in Preferences > Formatting because I have found it unreliable, and more of a nuisance than anything else.  Everything that can be done using this pseudo markdown can be done with shortcut keys, buttons, and/or menu.

 

Good shout -- it hadn't occurred to me that the auto format version would work differently to the keyboard shortcut!

I have now turned off Auto Formatting.  Hopefully the EN team are listening as we shouldn't be having to avoid or disable functionality to work around issues like this.

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...