Jump to content
Enternal

Difficulty Pasting List of URLs

Recommended Posts

In previous versions of Evernote, before they changed the Ctrl+Shift+V to the new caption Paste and Match Style, I could easily paste a list of URLs such as:

http://www.google.com/

http://www.yahoo.com/

http://www.yandex.com/

 

However after the newer updates, it no longer works and whenever I attempt to paste a list of URLs, it would look something like this:

http://www.google.com/<br/>http://www.yahoo.com/<br/>http://www.yandex.com/<br/>

 

where it adds all this HTML break line code. Is there any other way to make it work? The same thing happens when I paste it using Ctrl+Shift+V (though it worked in the past before they changed the text. Question though, it's still the same function right? They simply changed the caption? From what I tested it's the same but I just want to confirm).

 

Share this post


Link to post

Hi.  I just Ctrl-C / Ctrl-V (from the keyboard) pasted the list of URLs from here into Evernote without any problems - what source are you pasting from?  Have you tried any other options for copy / paste?  Tried pasting list into Notepad,  then back into Evernote?

Share this post


Link to post

Hello! I copy and pasted it from Notepad. That's one of the first thing I thought too when I tried it but still the same issue. I also tried it with AkelPad and various other editors. It's a weird one too that it was working all fine and everything and then the update did something to break it. Also note that it must be copy and paste into an existing note which is when it won't work. If you copy and then paste it through the function such as Ctrl+Alt+V (Paste to Evernote) then it work fine.

 

Actually there are times it works. For example a moment ago I copy and pasted it and it worked perfectly. I then delete that note, create a new note, and paste it again (I did not copy again so basically it's the same exact data that was copied and pasted into the previous note) and it showed up like that again. Very very odd issue. I also attempted an uninstall and reinstall of Evernote but same problem.

 

By the way, are there any way to download older versions of Evernote? I might have to revert to them if I can't figure out the issue with all these newer ones. Kind of annoying to work with since I deal with list of URLs pretty frequently. So far this problem existed on all my systems which are 2 Windows 7 x64, 1 Windows 10 x64 with Evernote version 5.9.1.8742 (276742). I stated all that simply because it's interesting how it totally works fine for you. So there must be something in common with my system. Still, the fact that it worked perfectly in earlier version of Evernote kind of annoys me.

 

The only way to make it work currently is to add filler text that is not a URL BUT must also contain at least a space such as:

http://www.google.com/
http://www.google.com/
http://www.google.com/
This Is A Filler With At Least 1 Space

 

 

 

 

EDIT

This might be a bit more useful for the developing team. So I open up notepad and manually typed in:

http://www.google.com/
http://www.google.com/

 

I then create a new note in Evernote. Named it Testing. Copy the texts above and then paste it into that note. I will see:

http://www.google.com/<br/>http://www.google.com/

 

I noticed that the URLs are now a link. I right click on the link to edit the URL and I see:

http://www.google.com/%3Cbr/%3Ehttp://www.google.com/

 

Notice the extra %3Cbr/%3E text. It looks like the URL transformation for <br/>. So for some reason Evernote tries to be smart and convert it to a hyperlink but instead, it convert both of the links into one hyperlink because it thinks the newline is a valid character within a URL yet it converts it to an HTML code. In previous version of Evernote, it does not try to be smart so for example when you paste the two http://www.google.com/URL lines above, they both appeared black because Evernote did not try to convert them into a clickable hyperlink. As a side effect, pasting the list of URLs works fine. In the newer Evernote version, it attempts to be smarter and ends up treating newline characters as part of the URL and convert it <br/> and then tack on the second line as a continuous URL which makes no sense at all. So the automatic hyperlink function in previous version of Evernote only works on single lines that it identifies as a URL. Newer versions of Evernote automatic hyperlink function attempts to work on multiple lines yet forget to stop whenever it encounter a newline character.

 

Proving example:

http://www.google.com/
http://www.google.com/
(empty line)
(empty line)
(empty line)
http://www.google.com

(empty line)

 

Resutling text:

http://www.google.com/<br/>http://www.google.com/<br/>http://www.google.com<br/>googlecom<br/><br/><br/><br/><br/><br/>googlecom<br/>

 

Resulting clickable mega URL for the text above:

http://www.google.com/%3Cbr/%3Ehttp://www.google.com/%3Cbr/%3Ehttp://www.google.com%3Cbr/%3Egooglecom%3Cbr/%3E%3Cbr/%3E%3Cbr/%3E%3Cbr/%3E%3Cbr/%3E%3Cbr/%3Egooglecom%3Cbr/%3E

 

Basically it's fun! :)

  • Like 1

Share this post


Link to post

Wow.  That should keep the devs busy for a while... :)   If you really want to step back until they manage to sort this out,  I'd suggest searching "evernote for windows released" in the forums (search is in the top right of your window).  You'll see all the release threads there.  Or you could use one of the third party sites like http://filehippo.com/download_evernote/

 

Good luck!  (And don't forget to backup everything you can before you make any changes...)

Share this post


Link to post

Haha yep I think they will have fun with this for a while. In the mean time, I will be using an older. Thank you very much for guiding me to the older version!

 

EDIT: OH! Just for kicks, I decided to subscribe and try the new beta version 5.9.2 Prerelease 276975 and the problem is fixed! Yeah! Thank you very much Evernote team!  :D

  • Like 1

Share this post


Link to post

×
×
  • Create New...