Jump to content

Archived

This topic is now archived and is closed to further replies.

manifold1978

ios (Archived) Strange behaviour with saved stack search

Recommended Posts

Hello,

Hoped people might have some ideas on this....

If I want to create a saved search with a specific stack, and also use “any:” before a following list of tags, something funny happens. I type the search in and results appear as expected, but once the search is saved it places the “any:” before the stack part of the query. Normally it adds several (i.e. “any:any:any”) for seemingly no reason. Since I’m a scrap merchant and I’m always searching for “old iron”, i thought it was adding the preceding “any:any:any” automatically, but it seems to do it with any search.

The search still works once saved, but the grammar seems all jumbled up.

NB: Another thing I’ve just found out: The saved searches I’m talking about here don’t work on iOS - seems to disregard the stack part of the search altogether. The problem mainly seems to be when stacks are involved, it's ok with notebooks.

My saved search, as I see it I my head, should look like this. This, to me, is meant to return all notes with any of the listed tags, across all notebooks in the "Personal" stack.

stack:Personal any: tag:"0 - Now" tag:"1 - Now" tag:"2 - Next"

On Mac Evernote, this works as I'd think, with the slight anomaly that once the search is saved, it pops up looking something like this below, and it's beyond my control to change once it's saved. It just keeps reverting back.

any:any:any: stack:Personal tag:"0 - Now" tag:"1 - Now" tag:"2 - Next"

It still works, and sometimes it's two "any:"s, sometimes three.

The same thing happens with notebook search, only it seems to stuff it's arbitrary number of "any:"s before the tags, the search still works as expected. i.e...

notebook:Personal any:any:any: tag:"0 - Now" tag:"1 - Now" tag:"2 - Next"

Despite the jumble, both saved searches work on my Mac. However, only the notebook search works on iOS. iOS seems to disregard the stack part of the search altogether, but ONLY if I have following tags with a preceding "any:". I can use stack search on its own on iOS no problem.

This is driving me insane. I hope I'm missing something obvious.

Any ideas?

Cheers,

A

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...