Jump to content

makaawhio@gmail.com

Level 1
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by makaawhio@gmail.com

  1. My Mac is running on El Capitan but it won't let me download Evernote because: "You have OS X 10.11.6. The application requires OS X 10.12 or later." The Mac runs fine but it's older so I can't update beyond El Capitan - where can I get an earlier version of Evernote to download please?
×
×
  • Create New...