Jump to content

Too easy to delete encrypted text

Recommended Posts

Yesterday I opened Evernote on my iPhone to look up something in one of my encrypted notes. I tapped the string of dots & started typing my pass phrase. After 3 taps I noticed that I didn't have the decrypt prompt and I was simply appending text. Tapped backup, and tapped one too many. The dots disappeared. I shook the phone to undo, more and more frantically, but apparently Evernote didn't recognize this as an undoable event. Shaken, I went to my iPad and iMac, finding that synchronization had worked too well and too quickly. The entire encrypted text was gone.

Undo didn't work. I hadn't deleted the note so it wasn't in the trash. A lot of valuable information was gone with just a tap.

After feverishly searching FAQs and forums I found that Premium subscribers like me could access backups of their notes. I downloaded the 2nd most recent backup, imported it, decrypted it, and found disaster had been averted.

Suggestion: If someone tries to back up over a block of encrypted text, get their pass phrase first.

Link to comment
  • 2 months later...

This just happend to me too. This is a FUNDAMENTAL FLAW.  I lost a very long written piece that I wanted to encrypt to keep private.  So, i tried encryption for the first time, and now, it is simply gone.  I went to web Evernote, hovered over the decrypt prompt, it told me my hint, and then, after typing a few characters in what I too thought was the prompt, I had overtyped the entire encrypted message.


Evernote, this kind of sloppiness is really inexcusable.  There is evidently no way to get the old message back.  Why not, as MANY of us have asked for, just give us the ability to password protect a NOTEBOOK?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...