Jump to content
  • 0
Chantal Leonard

Evernote for Mac 6.9 Beta 2 Released

Idea

Hi everyone,

The Mac client team is  pleased to announce the release of Evernote for Mac v6.9 Beta 2. 

As per usual, if you find an issue or have feedback on one of the new features, please let us know in a reply to this post.

You can download the new version here or from within the app. Please note that betas are available to users of the Direct Download version of Evernote, and are not available to users of the Mac App Store version.

Thanks and happy beta testing!

Version 6.9 Beta 2

New:

  • We’ve limited support for 6.9 to OS X 10.10+.
  • You can now search for Google Drive documents by title.
  • The share bar is now included in the sticky note header.
  • We’ve switched the behavior so Evernote is launched automatically on startup. You can modify this from Preferences.

Fixed:

  • Users can edit shortcuts if they replace the default shortcut in Preferences > Shortcuts.
  • Shortcuts for inserting date and time have been fixed.
  • Various crash and data sync issues.
  • Like 2

Share this post


Link to post

44 replies to this idea

Recommended Posts

  • 0
Just now, Chantal Leonard said:

We’ve switched the behavior so Evernote is launched automatically on startup. You can modify this from Preferences.

Just my 2¢ here - don't do this for upgrades, just new installs. I think it is a good idea overall, but I personally prefer my machine to boot as soon as possible and EN launches so fast when i get around to it, I don't need it running at boot/login.

  • Like 4

Share this post


Link to post
  • 0

Problem report: Editing links in notes fails; note display text is replaced by new URL

[This is a repeat report of a problem I noted with 6.9b1.]

Steps to reproduce:

1. Select text in a note; Format/Link/Add... (command K) menuchoice; type or paste URL or Evernote note link; press return or OK button.

Result: selected text is now underlined/blue if URL or green if Evernote link, and clicking on it goes to the linked object. (As expected, :)).

2. Select the text from step 1 (underlined/blue); Format/Link/Add... (command K) menuchoice; select URL (as entered from step 1), edit the URL or paste in a new one; press return or OK button.

Result: the link display text that was selected previously is replaced by the new URL or Evernote link, which becomes an active link. The formerly displayed text is gone. :(

Expected result: the link display text should remain unchanged and the new or edited URL or Evernote link should be active.

Implication: in 6.9b2 it is impossible to edit a link without destroying the displayed text. :angry:

 

  • Like 1

Share this post


Link to post
  • 0

Problem report: Sticky titles of notes do not word wrap if they are too long for the window width

As reported for 6.9b1. Just saying... they did before 6.9b1 I think....

Share this post


Link to post
  • 0
5 hours ago, Chantal Leonard said:

The Mac client team is  pleased to announce the release of Evernote for Mac v6.9 Beta 2. 

Thanks for the update.

Has this BUG been fixed:

 

Share this post


Link to post
  • 0

My OCD is killing me. The top border of the sort bar is still concealed in this beta. I think you should just move the sort bar 1px downwards. See screenshots for a better idea of the glitch.

 

glitch.png

fixed.png

  • Like 1

Share this post


Link to post
  • 0
On August 8, 2016 at 5:45 PM, DTLow said:

I don't know if this is an error introduced by the new beta version; I noticed a sync problem with tags updated on notes.

I removed a tag from various notes on my Mac.  Later, I noticed these notes hadn't syncd

I also submitted Ticket# 1767963

edited: I isolated this error to tag changes for multiple notes using the Mass Change feature

 

10 hours ago, JMichaelTX said:

Thanks for the update.

Has this BUG been fixed:

Confirmed - the issue has been resolved with mass changes to the tags not syncing

Share this post


Link to post
  • 0

The new Beta has removed the shortcuts from the sidebar, how do I get that feature back?

Share this post


Link to post
  • 0
16 minutes ago, cdspine said:

The new Beta has removed the shortcuts from the sidebar, how do I get that feature back?

Screen Shot 2016-08-17 at 9.24.27 AM.png

Share this post


Link to post
  • 0
17 hours ago, EdH said:

Just my 2¢ here - don't do this for upgrades, just new installs. I think it is a good idea overall, but I personally prefer my machine to boot as soon as possible and EN launches so fast when i get around to it, I don't need it running at boot/login.

 

This may be just for new installs or reinstalls. I upgraded to the latest beta and have my settings to where I need to open it on login. Checked last night and when I rebooted the Mac it stayed the same. I am running the public macOS beta so not sure if that would prevent it from following the open at login protocol but for me it stayed the same which is nice.

Share this post


Link to post
  • 0
55 minutes ago, Sayre Ambrosio said:

This may be just for new installs or reinstalls. I upgraded to the latest beta and have my settings to where I need to open it on login. Checked last night and when I rebooted the Mac it stayed the same. I am running the public macOS beta so not sure if that would prevent it from following the open at login protocol but for me it stayed the same which is nice.

Yes, I installed this morning and while the preference is there, it wasn't turned on, so the note is just a bit misleading.

  • Like 2

Share this post


Link to post
  • 0

Got this upon upgrading...  

Evernote_for_Mac_6_9_Beta_2_Released_-_Mac_Product_Feedback_-_Evernote_User_Forum.jpg

 

Just saw why - If the download fails, this is the release that gets downloaded --> Evernote_RELEASE_6.8_453748

Edited by lindseycholmes

Share this post


Link to post
  • 0
Just now, lindseycholmes said:

Got this upon upgrading...  

Evernote_for_Mac_6_9_Beta_2_Released_-_Mac_Product_Feedback_-_Evernote_User_Forum.jpg

Check if you have more than one Evernote app on your machine.

I experienced this when an upgrade installed the new app, but failed to delete the old app

Share this post


Link to post
  • 0
1 minute ago, DTLow said:

Check if you have more than one Evernote app on your machine.

I experienced this when an upgrade installed the new app, but failed to delete the old app

I had the .dmg file but not another installation. I just downloaded from above and reinstalled. Thanks!

Share this post


Link to post
  • 0

Hi, 

I just changed my install to the new beta (yeah I backed up my notes)
I was interested in checking out the code feature - I like that it has a shaded box, but the code still formats like normal text.
Is this a finished feature (i.e. from a previous version) or is this part of the beta?

Cheers,
Jeff 

Share this post


Link to post
  • 0

Hello jeffkranenburg,

I use the code block feature with Evernote for Mac (6.8).
In the settings under software updates I can activate the checkbox to activate code block.

Did you meant the code block feature ?

code_block.jpg

Share this post


Link to post
  • 0
On 8/18/2016 at 10:46 PM, Jay Wang said:

On 6.9 Beta 2 this bug is till present.

Hi @Jay Wang; I've split this off from this topic so our dev team is aware of this issue on the beta:

Thanks!

  • Like 1

Share this post


Link to post
  • 0
7 hours ago, greoj said:

Hello jeffkranenburg,

I use the code block feature with Evernote for Mac (6.8).
In the settings under software updates I can activate the checkbox to activate code block.

Did you meant the code block feature ?

code_block.jpg

Hi Greoj,

Yes that is what I mean and I also have it ticked, but this is how it appears in my notes

This is when I type it directly into Evernote - when I do a copy / paste job, it formats it correctly.
You can see that I have a capital letter in Var and the quotes are smart quotes, not code quotes.

I appreciate that Evernote is not a code editor, but is it meant to be like that? So should I use it for copy / paste?

 

Cheers,

Jeff

Screenshot 2016-08-21 08.36.00.png

Share this post


Link to post
  • 0
14 hours ago, jeffkranenburg said:

This is when I type it directly into Evernote - when I do a copy / paste job, it formats it correctly.
You can see that I have a capital letter in Var and the quotes are smart quotes, not code quotes.

I appreciate that Evernote is not a code editor, but is it meant to be like that? So should I use it for copy / paste?

Hi Jeff,

I think this is the behavior of the spell checking. Looks like an autocorrect feature.
In Evernote there are menu points under Edit > Grammar and Spelling (i use german layout - so that is my translation of the menu points).
You can check or uncheck the spelling feature.

I think when you uncheck the spelling feature your problem should be gone.

I hope that works for you.

Share this post


Link to post
  • 0

Pretty unhelpful error message - how am I meant to know which note is causing the error? I've deleted the most recent and I'm still getting the same thing.

 

Any clues before support open up?

Screen Shot 2016-08-21 at 13.18.16.png

 

Edit...

Seems like there are service problems - took over an hour for the status page to say so...

Still the error message is pretty useless

 

  • Like 1

Share this post


Link to post
  • 0

Multi-selecting notes and then selecting move to Notebook Trash does...erm...nothing.

Share this post


Link to post
  • 0

Hi,

I noticed two issues

1) Syncing: Attachments of notes get deleted when you don't wait long enough until attachment was fetched from the cloud and you selected a different note in the meantime. I submit a ticket 1784227.

2) Editable Attachments cannot be edited / changed. Preview.app says PDF cannot be changed and wants to save a copy. Issues seem to happen only with latest MacOS Beta 10.12 Beta 5.

I am a user of Evernote with two Mac, OS 10.11.6 and OS 10.12 Beta 5, DE Version 6.9 Beta 2 (453896 Direct)

 

Share this post


Link to post
  • 0

I discovered a very weird behavior today with 6.9b2. I had not tried this with previous versions so I don't know when it was introduced.

While playing with my keybindings today, I removed the keybinding for "Paste to Evernote" as shown in the attachment. After doing this, I find that the "a" key (without any modifiers!) gets bound to this action, so I can't type anything, as soon as I type an "a", Evernote gets brought to the front and a new note with whatever I have in the clipboard gets created.

I didn't realize immediately what had triggered this problem, so I initially restarted my session and rebooted my machine, and the condition persisted. After quitting Evernote or reassigning the binding, the problem goes away. I can reproduce this at will just by removing the keybinding.

This is clearly a big problem, I hope it can be solved by the next release - thanks in advance!

My system: Evernote Version 6.9 Beta 2 (453896 Direct), Mac OS X 10.11.6 (15G31).

Preferences.jpg

Share this post


Link to post
  • 0

Export All Notes gone???

Running 6.9 beta 2 and see no way to Export All Notes now.  I have it on my other mac in 6.8

Actually, I figured out how to get the option back.  I had to turn off 'New Notebook View" in Preferences.  You got yourself a bug :)

Edited by Cherice B
Update

Share this post


Link to post
  • 0
2 hours ago, Cherice B said:

Export All Notes gone???

Running 6.9 beta 2 and see no way to Export All Notes now.  I have it on my other mac in 6.8

Actually, I figured out how to get the option back.  I had to turn off 'New Notebook View" in Preferences.  You got yourself a bug :)

New Notebook View is turned on here and I just did a full export no problem.

  • Select the Notes section in the left pane
  • select any note in the note view
  • CMD-A to select all notes
  • File|Export

 

Share this post


Link to post
  • 0

I see that. However, it's not intuitive. With the old notebook view, you just clicked Notebooks on the left, then could right-click anywhere on the right pane and click Export All Notes. I don't really fancy waiting for it to select my 9,000+ notes via CTRL-A

Share this post


Link to post
  • 0
34 minutes ago, Cherice B said:

 I don't really fancy waiting for it to select my 9,000+ notes via CTRL-A

I have a Macbook with 16,500+ notes and CMD-A takes about 1.5 seconds. Maybe. Uphill. Against the wind. With a flat tire.

Wait. I just tested it. I overestimated how long it would take. It is way less than what I said.

  • Like 1

Share this post


Link to post
  • 0
34 minutes ago, Cherice B said:

To each their own, Ed....

Indeed. Just make your decision an informed decision, knowing that CMD-A to select all notes is nearly instantaneous and not a reason no to use it.

Share this post


Link to post
  • 0

Dear Friends at Evernote, 

I have two weird Table issues.    Version 6.9 Beta 2 (453896 Direkt)

First of all, I select the Text in the first cell and drag over to the last cell to select all content in the first row, but the selection only shows all the other cells (when I click "Bold" though, all text including the first cell is formatted). 

Bildschirmfoto 2016-08-29 um 11.04.18.jpg

The other strange thing happened when I triple-click a cell to select all text and press Cmd-X (or select Cut), or hit delete - it pastes the content of the next cell. I would expect the cell content to be deleted without the next cell flowing left.

Bildschirmfoto 2016-08-29 um 11.04.50.jpg

 

Also please read my rant regarding printing. Pretty please!

https://www.evernote.com/l/ABEBH84zArFC55J3N65y68SnZYDFuvHbS-I

 

Regards, Chris.

Share this post


Link to post
  • 0

I'm having some troubles with images.

The mac client show them with wrong proportions (stretched):

Screen-Shot-2016-08-29-at-2.57.33-PM.jpg

The same does not occur in EN for Web:

Screen-Shot-2016-08-29-at-2.57.08-PM.jpg

Share this post


Link to post
  • 0
On 8/23/2016 at 1:36 AM, Michael Sch. said:

1) Syncing: Attachments of notes get deleted when you don't wait long enough until attachment was fetched from the cloud and you selected a different note in the meantime. I submit a ticket 1784227.

What do you mean "when you don't wait long enough until attachment was fetched from the cloud:"?

It would be helpful if you were to list a series of steps that will reproduce the problem.

Share this post


Link to post
  • 0
On 8/29/2016 at 2:10 PM, gmbstn said:

I'm having some troubles with images.

The mac client show them with wrong proportions (stretched):

Screen-Shot-2016-08-29-at-2.57.33-PM.jpg

The same does not occur in EN for Web:

Screen-Shot-2016-08-29-at-2.57.08-PM.jpg

I have reproduced this problem. 

If you try to resize the image, however, you will find that it will snap back to the correct aspect ratio.

 

  • Like 1

Share this post


Link to post
  • 0

there are still issues with advanced date searches that work on my PC but NOT ON MY MAC!!!

This is the search that I can run successfully on my PC but not my Mac

notebook:"Actions Pending" tag:phone -reminderTime:day+1

Can you please fix it?

Also can you please add the ability to add the columns for "reminder time" and "reminder done" for the Mac version?

 

Share this post


Link to post
  • 0

Has anyone had issues opening encrypted PDF files? I am testing using PhantomPDF from Foxit to encrypt PDF files (on WIndows) and then seeing what works in Evernote.

The 128bit encryption works fine, but when I try to open a 256bit encrypted file, Evernote 6.9b2 crashes. It opens fine on Evernote for iOS, and I can open the file in Preview on my Mac and that works as well. Evernote gives a spectacular crash.

I've attached the crashdump, and sent it in via the crash dump box wth the following text:

eh20160905

Opening a PDF file that is encrypted. It opens fine in Evernote for iOS and in Preview on the Mac.

 

Share this post


Link to post
  • 0
On September 2, 2016 at 11:06 PM, wb said:

I have reproduced this problem. 

If you try to resize the image, however, you will find that it will snap back to the correct aspect ratio.

 

This is horrible on the Mac. None of my images look good. this is just a bad rendering on the mac overall. PDFs are fine, but images are very distorted. Images look fine on iOS and Windows.

Share this post


Link to post
  • 0

1. images are a mess, as reported above.

2. text entry in note title sometimes works ok, and sometimes doesn't, apparently because syncing starts and changes (like spaces or letters typed) get forgotten. i think i reported this a few years back, so either it has been there all along (i mainly use ios) or it is back again.

Share this post


Link to post
  • 0

Using the code formatting, it likes to change my code.  Here are a couple examples.  

  • Apostrophes-
    • Right:'
    • Wrong:‘ ’ 
  • Quotation marks-
    • Right: "
    • Wrong: “ ” 
  • Double dashes-
    • Right: --
    • Wrong: —

Share this post


Link to post
  • 0
On 9/3/2016 at 8:06 AM, wb said:

I have reproduced this problem. 

If you try to resize the image, however, you will find that it will snap back to the correct aspect ratio.

 

I've also noticed this problem. Slightly resizing the image fixes it, but it's very annoying.

Share this post


Link to post
  • 0

I have the same issue with the aspect ratio of images taken with the Evernote app on my iPhone. When these photos are viewed on my iPhone, the aspect ratios are fine, however, when viewed on my mac, the aspect ratio is all messed up. I've been a premium Evernote user in the past, however, for me this is a fundamental feature/workflow in my Evernote usage. If Evernote lets such an issue persist I would have a hard time becoming a paid customer again.

Where's Evernote's input on this? Are they even paying attention?

 

Screen Shot 2016-09-28 at 9.15.30 PM.png

Share this post


Link to post
  • 0

Same problem for some images (freshly clipped from Chrome) on Windows 10 Evernote Beta 6.7.5576. Yes, it's annoying.

For me cut/paste of the image worked as a temporary workaround.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...