Jump to content
MEPES

Firefox Crash of Firefox after Ubuntu upgrade 14.04 > 16.04

Recommended Posts

Couldn't get object: TypeError: Components.classes[cid] is undefined
Couldn't get string: closeAndStopPicking
in installToolbarItemconsole.error: rapportive-amo: 
  DEPRECATED: Module 'sdk/page-mod/match-pattern' is deprecated use 'sdk/util/match-pattern' instead
Traceback (most recent call last):
  File "resource://gre/modules/Promise-backend.js", line 937, in Handler.prototype.process
    nextValue = this.onResolve.call(undefined, nextValue);
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 87, in startup/</<
    run(options);
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 147, in run
    let program = main(options.loader, options.main);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 768, in main
    return loader.load(loader, module).exports;
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 79, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 331, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 279, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://rapportive-at-rapportive-dot-com/rapportive-amo/lib/main.js", line 3, in null
    var { MatchPattern } = require("match-pattern");
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 607, in require
    return _require(id);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 653, in _require
    freeze(load(loader, module));
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 79, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 331, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 279, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://gre/modules/commonjs/sdk/page-mod/match-pattern.js", line 8, in null
    deprecateUsage("Module 'sdk/page-mod/match-pattern' is deprecated use 'sdk/util/match-pattern' instead");
  File "resource://gre/modules/commonjs/sdk/util/deprecate.js", line 18, in deprecateUsage
    let stack = get().slice(2);
ERROR console.error: web_clipper: 
  Unsupported OS
  Linux
ERROR console.error: web_clipper: 
  Cannot load native lib
ERROR console.error: web_clipper: 
  Unsupported OS
Vector smash protection is enabled.
ExceptionHandler::GenerateDump cloned child 5831
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[NPAPI 5817] ###!!! ABORT: Aborting on channel error.: file /build/firefox-aTzZgw/firefox-47.0+build3/ipc/glue/MessageChannel.cpp, line 2027
[NPAPI 5817] ###!!! ABORT: Aborting on channel error.: file /build/firefox-aTzZgw/firefox-47.0+build3/ipc/glue/MessageChannel.cpp, line 2027

 

Share this post


Link to post

Hi.  Sorry but Ubuntu: not my skill set.  Firefox: not our remit.  Don't know if we can comment much on this...

Share this post


Link to post

Looks like your processor isn't compatible with the native component needed by Web Clipper.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...