Jump to content
Xiver

Line Spacing and Remove Formatting

Recommended Posts

I have a problem where when I copy or clip a note from a web page that it sometimes has inconsistent line formatting, especially annoying for recipes.  I tried using the remove formatting and simplify formatting options, but neither works.

 

Does anyone have any suggestions?  The only solution I could find to this problem was to copy out the entire note into notepad delete the note and recreate it and past the text in from notepad.

Share this post


Link to post

Hi.  Welcome to the curse of HTML formatting.  There are various different ways to lay out a page online,  and Evernote makes a (usually) pretty good guess of how to transfer that into a note.  But the codes are still hidden amongst the visible text.  Remove formatting should take them out,  but taking the codes away completely can also affect the layout. 

You could try 'Paste and Match Style' when you save the page initially - that's (kind've) 'paste as plain text'.  It's also possible to clip a screen shot (with serious limitations if your content is bigger than one screen) and let Evernote's OCR handle the content.  In that case I'll also add a 'smart' (ie decriptive) title and maybe tags so I can find the page again easily.

I clip some pages online by highlighting a portion of text and clipping the selection,  then go back to highlight and clip again,  pasting in each case with the 'match formatting' option.  It takes a little longer,  and -in that situation- I always paste images separately.

Copy and paste into Notepad will ensure that absolutely any non-character codes are gone,  and copy and paste back will give you absolutely 'pure' text-only copy.

If the notepad version is better than applying 'remove formatting' to a note,  please consider reporting it to Evernote as a bug: 'remove' should take out all formatting,  but apparently with some pages it is not.  Include the URL of the page you're copying from,  as well as a copy/ public-share URL of the resulting note.  You (probably) won't get any response,  but it may help improve the 'remove formatting' operation somewhere down the line..

Share this post


Link to post

Hi, I have seen other entries which where forwarded to this one. However it is not fully answered here:

My main issue is the spacing between two lines of text. In word processors etc. You can change this by selecting 1.1x, 1.5x line height and dramatically enchances readibility. In Evernote, lines of text are crammed with each other. Is there any way to change this? If not, can I make a feature request?

Same can be said for spacing after paragraphs.

Thanks

Share this post


Link to post

Line spacing exists as a feature request. You can go there and click the up arrow near the top of the page to vote in favor of it:

 

  • Like 2
  • Thanks 1

Share this post


Link to post
On 14/10/2017 at 10:51 AM, ssxtrix said:

Hi, I have seen other entries which where forwarded to this one. However it is not fully answered here:

My main issue is the spacing between two lines of text. In word processors etc. You can change this by selecting 1.1x, 1.5x line height and dramatically enchances readibility. In Evernote, lines of text are crammed with each other. Is there any way to change this? If not, can I make a feature request?

Same can be said for spacing after paragraphs.

Thanks

I had the same problem where I was not able the remove the paragraph spacing between each line. I found an easy way to get through it without a little playing around.
Copy the entire text that has the spacing.
create a few fresh lines and paste it there. 
Back space so that the second line goes on the same line as the first line 
Example1.0 First Line
Second Line
Example 1.1 First Line Second Line
Then just press enter so it makes a fresh line - this solved it for me.

Hope it helps until remove formatting is an option.

Share this post


Link to post

I've also seen one suggestion (sorry I don't know who it was from) that applying numbers or bullets to some lines,  then removing the numbers/ bullets,  reverts the text to standard single spacing.  Works for me...

Share this post


Link to post
1 hour ago, krigsmakten said:

What?  There is NO way to manage linespacing?  

Not with the Evernote editor.
You are able to use ofther editors and store the documents as note attachments.  
Most word processing apps support line spacing; I use Word/Pages

Share this post


Link to post

Ugh, I've just run across this problem

 

Even putting the text into a plain text editor and then pasting back into the note gives me the first line being BOLD, a large space to the next line and then normal spacing after that. The note contains PDFs so changing the whole note to plain text doesn't work because that deletes the PDFs.

I rue the day...

Share this post


Link to post
On 5/7/2018 at 4:08 PM, ooMikeoo said:

Ugh, I've just run across this problem

 

Even putting the text into a plain text editor and then pasting back into the note gives me the first line being BOLD, a large space to the next line and then normal spacing after that. The note contains PDFs so changing the whole note to plain text doesn't work because that deletes the PDFs.

I rue the day...

Hi.  Did you try pasting into a new note?  There may still be some formatting left in the old one...  The PDF files could be exported to your desktop and then re-attached as necessary...

Share this post


Link to post
On 5/7/2018 at 8:08 AM, ooMikeoo said:

Ugh, I've just run across this problem

 

Even putting the text into a plain text editor and then pasting back into the note gives me the first line being BOLD, a large space to the next line and then normal spacing after that. The note contains PDFs so changing the whole note to plain text doesn't work because that deletes the PDFs.

I rue the day...

What sometimes works for me: copy from the first character, not the first line, to the end of the last character (not line). Then select all, delete everything, then paste.

It appears that the paragraph marks before and after the stuff I care about are the problem makers. I can't select them directly, but I can avoid them...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...