Jump to content
sasilk

Can't delete tags from previously shared notebook

Recommended Posts

Hi,

 

I dropped a shared notebook that I was following, and have noticed that I still have a couple of tags from it remaining in my Tag View. This is the only place they exist. They are not in

  • The Tag List in the sidebar
  • My Evernote web account
  • Either of my iOS device clients

Things I have tried:

  • Right-click and select Delete Tag (I get a dialog saying that I can't because it's in a Shared notebook)
  • Drag the tag to the Trash (Adds the tag to my Shortcuts)
  • Select the tag and press Backspace (No effect)
  • Select the tag and press Delete (No effect)
  • Create a temporary tag, drag the unwanted tags to it so that they're nested and then delete the parent tag (Deletes the parent and puts the unwanted tags back where they were)
  • Close and restart Evernote and repeat all of the above (Same results)
  • Close all instances of Evernote (Desktop, web, and iOS), restart Desktop and repeat all of the above (Same results)
  • Sign out of Evernote, sign in again and repeat all of the above (Same results)
  • Search the forums and web for suggestions (Found all of the above, but nothing useful unless I was using a Windows client. And a statement that this would be fixed in "an upcoming update" which was a year old.)

The only thing I haven't done (which I know would fix it) is to rename my database and download it from the server again. (I have no Local notebooks) I'm reluctant to do this due to the sheer size of the database and the time and bandwidth it would take. Plus this seems a rather nuclear option for an issue that, frankly, shouldn't have occurred in the first place if Evernote removed shared notebooks correctly. 

Have I missed anything that might work? Or is this yet another known bug that is being ignored while they mess around with the interface repeatedly?

Thanks,

Stephen

 

  • Like 1

Share this post


Link to post

Not a single response? I know (from the forums here) that I'm not the only person experiencing this. Is it the fact that I went through a proper troubleshooting checklist that eliminated anything that might have shown that it wasn't a bug that's stopping Evernote from responding?

 

Share this post


Link to post
1 hour ago, sasilk said:

Not a single response? I know (from the forums here) that I'm not the only person experiencing this. Is it the fact that I went through a proper troubleshooting checklist that eliminated anything that might have shown that it wasn't a bug that's stopping Evernote from responding?

You might want to contact Evernote support and open a ticket       Contact Evernote Support

Share this post


Link to post
On 5/11/2016 at 0:14 PM, sasilk said:

Things I have tried:

  • Right-click and select Delete Tag (I get a dialog saying that I can't because it's in a Shared notebook)
  • Drag the tag to the Trash (Adds the tag to my Shortcuts)
  • Select the tag and press Backspace (No effect)
  • Select the tag and press Delete (No effect)
  • Create a temporary tag, drag the unwanted tags to it so that they're nested and then delete the parent tag (Deletes the parent and puts the unwanted tags back where they were)
  • Close and restart Evernote and repeat all of the above (Same results)
  • Close all instances of Evernote (Desktop, web, and iOS), restart Desktop and repeat all of the above (Same results)
  • Sign out of Evernote, sign in again and repeat all of the above (Same results)
  • Search the forums and web for suggestions (Found all of the above, but nothing useful unless I was using a Windows client. And a statement that this would be fixed in "an upcoming update" which was a year old.)

I just discovered that I am having the same issue. However, this did not occur with another shared notebook. While tags for one shared notebook were deleted, the tags from the other one are not getting deleted. I tried the steps you tried and still did not manage to delete them. I am using Evernote for Mac - Version 6.8 (Direct).

Share this post


Link to post
2 minutes ago, ChiragC said:

I just discovered that I am having the same issue. However, this did not occur with another shared notebook. While tags for one shared notebook were deleted, the tags from the other one are not getting deleted. I tried the steps you tried and still did not manage to delete them. I am using Evernote for Mac - Version 6.8 (Direct).

I have a ticket open for it - I suggest you do the same.

Share this post


Link to post
3 hours ago, sasilk said:

I have a ticket open for it - I suggest you do the same.

 

3 hours ago, ChiragC said:

I just discovered that I am having the same issue. However, this did not occur with another shared notebook. While tags for one shared notebook were deleted, the tags from the other one are not getting deleted. I tried the steps you tried and still did not manage to delete them. I am using Evernote for Mac - Version 6.8 (Direct).

@sasilk, I've followed up on your ticket and it looks like this issue has been escalated to our Technical Support team so they can investigate what might be causing this issue. Thanks for reporting this and for your patience in working with us through this.

@ChiragC I don't see an open ticket from you regarding this issue, but when you get an opportunity to submit one you can let me know the number here and I will be happy to follow up on it for you!

Share this post


Link to post
5 hours ago, BSR said:

 

@sasilk, I've followed up on your ticket and it looks like this issue has been escalated to our Technical Support team so they can investigate what might be causing this issue. Thanks for reporting this and for your patience in working with us through this.

Thanks. I was aware that it had been escalated. I had a very quick response to my ticket by Ellen G, who kept me up to date until she handed it on.

Share this post


Link to post
On 8/21/2016 at 10:39 PM, BSR said:

@ChiragC I don't see an open ticket from you regarding this issue, but when you get an opportunity to submit one you can let me know the number here and I will be happy to follow up on it for you!

Ticket #1786497

Share this post


Link to post
1 hour ago, ChiragC said:

Ticket #1786497

Thanks for following up with me. I grabbed your ticket and went ahead and sent you some steps to try. Let me know how it goes in the ticket. I look forward to your response!

Share this post


Link to post
On 8/22/2016 at 3:09 AM, BSR said:

 

@sasilk, I've followed up on your ticket and it looks like this issue has been escalated to our Technical Support team so they can investigate what might be causing this issue. Thanks for reporting this and for your patience in working with us through this.

 

Hi,

It's been 2 months since my ticket regarding this issue was escalated - has there been any progress? Given that it was reported and acknowledged over a year ago I would have hoped to hear something by now, but the silence has been deafening (as it has been with every report of this problem here on the forums). Is this actually being looked at? Or are new features still more interesting than old bugs?

Stephen Silk

Share this post


Link to post

I've been trying to get the same issue resolved, it drives me nuts because I organize Evernote by tags and these random shared tags kind of mess things up. Sometimes when I try and create a new tag it will default to uppercase because one of the random shared tags is in uppercase which I typically never do. Come on Evernote, how hard can this be? I won't even accept new shared notebooks now because of this :(.

 

Share this post


Link to post

It sounds like you use Evernote in a similar way to me Steve, and you're having the same issues I am.

As you can see above, I followed up on this back in October but still haven't heard anything and the issue is still outstanding. My suspicion is that, since there's a workaround for it in the Windows client, it's considered "only a Mac issue" and so not of any great importance. Not because it's Mac specifically, but because the Mac user base is much smaller, and there are likely to be fewer resources allocated to it in terms of developers and testers.

Stephen Silk

 

Share this post


Link to post

Hi @sasilk and @steve.anderson,

It looks like this is still an open issue with our developers. I don't have an ETA on a fix currently.

In the meantime, do the shared tags appear in your Tags list on the web?

If they do not appear on the web and you haven't already done so, try force syncing the Mac application.

To force the Mac application to sync all of your notes from the server, follow these steps:

1. Open Evernote for Mac

2. Hold the **Shift** and **Option** keys on your keyboard and click the sync wheel (next to your username)

3. Depending on the number of notes in your account, the amount of time it can take for the force sync to finish will vary.

Please allow the application to complete the sync process before continuing to use the application.

  • Like 1

Share this post


Link to post

Thanks for your suggestion BSR and willingness to help. I've tried it and it unfortunately made no difference.

You might want to read my initial report on this at the beginning of this thread. It's been an open ticket since August and a known issue by the development team for at least a year before that.

Stephen Silk

Share this post


Link to post
3 hours ago, sasilk said:

Thanks for your suggestion BSR and willingness to help. I've tried it and it unfortunately made no difference.

You might want to read my initial report on this at the beginning of this thread. It's been an open ticket since August and a known issue by the development team for at least a year before that.

Stephen Silk

Hi Stephen,

Thanks for your follow up. I definitely saw your comment at the beginning of this thread. Our development team is still working on a fix for this. I don't have a firm date but I will make any updates available here as I receive them. 

Let me know if there's anything else I can do in the mean time.

Share this post


Link to post

Nearly 6 months since the last update and year after the issue was reported there's no sign of resolution of this annoying bug :blink:.

 @BSR Do you have an update for us?

  • Like 1

Share this post


Link to post
6 hours ago, arunone said:

Nearly 6 months since the last update and year after the issue was reported there's no sign of resolution of this annoying bug :blink:.

 @BSR Do you have an update for us?

It looks like our developers have implemented the fix for this and it is currently scheduled to come out in one of the version 6.12 updates. I don't have a firm date or version number I'm able to provide.

Do the tags appear when logging into your account from the web at evernote.com? If not, the force sync steps I posted above should resolve the issue. Please let me know how this works out for you.

Share this post


Link to post
8 hours ago, BSR said:

It looks like our developers have implemented the fix for this and it is currently scheduled to come out in one of the version 6.12 updates. I don't have a firm date or version number I'm able to provide.

Do the tags appear when logging into your account from the web at evernote.com? If not, the force sync steps I posted above should resolve the issue. Please let me know how this works out for you.

If you had read the thread you would see that, firstly, I detailed in the very first post where these tags do and don't appear, and secondly, the reasons many of us don't want to force a sync. As a couple of examples, sheer size of the data to be downloaded on slow links and with limited data caps, local folders, and others. And really, the problem shouldn't have even occurred in the first place, and waiting almost three years (and counting) for a real fix is ludicrous.

stephen Silk

Share this post


Link to post

Hi there,

This thread is old but I'm having the same issue and cannot figure out what the fix is. I also cannot seem to submit a ticket, which is strange.

Can someone help me resolve this issue? I have like 50 unused tags from my past employer's previously shared notebook.

Thanks!

Mike

 

@BSR

Share this post


Link to post
4 hours ago, theroyaltannenbaum said:

Hi there,

This thread is old but I'm having the same issue and cannot figure out what the fix is. I also cannot seem to submit a ticket, which is strange.

Can someone help me resolve this issue? I have like 50 unused tags from my past employer's previously shared notebook.

Thanks!

Mike

 

@BSR

Hi Mike,

 

There is no fix, at least for Macs. We have to wait for Evernote to fix the problem. They've been promising a fix in "an upcoming release" for over three years now.

 

there is apparently a workaround for Windows users - you can find it here in the forums.

Share this post


Link to post
51 minutes ago, sasilk said:

There is no fix, at least for Macs. We have to wait for Evernote to fix the problem. 

There was a question - Do you see the same problem using the web platform?

If the problem is restricted to your Mac,  my solution would be to delete the database and let it be rebuilt from the servers

or BSR's forced sync solution at

 

  • Like 1

Share this post


Link to post

Please read the entire thread (which I started) before making suggestions that have been made multiple times before.

it is *not* a problem with "just my Mac", it is reported across all platforms, including the web. It has been acknowledged as a bug by Evernote - they just haven't fixed it yet. There is a workaround for Windows, but not for other platforms.

 

Share this post


Link to post
32 minutes ago, sasilk said:

Please read the entire thread (which I started) before making suggestions that have been made multiple times before.

Actually you said "The only thing I haven't done (which I know would fix it) is to rename my database and download it from the server again"

Maybe you're not willing to help yourself but others might benefit from these suggestions

Share this post


Link to post

I also wrote, fyou'll check, that there were specific reasons that I can't take that course. And, more importantly, while that might fix my individual problem it does nothing to address the root cause.

Share this post


Link to post

I'm having the same issue ofvUnable to delete tags from shared notebook. The owner of the notebook has deleted the tags on their end because they no longer use them. (started ticket# 2182497)

Share this post


Link to post
On 07/12/2016 at 4:39 AM, BSR said:

Hi @sasilk and @steve.anderson,

It looks like this is still an open issue with our developers. I don't have an ETA on a fix currently.

In the meantime, do the shared tags appear in your Tags list on the web?

If they do not appear on the web and you haven't already done so, try force syncing the Mac application.

To force the Mac application to sync all of your notes from the server, follow these steps:

1. Open Evernote for Mac

2. Hold the **Shift** and **Option** keys on your keyboard and click the sync wheel (next to your username)

3. Depending on the number of notes in your account, the amount of time it can take for the force sync to finish will vary.

Please allow the application to complete the sync process before continuing to use the application.

Thanks @BSR. This worked

  • Like 1
  • Thanks 1

Share this post


Link to post

An update for anyone that is still experiencing this issue, as I am. 

I opened Ticket# 2537317 on this issue on 27 May 2018 (~4 months ago) even though this thread was started almost 2.5 years ago (As is typical of Evernote, development effort is put into developing new buggy and, often not requested, features while the existing functionality remains infested with bugs). After performing all manner of technical gymnastics, including two complete deletions (right through the bowels of MacOS) and rebuilds of Evernote on multiple Macs and different Evernote accounts, with the issue returning every time, I pleaded with Evernote to concede the issue MUST be in their application and/or server code and not something client or account related as they were so desperately trying to convince me. At this point I was so hoping that they might finally show some care factor and get onto investigating the root cause starting with some serious troubleshooting of the gazillion log files that I so kindly provided them. After countless hours of apathy and resistance from Evernote who claimed they could not replicate the issue (I doubt they even tried to be frank), I bit the bullet and did their job for them. I wrote up the following procedure to replicate the issue and sent them a narrated video so there could be no crack for them to slip out of:

------

BUG REPLICATION PROCEDURE
 
Scenario 1: Person A can create a tag in Person B's account that they cannot delete
Clearly, one user should not be able to permanently impact another users account configuration like this.
  1. Person A creates tag <Test Tag A>
  2. Person A adds <Test Tag A> to a note in a notebook they created and have shared TO Person B
  3. Allow note to sync
  4. Person A deletes <Test Tag A> from their account
  5. Sync note again and confirm that <Test Tag A> remains in Person B's account even though it has been deleted from the shared note.
  6. The orphaned <Test Tag A> in Person B's account correctly shows a "0" count but Person B cannot delete this tag.
 
Scenario 2: Person B can prevent Person A from deleting a tag that they created
Clearly, one user should not be able to permanently impact another users account configuration like this.
  1. Person A creates tag <Test Tag B>
  2. Person A adds <Test Tag B> to note in a notebook shared TO Person B
  3. Allow note to sync
  4. Person B moves note into a notebook that Person B created and has shared TO Person A
  5. Allow note to sync
  6. Person A deletes the <Test Tag B> from their account (and receives warning that the tag is in a shared account).
  7. <Test Tag B> is removed from the note in Person A's account that Person B shared with them HOWEVER, the note is not deleted from Person A's account. <Test Tag B> is now showing in Person A's account with "0" count (i.e. it is orphaned).
  8. Person A again attempts to delete this orphaned <Test Tag B> but is unable to do so with the message appearing again that the tag is in a shared note (even though it is not in the shared note in Person A's account.
  9. Person A now has no way of deleting this orphaned tag <Test Tag B>
  10. Person B is also unable to delete <Text Tag B> from their account with the same experience as outlined in steps 6-9

------

After passing through the various internal hoops and hurdles I was delighted to hear back that they were able to replicate the issue and had scheduled it to be fixed in the next development sprint.

The next release came. No fix, Then the next. Still no fix. What's going on I asked .... and then it came. The apology and the confession that, in fact, it was not being worked on AND the "product director" had bumped it in favor of "other priorities". There was now no commitment to fixing it, at all. THIS BUG HAS BEEN AROUND FOR AT LEAST 2.5 YEARS, HAS NO MANUAL FIX OR WORK AROUND, IS A RIGHT PITA AND IT GOT BUMPED IN FAVOR OF UPDATING THE SHAPE OF MADS' TRUNK AND THE SHADE OF GREEN IN THE EVERNOTE BRANDING. Way to go Evernote!!! Leading by example by showing all of us long term loyal customers "How to Focus on what really matters" - NOT .

To add salt into the wound, and the prompter for me to write this post, I checked on the status of the ticket in my account yesterday to discover that IT HAS BEEN MARKED AS "RESOLVED" EVEN THOUGH IT ISN'T - I STILL CANNOT DELETE THE EFFECTED TAGS. I cannot fathom what corporate culture/performance management/software dev process promotes this as the right thing to do.

This whole saga demonstrates EXACTLY why the Evernote business is failing. There are some very good people at Evernote (such as my contact in the support team who is diligent and professional at all times) but they are sadly let down by a management team that simply don't get it. The recent departure of the Evernote's executive team is a welcome sign but I wonder why the person that hired them, and managed their performance (or lack thereof), hasn't left with them. Doesn't the buck stop with them? Doesn't the fish rot from the head?

I've given up hoping Evernote will improve. Right now I am just hoping that it gets acquired ... by Atlassian. Evernote's existing customers and staff deserve that class of management. It's nice to dream.

Share this post


Link to post

Well, so much for the "a fix has been implemented and will be released in one of the 6.12 releases" comment a while back, seeing that we're on 7.2 now now, with no sign of any action. And Stuart G has just confirmed that it isn't being worked on, and probably never will be. Lies, damned lies, and Evernote Support.

Fortunately I no longer have the problem, having bought a new Mac and needing to download my database again. But that does nothing for the people out there who still have this issue (and now look like they always will).

Stephen Silk

 

  • Like 1

Share this post


Link to post
17 minutes ago, sasilk said:

Fortunately I no longer have the problem, having bought a new Mac and needing to download my database again

It seems this bug has many forms because I have tried multiple database rebuilds across different computers and accounts. The troublesome tags just keep coming back and cannot be deleted which is why I have suggested it must be something server side. Deleting the troublesome tags via the web version gives the appearance of success but they aren't actually deleted on the Mac client app. Sync it up and the web version shows them again ... arrrgh.

I could live with the old tags if they were only just visual polluting of my tag list. The real frustration is that they keep showing up in the tag autocompletion which is very annoying and disruptive. ?

Share this post


Link to post

The tags didn't show up in my web account, or on my mobile devices - only on my Mac. So creating a new database from the server worked for me. I suspect the issue may depend on how far the corruption has gone.

There's a suggestion further up about a forced sync which has worked for some, but of course it won't work if the tags are on the server and on the client. But it might be worth a try - all you have to lose is some time and bandwidth.

 

Stephen Silk

 

 

  • Like 1

Share this post


Link to post
3 hours ago, sasilk said:

There's a suggestion further up about a forced sync which has worked for some, but of course it won't work if the tags are on the server and on the client. But it might be worth a try - all you have to lose is some time and bandwidth.

Thanks for the suggestion but that was tried long ago without success. Even Evernote have conceded they don't have any workarounds or further things to try which is all the more reason it galls me that they won't prioritise a fix. 

For kicks I'd suggest following my bug replication procedure above so you can see the exact issue I have experienced BUT PLEASE DON'T or you will have introduced some tags that you won't be able to delete also.

Share this post


Link to post

Yet another update to advise that the latest version of Evernote for Mac (v7.6) STILL does not fix this issue.

The underlying bug in the code still exists that allows tags to be created that cannot be subsequently deleted (refer above replication procedure).

Evernote support were again asked for an update with the usual boilerplate reply. Here are some edited highlights ...

"I hear your frustration and I've discussed with our product manager again today to see if it can be resolved soon."  >  I've lost count how many times this has been said.

"I'll keep you posted on any changes to the status of this issue."  >  In other words, "you'll never hear from me again unless you follow me up".

"Again, my apologies that it's taken so long!" > It speaks volumes about Evernote's lack of commitment to a quality that after all these years they aren't utterly embarrassed to keep repeating such meaningless apologies.

So while the core functionality continues to fall apart, Evernote continue to focus on meaningless non functional UI changes like Dark Mode and transparent side bars * sigh * ... It is little wonder that the Evernote business is going down the toilet.

Share this post


Link to post

They have a workaround for their main customer base (Windows), so as far as they're concerned it's fixed. Mac users are second-class citizens to Evernote. I was explicitly told (on this forum) that it had been fixed and would be implemented in one of the 5.12 release. That was obviously an outright lie, since we're at 7.6 and no change. Maybe they meant for the Windows version?

i suspect that boilerplate is an Evernote template it’s used so often.

  • Like 1

Share this post


Link to post

Another update. Release 7.7 for Mac has been made and it contains those very critical updates to Dark Mode that we all, apparently, have been waiting for. However, IT  STILL DOES NOT CONTAIN A FIX FOR THIS BUG. Here is some of the feedback I have received to my further enquiries as to why this latest release again neglected this bug .. can you see a trend here?

"I reviewed the ticket and confirm that there hasn't been any updates" > No ship Sherlock. Thanks for telling me what I already know.

"The referenced ticket hasn't been closed. Our tech support will provide you an update when there are any changes to the status of this issue. Our development team is now working on this problem and trying identify the root cause to implement a fix for a future update."  > This is not the first time they have said that they are actively working on it, only to find out later that it was a complete lie. Perhaps I am just being too demanding, the bug has ONLY been around 4 years after all. 

"thanks for your honest feedback. I'm happy to pass this along to our product team" > That old chestnut. I think this is called "passing the buck". I've lost count for the amount of times I have received this entirely meaningless, and utterly unhelpful comment from Evernote Support. It is Evernote code for "I'm shifting this from my responsibilities to a part of the organisation you can't interact with directly so that hopefully you just give up".

HOWEVER ... I have been advised an ETA will be sent to me. Any Dev team worth their salt wouldn't take long to give such an estimate (particularly given the amount of times they say they have been actively working on this) so let's see if something is provided in the next week. Fair to say that if it takes any longer than a week then it was just another lie, consistent with Evernote's culture of being more concerned with how they look instead of how they actually are.

Share this post


Link to post

Two releases later and we are now up to Release 7.9 with no fix in sight. The new CEO, who was all guns blazing with enthusiasm for helping us "fall in love again" with Evernote is now MIA and has failed to follow up on his promises to look into this matter. Not even as much a rough idea as to when resources will be allocated.

So, I bit the bullet, again, and went the double nuclear option and not only uninstalled and revoked all my Evernote clients (Mac, iOS) but also for those of family members who I had shared notes with. After hours of work uninstalling, re-installing and reconfiguring 8 client apps over three accounts I can finally report that the troublesome tags that have been polluting my tag list have finally disappeared. After 24 hours they have not reappeared.

So, while I have managed to work around this issue at a significant loss of productivity, the underlying issue is still present - sharing notes with tags can lead to them becoming undeletable (is that a word!?). Clearly the client side database is not designed properly and it would appear from the ongoing apathy to this issue, including from Ian Small, that this is never going to be fixed.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...