Jump to content
johnnyb138

ANSWERED Images from camera save as black images

Recommended Posts

Hi! When taking a photo with the evernote camera, the images initially look just fine and the thumbnail looks fine (first image), but after hitting okay the images save as blank images that are just black (second image). Any help in resolving this issue is greatly appreciated! 

Phone: Sony Xperia z3 Compact
Android version: 6.0.1
Build: Z3 Compact Marshmallow concept latest (MMB29M.Z1.3555-somc) 

Thanks!

Screenshot_20160331-141117.jpg

Screenshot_20160331-141124.png

  • Like 1

Share this post


Link to post

Hello @johnnyb138,

Thank you for posting and welcome to the forums. Did this start after the update to Evernote 7.7 on Android?

Share this post


Link to post

Hi Matt,

I'm not sure exactly when it started. I haven't used the camera scanner in about 2-3 weeks, so sometime between now and 2-3 weeks ago. I am running version 7.7 right now though. Should I try an older version?

John

Share this post


Link to post

Hi Matt,

I just installed version 7.6 and can confirm the camera works fine again. For now I'll continue to use the old version while you work on the bug. Thanks for the tip!

John

Share this post


Link to post

When Evernote upgraded to 7.7 on my Android, LG G3 the document camera now produces only a solid black image. Uninstalled. Restarted phone. Downloaded a new Evernote install. Still the same thing. The camera itself works because it will take photos w/in Evernote and post to a note.

Been using Evernote to scan and organize docs for a couple of years now. No probs until now. 

Long-road solution: Use CamScanner, save as a jpeg, then share with Evernote. :-/

Share this post


Link to post

Hello, 

I just want to report the same issue that I have started to notice with the beta2 version of 7.5. Versions 7.5.1 and 7.6 did not cause this issue. 

7.5 beta 2 and 7.7 versions have the new scanning functionality unlike 7.5.1 and 7.6 versions. 

On 7.7 version the picture is black unless saved as image or raw. All other formats end up with a black picture. 

Phone: Oneplus one / Android 6.0.1

Thanks in advance for your help. 

Ago

Share this post


Link to post

I have export the same problem after updating on Android to version 7.7.

Seriously affected workflow.

Sent logs to Evernote support and they are looking into the problem but no time on a fix.

 

 

Share this post


Link to post

Version 7.7.1 does not solve this issue I am afraid. 

Would be appreciated if someone from Evernote could let us know about this issue as it had been opened for a week without any acknowledgment of this being taken care of.  What about the promise to have quick support being premium account? 

  • Like 1

Share this post


Link to post
1 hour ago, August1 said:

Version 7.7.1 does not solve this issue I am afraid. 

Would be appreciated if someone from Evernote could let us know about this issue as it had been opened for a week without any acknowledgment of this being taken care of.  What about the promise to have quick support being premium account? 

Hi.  If you've raised a support request,  please post the ticket number here and we can get someone to look into it for you.  If you're referring to the posts here,  this is a user-supported forum and volunteers tend to be available as and when we have time free...

Evernote employee @Matt W. who posted here a few days ago,  is presumably looking into the issue - I'm sure he'll get back to us as soon as there's any progress..

  • Like 1

Share this post


Link to post

Hello all,

Thanks for hanging in there with us. We have seen multiple reports of this on a range of Android devices. The team is currently looking into what is causing this. I will keep you posted once I get more information.

In the meantime, you are able to use the default camera application on your device to capture the images and then attach them to your notes using the "Add to Evernote" option from the share menu of the image.

  • Like 1

Share this post


Link to post
16 minutes ago, gazumped said:

Hi.  If you've raised a support request,  please post the ticket number here and we can get someone to look into it for you.  If you're referring to the posts here,  this is a user-supported forum and volunteers tend to be available as and when we have time free...

Evernote employee @Matt W. who posted here a few days ago,  is presumably looking into the issue - I'm sure he'll get back to us as soon as there's any progress..

Thanks for the clarification, I indeed thought I was logging a bug by posting messages. I have therefore logged a ticket #1546998 before Matt could answer.

@Matt W.  feel free to let us know if we can help by providing logs or anything else.

Cheers.

Augustin

  • Like 2

Share this post


Link to post

Hi @August1,

Thank you for the ticket and I have sent instructions to obtain a log to your email provided with the ticket. From there we will further look into the cause of this.

Share this post


Link to post

Hey, y'all. I didn't have time to read every little post above this morning, but I see a lot of mention of the Evernote update.

With me, it was immediately after my phone went from Lollipop to Marshmallow. Did anyone else experience that? 

  • Like 1

Share this post


Link to post

Having the same issue here. All black images. Any word on a fix or what's causing the issue. I just started using evernote and love it so far. Considering a premium account if you can get this bug fixed.

Share this post


Link to post

Hello all,

Thank you all for posting. The team is on top of this right now and should be corrected in the next release. In the meantime you can still use the the stock camera application on your device and attach the images or you can disable the "Activate Multi-shot" option in the Camera Settings in Evernote and use the stock camera for the images. This is a workaround in the meantime. I will let you all know when I hear more.

  • Like 1

Share this post


Link to post

Fyi: Disabling the 'activate multishot'  option for does not seen to work on my phone.   Began seeing this behavior after Marshmallow Android update was pushed to my phone - is this some kind of permissions issue ? 

  • Like 1

Share this post


Link to post

Hi @brightrock,

Hmm. How long ago did you install the Marshmallow update?

The camera issue that people are experiencing is related to the application update itself and is not believed to have to do with the application permissions, as no permissions changed with the update from 7.6.1 to 7.7.

  • Like 1

Share this post


Link to post

Looks like a coincidental collision between two issues.   Resetting my android theme seems to have fixed several other problems and now the 'Disabling multishot'  workaround works for me, but the other problem remains so.  

 

I'll wait for the next Evernote app update and assume that it's just a coincidence that I first noticed this right after the Marshmallow update yesterday. 

  • Like 1

Share this post


Link to post

Fyi I have raised ticket #1546998 related to this issue so that Evernote team could investigate. 

Latest news is that a fix should come with version 7.8 that is tested right now prior to  release 

  • Like 1

Share this post


Link to post

I'm also seething this issue with documents, post-it and business cards. (1+ One running Android 6.0.1, CM 13 - Dragon Fruit 4,  Evernote 7.7.1) 

Share this post


Link to post

I also have this problem and it still exist after the latest update.

Motorola G Android 6.0 (patch 1 jan 2016)

Is there any plan to get it fixed?

I was also wondering if it might have connection with another issue as they arrised simultaneously ; After the new ability in Lollipop to use SD card as internal storage Evernote has been regulary chrashing saying that theres is a database error and or error with the card.

 

 

Share this post


Link to post

The workaround of deactivating multi-show works for me. I'm using Samsung S5 with Android 6.0.1.

Share this post


Link to post

Hello all,

Evernote 7.8 is currently in testing and will be released to correct this. Once it is released, please let me know if you still experience this.

  • Like 1

Share this post


Link to post

Hi Matt,

I'm running Evernote 7.8 on my Moto G and I'm still having issues with the camera integration. I try to take a picture of a document and I'm using the camera in automatic mode. Now the picture is taken automatically but it is not recognized as a document. So I try to change the value of the "Save as" dropdown box to "Document" but after I did that the picture turns black. The same thing happens when I choose "Color Document" or "Post-It". 

Are you guys aware of this issue? Would be great to have this working again. Let me know if you need any more information or log files from me.

Regards,

Felix

Bild.1.jpg

Bild.2.jpg

Bild.3.jpg

Share this post


Link to post

I have got the same problem. When I scan a document the small picture in the corner is black (and also the final result). When I take a picture with the camera, the small picture is normal, but the final result is again a black picture. 

Phone: OnePlusOne, Android 6.0.1 Evernote 7.7.1

Share this post


Link to post

Testing Evernote 7.8.1
Still have this problem (sadly)

Phone: OnePlusOne, Android 6.0.1 Evernote 7.8.1

Share this post


Link to post

Hi all,

I have the exact same issue on a OnePlus One running Android 6.0.1 Evernote 7.7.1!

Thanks,

Share this post


Link to post

Hello all,

It has been a bit since I posted an update on this and wanted to keep you guys up to date. We are working on some pretty cool stuff for the 7.8 update and is in the last part of testing and will be released really soon. Once it has been released I will post again to see if any of you are still encountering the issue with camera.

  • Like 1

Share this post


Link to post

Same problem.

OnePlusOne, Android 6.0.1 Evernote 7.7.1

ETA on the fix?

Do I need to request a trouble ticket?

thanks..

 

Share this post


Link to post

Same issue on OnePlus One running Android 6.0.1 Evernote 7.7....

where could we install previous version 7.6?

Share this post


Link to post

Hey folks,

We are working on rolling out the update for 7.8 (7.8.2). Please check the Google Play Store for the update over the few days and see if you continue to see black image captures in Evernote.

If you still see them, please list the device name, Android version, and version of Evernote installed.

  • Like 1

Share this post


Link to post

Hi Matt,

Everything is working very well at Beta 7.8.2

Thanks to the development department (and your support ;) 

 

  • Like 1

Share this post


Link to post

Still the same for some reason :( The camera makes a photo, but when I select "Document" (or any other options), the picture turns black.

Sony Xperia Z3 Compact, Android 6.0.1, Evernote 7.8.2

All is the same as reported above:

On 4/30/2016 at 5:07 PM, Felix R. said:

 

 

Any help appreciated!

Share this post


Link to post
On 5/25/2016 at 6:31 PM, AMalakhov said:

Still the same for some reason :( The camera makes a photo, but when I select "Document" (or any other options), the picture turns black.

Sony Xperia Z3 Compact, Android 6.0.1, Evernote 7.8.2

It's really magic: all fixed itself today after Xperia System update!

Share this post


Link to post

I'm still experiencing the black image if I try to save it as a document. I don't see any option to update my Evernote version in the Play Store either.

LG G3, Android 6.0, Evernote 7.8.1

Share this post


Link to post

I'll leave this here for anyone else who is experiencing the issue. Even though the play store said that Evernote was installed on my device and didn't show me the option to update I clicked on the installed button and choose my LG G3. The app installed itself and is now version 7.8.2 and most importantly the doc camera works properly again.

Share this post


Link to post

@AMalakhov, That is great to hear it is now working.

@hoonin_hooligan, Welcome to the forums and thank you for posting. Is this problem only happening when you switch the image type after the capture and does it go back to normal when selecting the original capture type?

Share this post


Link to post

I'm using evernote 7.9.2 with sony z3 6.0.1, same problem, black image when saving as documents, it's really annoying as I need to use another app to scan and share to evernote

Share this post


Link to post

Hi @magician18,

I would recommend submitting a support ticket by clicking on the link in my signature and a member of our support team will reach out to you for further information on this so we can see what could be the cause.

Share this post


Link to post
On 6/23/2016 at 3:17 AM, magician18 said:

I'm using evernote 7.9.2 with sony z3 6.0.1, same problem, black image when saving as documents, it's really annoying as I need to use another app to scan and share to evernote

Also on 7.9.2. On a Samsung Galaxy 5 (Android 6.1)

Also having the black image problem whenever I try to save as a document or a business card.

Share this post


Link to post

I have the same problem.
Samsung Galaxy S5, Android 6.0.1, Evernote 7.9.3.

Share this post


Link to post

Noticing that several of these were happening on Samsungs with Android 6, I did a quick test, and I don't seem to be having the problem. Hopefully the support tickets will get it fixed, but for the benefit of other users, I wonder if @Bryan Sullo or @Gauthier could indicate the circumstances under which the problem occurs.

  • Like 1

Share this post


Link to post

Evernote 7.9.3 - Samsung Galaxy S5 - Android 6.0.1

Plus to add note, Camera, Snap picture, shows up in gallery fine, switch to save as "Document", Processes, 100% black rectangle. Sad Panda.

Love Evernote, love little notebooks, hope this gets resolved so I can combine workflows :)

Share this post


Link to post

Exactly the same issue with the camera function. Image on screen goes black as soon as you select document. This issue appears to have a long history going by this thread.

Share this post


Link to post
On 8/15/2016 at 11:47 AM, NetizenX said:

Evernote 7.9.3 - Samsung Galaxy S5 - Android 6.0.1

Plus to add note, Camera, Snap picture, shows up in gallery fine, switch to save as "Document", Processes, 100% black rectangle. Sad Panda.

Love Evernote, love little notebooks, hope this gets resolved so I can combine workflows :)

 

On 8/18/2016 at 11:01 AM, Roseberryrose said:

Exactly the same issue with the camera function. Image on screen goes black as soon as you select document. This issue appears to have a long history going by this thread.

I'm a little lost. How do you "switch to save as 'Document'," or "select document"? For me, I can tap the icon in the upper right corner to switch between Manual and Automatic (document-capturing) mode, but I never see an option to select or save as document.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...