Jump to content
BrianN

Account Billing & Support

Recommended Posts

I've been a premium member for a year and got an email offering me 18 months for a 12 month subscription if I signed up before a certain time.

I did this but got charged full amount and then did not get the 6 months added.

Sent an email, logged a support email through my account but 2 days later.....NOTHING!!

 

Not happy. 

 

Anybody else had similar experience??

Share this post


Link to post

Several questions on this,  turns out the advertised offer was for new customers only.  If you have a ticket number for your support request,  please post it here and we can flag this for an Admin to look at if you wish...

Share this post


Link to post

No ticket number - I sent a quey via my account and also sent an email to billing and subscriptions. 

It did not indicate new accounts....and funnily enough why did I get 3 emails offering this in the week that my subscription was du to expire.

 

Not happy with this so please can you direct me how to get a refund?

Appalling customer comms - why has it took 2 days for a response and only whn posted on here?

Share this post


Link to post

Didn't know you could send queries in any other way than a support ticket - submit one by choosing "payment issue" in the first dropdown after logging in here > https://www.evernote.com/SupportLogin.action

You'll get an instant (or fairly quick) acknowledgement and ticket number - post that here and we can get an admin to have a look at the issue for you.

Premium / Business users also have access to a Chat option (7am-7pm PST weekdays) - click 'continue' on the support page after logging in.

Share this post


Link to post

Thanks 


Ticket# 1331853
 
If somebody form admin could please take a look and either arrange a refund, the extra 6 months, or downgrade to Plus and refund the difference.
I'd already been considering terminating and this offer was wgat made me re-sign :(

Share this post


Link to post

OK - flagged;  hopefully you'll get a quick(ish) response...  (I'd guess things are busy after the holiday weekend)  ;)

  • Like 1

Share this post


Link to post

Hi Brian--I've escalated this in our queue and a representative will you sorted in short order.

  • Like 3

Share this post


Link to post

I have a problem that is almost similar.

I have a premium subscription but keep getting deactived and sent to basic because of my business account.  The business account setup is confusing.  I paid for members and removed them then my business account was canceled..... i lost weeks of data and information.  I talked to Billy J from support and she said that I could get access to filesand that I will have to sign up with my business account and can do it on credit.  I did do that but never did get my lost data back.  I kept trying. I also ended up not canceling the Business account.  Never had the employees to be charged and now I am being billed for the entire year $600 and never used it.  Never would have resigned up either if it was not suggested for me to get my files.  

I need my premium account back.  I paid for it for one year and its not been a year yet.  Please Help!!!! I am disappointed.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...