Jump to content
goodforenergy

Undo reverts typing instead of autocorrection

Recommended Posts

I am trying to use Evernote to store some notes in MÄori. Unfortunately, as there is no dictionary I can install to type in MÄori, this means a lot of the words I type are marked as incorrect by the Mac built in spellchecker.

 

More frustratingly, the autocorrection will change MÄori words into English ones, but if I hit undo, instead of reverting the autocorrection as it usually does, Evernote reverts my typing of the word.

 

You can see this in action here, where I'm trying to add the word "pepeha" at the beginning of the sentence. I type it, it autocorrects to "pepper", I hit "undo" and it removes the whole word.

 

This is driving me crazy, but I don't want to turn off autocorrect system wide in Mac just to fix the issue. Any help appreciated :)

Share this post


Link to post

Hi.  Not a Mac user,  so I can't offer any suggestions there,  but if the system spell checker seems to be a problem,  you could look to see if they've got MÄori as an additional option..

 

Workarounds if that's not possible -

  1. do your writing in another app that supports the language - or at least where you can turn off checking - and then copy/ paste the text into Evernote,  or just attach the app file to the Evernote note.
  2. have a look at the Evernote translation program - here - even if you're not a native speaker,  joining the program might allow you to build up another dictionary that won't challenge your spelling...
  3. Google "word processing in MÄori" (without the quotes) to see if there are any other useful options available - like a web-based service - to create documents in that language.

We do have some Mac user advisors around here who may be able to add something more later...

Share this post


Link to post

Hi gazumped,

 

Thank you for your creative suggestions. Unfortunately there is no MÄori dictionary for Mac. They do allow installation of dictionaries but I can't find a MÄori dictionary in the format they require.

I think I'll have to go with typing first in another application, as you suggest. Not ideal though - hopefully this could be considered as a bug and looked into in the future..

 

Thanks!

  • Like 1

Share this post


Link to post

You're welcome - sorry I couldn't help.  There's another couple of options I thought of too that may or may not be viable -

 

Auto correct systems in Windows underline misspelt words and if you right-click,  offer the option to correct/ ignore/ add to dictionary.  I don't think that's available in Mac,  but it's already a feature request from another user. 

 

In Mac's you have powerful scripting options - that are out of my expertise,  but maybe someone who's more familiar could suggest a way to use them to maintain your spelling options.

 

There's also AutoHotKey - a scripting app that can repeat standard keystrokes,  and various text expander apps that will insert a whole word from an optional code - type #M forinstance to get MÄori.  (Whether that would trick the spelling software I don't know!)

 

Using another app for your typing is certainly the quick and easy fix for the moment though...

 

;)

Share this post


Link to post

Evernote just uses Apple's dictionary so you can turn off auto-correction in the system preferences.   Go to Keyboard / Text and uncheck "Correct spelling automatically".  I hope this helps.  Also it looks like Apple supports adding other dictionaries so it might be possible to add a the language of your choice.

Share this post


Link to post

Hi Software Marcus. Thanks for your message, but as I said in my original post, I don't want to turn off auto-correct system wide. I also mentioned in my second post there is no MÄori dictionary available.

 

I think this behaviour is a bug that should be addressed in Evernote.


 

Share this post


Link to post

This is just a stupid behavior of Evernote and even independent of your special language problem. Typing some more technical words in a more common language yields the same. Other people are saying the same. Here, a bug was reported and the Evernote team seems to deem the behavior "normal". Try firing up the OS X TextEdit App and do the same there. Autocorrect is undone correctly... I am afraid these are the usual insufficiencies of the Evernote text editor. Maybe the new CEO with his focus on core features will help with this one...

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...