Jump to content
iRock1

ANSWERED Evernote notes aren't showing up in Spotlight results

Recommended Posts

It used to be that when I searched something in Spotlight, the results included my Evernote notes. That's no longer the case, at least using the latest release of Yosemite and Evernote.

Is this an acknowledged bug in Evernote, something on the Apple side or just me?

Share this post


Link to post

@iRock1 -  This has been an issue in the past but we implemented some fixes a number of versions ago. There are a few things I'd like you to check if this is still an issue for you:

 

  1. If you installed the desktop app via the Mac App Store, try switching to the direct download from Evernote.com. Instructions are on our KB: https://evernote.com/contact/support/kb/#!/article/24422932
  2. If you are still seeing the same issue after switching to the direct download, try a Spotlight rebuild by performing the following steps in Evernote: (Edit: Apologies, I originally provided the wrong instructions) 

1. Hold down the Option key on your keyboard and hover over "Help" on the top menu bar

2. Mouse over "Troubleshooting" on the dropdown menu that appears 

3. Select "Recreate Spotlight Search Index"

 

If this still doesn't resolve your issue, please submit a support ticket, post the ticket number here and we can take a look.

 

 

  • Like 2

Share this post


Link to post

 

@iRock1 -  This has been an issue in the past but we implemented some fixes a number of versions ago. There are a few things I'd like you to check if this is still an issue for you:

 

  1. If you installed the desktop app via the Mac App Store, try switching to the direct download from Evernote.com. Instructions are on our KB: https://evernote.com/contact/support/kb/#!/article/24422932
  2. If you are still seeing the same issue after switching to the direct download, try a Spotlight rebuild by performing the following steps in Evernote: (Edit: Apologies, I originally provided the wrong instructions) 

1. Hold down the Option key on your keyboard and hover over "Help" on the top menu bar

2. Mouse over "Troubleshooting" on the dropdown menu that appears 

3. Select "Recreate Spotlight Search Index"

 

If this still doesn't resolve your issue, please submit a support ticket, post the ticket number here and we can take a look.

 

 

 

 

Hi,

 

I followed the instructions that you provided earlier (I didn't read your update in time). I removed Evernote (which was originally installed via the App Store), then installed it again using the image available on the website. Then I rebuilt the Spotlight database using the method published earlier.

 

Not sure if removing Evernote in first place was absolutely necessary though, but now it works as it should.

 

Thank you.

  • Like 1

Share this post


Link to post

 

This has been an issue in the past but we implemented some fixes a number of versions ago. There are a few things I'd like you to check if this is still an issue for you:

 

Version 6.2.1 (452715 App Store).

Should OS-X Spotlight be working Ok in this (App-Store) version? 

Or is it still necessary to make the switch over to Direct download?

 

Also, what causes this problem -

And are there any other significant differences between the two forks?

 

Thanks.

Share this post


Link to post

Funny, I have the opposite request -- I would like the option to exclude notes from Spotlight indexing. I've created a separate thread for this.

Share this post


Link to post

 I have tried the fixes above as well as entering the following terminal commands: 

Turn off spotlight:

sudo mdutil -a -i off

Unload it:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Load It:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Turn on spotlight again:

sudo mdutil -a -i on

 

The terminal commands worked to force spotlight reindex but Evernote results are still not showing. I have submitted support ticket  # 2470717.

Share this post


Link to post

I, too, have discussed with Evernote support. In my last correspondence with them (March 5) they indicated "we are currently aware of this issue, and although no ETA of when it will be resolved, I can assure you we're working diligently to fix it"

FWIW, I am using the direct download version

Share this post


Link to post

Hi, OP back here three years later.

The Spotlight index is working for me under El Capitan. However, I see all my notes duplicated. For instance, one of them displays a copy called p540.enspot (all of them follow this convention, with p followed by a three digit number and the .enspot extension).

What's going on this time?

Share this post


Link to post

Ever since I upgraded my work and home MBPs to High Sierra (macOS 10.13), Spotlight only seems to index the titles of my notes, I can't search for their contents. None of the tricks and workarounds recommended on these forums helped me, Evernote support told me it was a known issue and they were working on it.

Today I spent some time (again) troubleshooting this issue after installing Evernote 7.2.2 from scratch, got lucky and could fix it. I share it here in hopes that it can be useful to others:

  1. Launch Terminal and change directory to (replace <id> below as necessary):
    cd ~/"Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/<id>/localNoteStore/"

  2. Create a symlink to ../content:
    ln -s ../content/ content

  3. Re-index files  (replace <id> in the command below as necessary):
    mdimport ~/Library//Containers/com.evernote.Evernote/Data/Library/CoreData/com.evernote.Evernote/<id>/ENNote/_records

  4. Wait until done. You might see some dyld warnings about paths being ignored.

Now your notes should  (hopefully) be properly indexed in Spotlight. If this didn't work for you, try this other fix on Jens Willy's website: http://jenswilly.dk/2015/10/fixing-evernote-and-spotlight-indexing/#comment-3757837.

Why is the symlink necessary? After following the instructions in Jens Willy's blog post, mdimport failed with lots of warnings:

Quote

I/O warning : failed to load external entity "~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/158389171/localNoteStore/content/8DF0B990-3982-4651-ADB5-3ED1B0DA2977/content.enml"

I/O warning : failed to load external entity "~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/158389171/localNoteStore/content/3DB2A236-EAE4-4F88-9CE2-031B3914C912/content.enml"

I/O warning : failed to load external entity "~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/158389171/localNoteStore/content/527877F5-BACF-4087-B431-B5E2632AF9E7/content.enml"

That's because mdimport was trying to access a non-existing folder. The symlink fixes that.

I hope this helps,
Jaume

 

  • Thanks 1

Share this post


Link to post

@jaume, first off... THANK YOU for posting. This problem continues to plague me and significantly impacts my daily workflow. I appreciate you posting.

Unfortunately, I’m blindly following the steps in your post and the Jens Willy blog post. Not working for me.

In his first step he instructs to run mdimport to show spotlight indexers. He goes on to state there should only be one and it should be in the application bundle. I do only have one entry, but it is: /Applications/Evernote.app/Contents/Library/Spotlight/EvernoteSpotLightImporter.mdimporter

I left that alone and continued on with his other step (#4) to run  mdimport /Users/username/Library....  This was after I added the symlink per your instructions.

When I run the mdimport command I simply see series of I/O warnings...

“failed to load external entity “/Users/<my user name>/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/<my account number>/localNoteStore/content/<record guid>/content.enml

Any suggestions on other steps I should take? Thanks again for helping an Evernote friend in great need!  :-). — jay

 

edit (FWIW)... I just scrolled to top of the listing for the mdimport command execution. As Jens Willy posted in one of his responses, I also received 3 dyld warnings related to LC_RPATH “@executable_path/.... being ignored in restricted program because of @executable_path”.

Share this post


Link to post

@jayelevy You're welcome! The warnings you see are the same warnings I got before I created the symlink. Is the symlink in the localNoteStore folder, and did you create it with "ln -s"?

This is what it looks like on my end:

$ pwd
~/Library/Containers/com.evernote.Evernote/Data/Library/Application Support/com.evernote.Evernote/accounts/www.evernote.com/158389171/localNoteStore
$ ls -l
total 7768
-rw-r--r--@ 1 llj  staff   794624 Jul 11 13:16 LocalNoteStore.sqlite
-rw-r--r--@ 1 llj  staff    32768 Jul 12 12:57 LocalNoteStore.sqlite-shm
-rw-r--r--@ 1 llj  staff  2377272 Jul 12 12:57 LocalNoteStore.sqlite-wal
lrwxr-xr-x  1 llj  staff       11 Jul 12 10:41 content -> ../content/
$ file -h content
content: symbolic link to ../content/

Can you post the contents of your localNoteStore folder and the output of "file -h content"?

 

 

Share this post


Link to post

@jaume, where is your tip jar??? ?  Thanks for the nudge in the right direction... I created the symlink based on the Jens Willy post, not yours. I re-worked to create the correct symlink (to point to content) and it worked!!

I really am sincerely grateful to you for taking time to post here and to respond to my question. 

I'm perplexed why the Evernote team has been so slow to fix. Nonetheless, I seem to be back (finally) in working order.

again... my thanks to you -- jay

Share this post


Link to post
13 hours ago, jaume said:

Spotlight only seems to index the titles of my notes, I can't search for their contents.

1715876508_ScreenShot2018-07-12at12_12_34.png.f86fca09703e3eb79969a98bab81cfca.pngTo rebuild the spotlight search index

Select the Help Menu while holding down the option key
select Troubleshooting > Recreate Spotlight Search Index

Share this post


Link to post
43 minutes ago, DTLow said:

To rebuild the spotlight search index

@DTLow that option does not resolve the problem. At least in my environment. That was one of the first things I tried when the problem first appeared.

I've had an open support ticket with Evernote for some time to resolve the issue. Of course, early in the troubleshooting they too suggested this (and other) steps. They've since acknowledged the issue and have said a fix is pending.

Fortunately, the steps described by @jaume have resolved my issue. 

Share this post


Link to post
Quote

To rebuild the spotlight search index

@DTLow That didn't help me either, and, if I understand it correctly, now it is clear to me why. The Recreate Spotlight Search Index menu item recreates the Evernote Note metadata files located in this folder:
~/Library//Containers/com.evernote.Evernote/Data/Library/CoreData/com.evernote.Evernote/<id>/ENNote/_records/
(which works nicely) and requests Spotlight to re-index them. And that last part fails in the same way "mdimport" failed in my tests: there is a path mismatch that prevents Spotlight from indexing the metadata.

I hope Evernote can look into it, find out what the root cause is, and finally fix it.

@jayelevy I'm glad Spotlight is working for you too! 

Share this post


Link to post

In case it helps anyone, I had this problem after blowing out my `$HOME/Library/Application Support/com.evernote.Evernote/` folder to fix a different sync issue. I was left with thousands of orphan  `p###.enspot` files that were linked to the "wrong" account. These showed up in Spotlight, but couldn't be opened and popped up the error box below when clicked on:

image.png.3325288a163bb7153e69b05ac3575ba2.png

To fix it, here's what I did:

1. Quit Evernote + Clipper completely
 
2. Go to EN's CoreData folder:
~/Library/CoreData/com.evernote.Evernote/
 
3. Delete each folder you see there - they will have GUID names - bunch of random numbers+letters (subfolder /ENNote/_records/ are where the p###.enspot files are...)
 
4. Relaunch Evernote and then hold OPTION while clicking the Help menu
 
5. Choose Database > Rebuild Spotlight Index
 
6. Leave EN open during this process, which could take quite a long time...
 
There's no indication that it's complete, just check Activity Monitor and see when mdworker CPU usage goes back down to normal.
 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...