Jump to content
barry.hemphill

Bug: Note title disappears, replaced with first line of note body

Recommended Posts

Using Evernote 5.8.14.8221, Windows 7 x64

 

When I create new notes and set a title, the title is repeatedly replaced by the first line of text from the body. I did a bit of troubleshooting and it is reproducible.

 

To reproduce this: create a new note, start typing in the body of the note and wait a few seconds until Evernote auto-saves the note without setting the title for the first time (just let Evernote set the title itself. Then type something in the title, hit enter to return to the body and wait for the next auto-save. The title reverts to the original auto-set title.

 

It doesn't happen 100% of the time, but I believe it happens 100% of the time the first time I set the title. If I set the title repeatedly it will eventually stay.

 

It doesn't sound like that bad of a bug but it is surprisingly annoying, especially when I've typed a fairly long title a few times and still loose it.

 

 

  • Like 3

Share this post


Link to post

Agreed; this has happened to me many tens of times over many months, right up to the present. It violates a basic UX principle -- don't throw away user input without warning.

  • Like 1

Share this post


Link to post

v5.9.6.9494 (277494)

Still happening. I've seen it a lot lately.

Just happened again. I've been working in a note, and initially the title was set to the first line in the note.  After an hour of working in the note (a lot of cutting and pasting from other places), I decided that the note should have a title of my own choosing.  After about 8 words into the title, Evernote cleared what I had typed and replaced it with the first line of the note again. Gaaaah!!!  This is irritating.

I imagine a workaround might be to set the note to a single character and hit enter, and make it stick, and maybe evernote won't mess with the title anymore and try to automatically set it from the first line anymore. Then I might be safe to type away to give it the title that I want and it won't wipe it out on me. Clearly a bug that needs to be fixed. Anybody report this one to customer support?

 

  • Like 1

Share this post


Link to post
On 12/27/2015 at 11:59 PM, jdmarch said:

Agreed; this has happened to me many tens of times over many months, right up to the present. It violates a basic UX principle -- don't throw away user input without warning.

 

Agreed with you, but I don't think this was intentionally designed to to this. I think it's a bug that is causing it. It wasn't like this before.

Share this post


Link to post
On 1/5/2016 at 8:53 PM, mds386 said:

Agreed with you, but I don't think this was intentionally designed to to this. I think it's a bug that is causing it. It wasn't like this before.

Agreed. (Who would ever intentionally design software to work this way?) My point was simply that this is not a "merely cosmetic" bug, to be fixed at leisure, but rather something which seriously intrudes on user workflow.

Share this post


Link to post
32 minutes ago, jdmarch said:

Agreed. (Who would ever intentionally design software to work this way?) My point was simply that this is not a "merely cosmetic" bug, to be fixed at leisure, but rather something which seriously intrudes on user workflow.

Ah, I see. I didn't mean my reply to sound like I wasn't agreeing with you. This is a problem, and I hope it gets fixed soon as well.

Share this post


Link to post
1 hour ago, mds386 said:

Ah, I see. I didn't mean my reply to sound like I wasn't agreeing with you.

Not at all. All good! :)

Share this post


Link to post

I get this bug a lot as well. It's particularly annoying for me as I'm not a great touch typist so generally look at the keyboard when typing. What tends to happen then is that the title I am typing will be replaced by the default and my typing continues from the start of the note title which is a bug in my book

  • Like 1

Share this post


Link to post

This scribe is not being 'driven up the wall' (maybe Google's new car can do that?) but the inexplicable and sudden disappearance of text in the note title appears to be a software design fault, the persistence of which is mildly irritating. While one is typing the title, hitting 'Enter' before it is finished seems to save what's so far there, but obliges a return to the same place to complete it. Perhaps an Evernote employee could give subscribers some guidelines, if fixing the root cause of the problem is not yet within reach? 

Share this post


Link to post

Updated to v6.0.x and it's (tentatively) looking like this bug had been fixed!

What's New in the 'Evernote for Windows 6.0 (6.0.4.1688) GA Release Notes' says: The note title no longer clears itself at unexpected times.

Thank you Evernote!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...