Jump to content

Recommended Posts

Hello.

 

I am in a Windows environment at work, using OS X at home and iOS8 in between.

EN on all platforms and OmniFocus on the Apple devices.

Outlook at work is set up with a VBS that forwards any emails of my choice to Omnifocus.

 

What I am missing, is a way to send stuff from my EN on Windows to Omnifocus.

To do this, I downloaded the attached script from asianefficiency.com. This script is supposed to add notes tagged with "review"in EN, to OmniFocus and include a link directly to the note in the local EN app. By leaving the Mac at home on, with EN, Lingon 3 and Omnifocus running, all EN notes I tag with "review" in Windows at work should be synced back to EN on Mac at home and then be read by the Applescript and added to Omnifocus on the Mac. This is again synced to my iOS8 device, which I intend to use as my task manager at work.

 

Now, it seems to more or less do this, but something strange is going on with the "review" tag in EN; it seems to be copied in increments ("review 1", "review 2", "review 3" etc..) and sometimes removed entirely and then changing tags on notes from "review" to one of these copied ones. The script will only touch notes tagged with "review", so for many notes it does not do anything.

Also it deletes the tag entirely from EN. I want the tag to remain in the taglist and have tried with unassign instead of delete in the script, but that just leaves the tags on the notes, so Omnifocus keeps getting copies of the same notes over and over..

 

Im suspecting my issues may have something to do with multiple devices syncing EN together, creating conflicts, but I don´t know much about this stuff.

 

Anybody who understands what is going on here and is able to help me?

Evernote2Omnifocus.rtf

Share this post


Link to post

You have a very complex process with a lot of moving parts.  Hard to diagnose.

 

But I would start with the scripts.  IMO that is most likely where things are going wrong.

I've never seen Evernote (Mac or Win) change a Tag name without some instruction from the user.

Break the process/scripts down into small steps that you can test individually.

 

If you can bring your Mac to work, you might setup some simple tests to narrow things down.

 

Good luck, and let us know how it goes.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...