Jump to content
Justin Street

New Evernote for Windows 5.8.5 GA

Recommended Posts

A new version of Evernote for Windows is available. You can download it here

 

5.8.5 Release Notes:

 

New
  • Presentation Mode has been improved with a fresh look and new features:
    • Use the layout panel to navigate your presentation and add dividers
    • Images are now presented from screen-edge to screen-edge
    • Beautifully styled tables make your information stand out
Improved
  • Work Chat:
    • Updated look and feel of Work Chat
    • Removed duplicate contacts from the contact picker
  • Number of notebooks is now displayed on the Notebooks page
  • Fixed Japanese font issue in Context
  • Fixed issue causing images to be cropped when printing
  • Fixed issue causing Evernote window to remain when capturing a screenshot
  • Fixed several stability issues

For folks who were on our last beta, this update also fixes some note editor bugs that were introduced:

  • Fixed issue where copying the note title wasn't working
  • Fixed issue where "paste as text" wasn't working
  • Fixed issue where dragging text changed the background color

 

Enjoy!

  • Like 2

Share this post


Link to post

Hey Justin - thanks for the Easter present;  one minor query - when I Present one slide I get 5 controls on screen.  When I try others I just get 2.  Or'  after a little experimentation 3 or 4!

 

OK - on one Windows 8.0 Laptop I chose three random notes -

post-63053-0-88000800-1427980305_thumb.j

 

and saw five icons -

post-63053-0-75667100-1427979648_thumb.j

 

But then tried to move on to the next screen,  and found I could not:  arrow keys / page down / menu options - nothing worked.

 

Tried the same thing on another laptop (Windows 8.1 this time) and saw only two icons

post-63053-0-93193800-1427979829_thumb.j

 

I used a different note,  so went back to the first choice and tried again - saw the four icons.

 

So.  Thus far,  I seem to get different menu choices depending on different notes,  and the same note on different computers also gives me different choices.  Weird.

 

On the plus side,  I discovered double-clicking an image in Presentation Mode makes it bigger and centre-stage.  Disappointed again though that there's no print presentation function (that I've found yet...)

 

 

 

Share this post


Link to post

In this new version, if you try to copy and paste text that includes checkboxes, the checkboxes do not copy into other applications.  They are just ignored and left out.  This worked fine in prior released versions. 

Share this post


Link to post

What happened to the 'many improvements to the note editor' which were listed as part of the 5.8.5 beta? I can't see a single change to the note editor at all. Did these changes get withdrawn from the GA release?

Share this post


Link to post

@Liam, the note editor changes are available to beta users only for the time being.

Share this post


Link to post

Version 5.8.5.7193 (275193)

 

All tables are at 100 % now - no matter what are the pixel/percent settings was when you generated the table.

Share this post


Link to post

Not sure I see any changes in tables?  What exactly happened?

Share this post


Link to post

Not sure I see any changes in tables?  What exactly happened?

 

I don't see any either. 

Share this post


Link to post

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

  • Like 1

Share this post


Link to post

 

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

 

 

Same, and miss the new tables/checkboxes :(

  • Like 2

Share this post


Link to post

 

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

 

There is. You need to click on tools, then options and then 'Enable Beta Features and Updates'. I hope EN fixes the scrolling bar.

Share this post


Link to post

 

 

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

 

There is. You need to click on tools, then options and then 'Enable Beta Features and Updates'. I hope EN fixes the scrolling bar.

 

 

Yup.  Been there,  done that (ages ago).

Share this post


Link to post

 

 

 

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

 

There is. You need to click on tools, then options and then 'Enable Beta Features and Updates'. I hope EN fixes the scrolling bar.

 

 

Yup.  Been there,  done that (ages ago).

 

 

So had I... but somehow mine got unchecked? I checked it again, it restarted EN, and I have the new tables/checkboxes... did the latest release disable this checkbox in the Options?

Share this post


Link to post

 

 

@Liam, the note editor changes are available to beta users only for the time being.

 

?? There's no current beta is there?  I'm on the beta track,  but my latest version is the public one,  and I don't see any available updates...

 

There is. You need to click on tools, then options and then 'Enable Beta Features and Updates'. I hope EN fixes the scrolling bar.

 

Thanks.  I completely missed this option and it was checked on my system.  I like the new checkbox look but as pointed out in my post #3 above I regularly have to copy status notes out to other applications and the new checkboxes do not copy out.  At least now I can deselect this option, copy what I need and then re-enable.  I hope the developers decide to fix this before they bake in the new editor and remove the ability to opt out of the beta changes.

Share this post


Link to post

DId the same and now I have the new tables.  Downside, the table I use the most is a Phone Call template, and the new table wraps text in the header column for no good cause.  Argh!  Screen shots below of same note current and beta.  Unchecking beta features after I post this.   :(

 

Current                                             Beta

 

post-58142-0-93177700-1428357431_thumb.p           post-58142-0-23173100-1428357449_thumb.p

Share this post


Link to post

We are seeing similar table usability issues with the latest version of EN Mac.

It certainly appears that little real-world use of tables is understood by the UI designers nor by the usability testing group (if they have one).

 

I know that Evernote is not intended to provide the rich features of MS Word, nor am I asking for it, but if the designers would use/study how MS Word handles tables, and the table formatting/setup options that it provides, it would be very useful, IMO.  They could at least get some good ideas.

  • Like 2

Share this post


Link to post

Beta Options: Nice typo in the German version.

 

You should change "Beat Features" to "Beta Features"  :)

 

Well, sometimes some music would not be bad, as well.

Share this post


Link to post

Definitely something strange going on with checkboxes.  I've commented earlier that text which includes (beta) check boxes do not copy into other applications, such as Word.  The text copies but checkboxes are dropped.  Today I was editing a note (within Evernote), with the beta features turned on, and noticed that all of the checkboxes within that note were removed.  This was in a local notebook so I couldn't use note history to grab a prior version and had to recreate the checkboxes instead.  This only happened to the note that I was editing, no others were affected. 

 

After further checking I found that the disappearing check box problem is connected to Presentation mode.  I can recreate it in the following way:

 

- Start with a note that has checkboxes and start presentation mode. 

- Change screens so that the note is on one screen and the presentation mode is on another.  This may not be required but allows you to see what is happening.

- On the presentation screen now click on the layout editor button to open the layout on the right side of the display. 

- Now click on one of the blue dots along the right edge.  I think they indicate page separation. 

 

As soon as you click on a blue dot the check boxes will disappear from your original note, not the one shown on the presentation screen.  You don't need to have the beta editor options turned on.  This will happen either way.

  • Like 1

Share this post


Link to post

Anyone having an issue using the note editor formatting tool bar? If I am typing and press CTRL-B, I, or U, the toolbar changes to show I am now in Bold/Italics/Underline mode, but as soon as I type a new letter, I am back to normal. I have to type the text I want, then highlight it, then press the toolbar or CTRL-key sequence. Then I am stuck in that mode. Again, pressing CTRL-key or the buttons shows I am in normal mode again (based on the tool bar button states) but as soon as I start typing, I am back in whatever mode I used to highlight the previous characters.

Share this post


Link to post

Ugh. I also just created a note by putting in the title, then I started typing in the body itself. I just realized my title got removed and is now the first 100chars or whatever the number is from the first line of the note.

 

Why does Evernote do that? I shouldn't have to type the body first, then wait for it to create the subject, then override the subject with what I want in there.

Share this post


Link to post

Noted the issue from the formatting bar. That's a "beta features" issue which will be resolved in the next release.

  • Like 1

Share this post


Link to post

Noted the issue from the formatting bar. That's a "beta features" issue which will be resolved in the next release.

 

While you are looking at the formatting bar, it would be really nice if the problem where the formatting bar doesn't appear if you go to a note from a saved search is fixed.  You have to first jump to the title and then back down to the body of the note for the formatting bar to appear.  This one has been around for a while and is not related to the beta features, I've reported it in the forum before.

  • Like 2

Share this post


Link to post

 

Noted the issue from the formatting bar. That's a "beta features" issue which will be resolved in the next release.

 

While you are looking at the formatting bar, it would be really nice if the problem where the formatting bar doesn't appear if you go to a note from a saved search is fixed.  You have to first jump to the title and then back down to the body of the note for the formatting bar to appear.  This one has been around for a while and is not related to the beta features, I've reported it in the forum before.

 

 

I can confirm it vanishes, but I've never sat down to see what the sequence of events that causes it is.

Share this post


Link to post

[Ctrl]+[x] acts like [backspace] if no text is selected. (Should do nothing in that case.)

Share this post


Link to post

 

 

Noted the issue from the formatting bar. That's a "beta features" issue which will be resolved in the next release.

 

While you are looking at the formatting bar, it would be really nice if the problem where the formatting bar doesn't appear if you go to a note from a saved search is fixed.  You have to first jump to the title and then back down to the body of the note for the formatting bar to appear.  This one has been around for a while and is not related to the beta features, I've reported it in the forum before.

 

 

I can confirm it vanishes, but I've never sat down to see what the sequence of events that causes it is.

 

Registry fix, set the registry value (DWORD) "AutoShowNoteToolbar" 0.  This will add an option to the view menu to show editing toolbar and it will stay,  Have to click info to see other note info at that point.  FWIW.

 

post-58142-0-19083900-1428527105_thumb.p

  • Like 2

Share this post


Link to post

Thanks for the toolbar hack. works wonderfully.

  • Like 1

Share this post


Link to post

Registry fix, set the registry value (DWORD) "AutoShowNoteToolbar" 0.  This will add an option to the view menu to show editing toolbar and it will stay,  Have to click info to see other note info at that point.  FWIW.

 

Thanks for posting, Cal.

But it should not be necessary to make a registry hack.

  • Like 2

Share this post


Link to post

 

 

 

Noted the issue from the formatting bar. That's a "beta features" issue which will be resolved in the next release.

 

While you are looking at the formatting bar, it would be really nice if the problem where the formatting bar doesn't appear if you go to a note from a saved search is fixed.  You have to first jump to the title and then back down to the body of the note for the formatting bar to appear.  This one has been around for a while and is not related to the beta features, I've reported it in the forum before.

 

 

I can confirm it vanishes, but I've never sat down to see what the sequence of events that causes it is.

 

Registry fix, set the registry value (DWORD) "AutoShowNoteToolbar" 0.  This will add an option to the view menu to show editing toolbar and it will stay,  Have to click info to see other note info at that point.  FWIW.

 

 

Works great for me as well.  Thanks for posting the work around.

  • Like 1

Share this post


Link to post

@JM,

Less of a hack for me, as I prefer the frozen edit toolbar. It is an extremely well hidden option. ;-(

I don't understand why it isn't just a default on the view menu, particularly when the hover method isn't reliable.

Share this post


Link to post

I have no idea whether I should post this here or in the iOS feedback area, so here it goes because it has to do, potentially, with the new tables (I don't have a way to test without them).

 

When I create a table on Windows EN 5.8.5 with the beta tables enabled, the text inside the boxes is vertically center-aligned when viewed on mobile (iOS 7.7 beta 4).

 

Windows table:

se6uYJDSfB-3000x3000.jpeg

 

 

Mobile view:

ZxLX2u_Hme-3000x3000.jpeg

Share this post


Link to post

What does this 'hack' actually do?

It adds two options to the View menu, Show Note Info (F8) and Show Editing Toolbar (Ctrl-F8).  Selecting either option locks it.

Share this post


Link to post

With all due respect to developers and evernote

but this beta release is of the worst quality I can remember (and I have used evernote for many years).

Maybe windows app priority is very low, maybe your testing scenarios are very limited, I don't know. I'm on beta channel and I was OK to stand bugs cause I thought it's matters of couple of week, but now it's 5.8.5.7193 GA and I still see almost all of them:

I have special note where I keep all passwords to sites, of course it's encrypted, of course it's a table. (I don't want use special password keeping software, it's intentional).

And now my workflow for using this password keeping note is totally screwed:

  • visually changed table (as noted in several previous messages).
  • can't search inside encrypted note
  • can't insert newline inside cell (table immediately became broken)
  • copying is broken - if I'm selecting whole cell content, copy it, when I'm pasting it's inserting newline before and after content

 

Share this post


Link to post

What does this 'hack' actually do?

 

As I understand it, when you click in the note body, the formatting toolbar appears, but is replaced by note information if the cursor is placed in the note title.  Sometimes this auto-switching doesn't work (and hasn't done for many, many versions!).  I haven't tried it, but the hack prevents the auto-switching from taking place.

Share this post


Link to post

 

What does this 'hack' actually do?

 

As I understand it, when you click in the note body, the formatting toolbar appears, but is replaced by note information if the cursor is placed in the note title.  Sometimes this auto-switching doesn't work (and hasn't done for many, many versions!).  I haven't tried it, but the hack prevents the auto-switching from taking place.

 

The hack lets you lock the edit toolbar into place if you like from the View menu..

Share this post


Link to post

I created a table with two columns. I needed a third, so I selected a box in the right column, right clicked, and selected "Insert Column to the Right." I expected to get a third column with all 3 evenly sized, but instead the new column halved the width of the column on the right, making the sizing 2/4 + 1/4 + 1/4. Dunno if this should be default behavior, but I suspect not :D
 
e93371ed161345a63bda8ec25cc915a8.gif

 

Edit: Also there's still the Arial/Segoe bug RE: font title. Edit 2: This is only a problem with beta enabled. No beta = Segoe titles.

Edited by chirmer

Share this post


Link to post

I've managed to finally capture an odd behavior I've experienced a couple of times -- when scrolling to the bottom of a notebook, sometimes it bounces back up on its own accord. Not much, but enough to cover half or even all of the bottom row of notes. I've experienced it a couple of times but haven't been able to pinpoint why or capture a gif as the notes have contained sensitive data. In this gif, I scrolled to the bottom of a notebook, and each time I do, it bounces up on its own. I'm not scrolling up.

 

23609bb55e290a231b5df37dd4ed1d50.gif

Share this post


Link to post

Hi folks—

Copy/paste from encrypted text appears to insert a newline/carriage-return before and after.

 

2015-04-19%2020_44_34_zpsg6ujcqau.png

 

 

2015-04-19%2020_46_54_zpsosgobnbg.png

 

 

One use-case of how this might mess things up is if using encrypted text for login/password for websites.  It will produce incorrect username or password errors.

  • Like 1

Share this post


Link to post

Thanks for the update,  but dedicated password management software is a lot better than Evernote for that sort of thing - and it doesn't fluff the password by inserting incorrect returns.  Still - it's a mini-bug.

  • Like 1

Share this post


Link to post

Thanks for the update,  but dedicated password management software is a lot better than Evernote for that sort of thing - and it doesn't fluff the password by inserting incorrect returns.  Still - it's a mini-bug.

Is that like a gnat?   ;)

  • Like 2

Share this post


Link to post

Thanks for the update,  but dedicated password management software is a lot better than Evernote for that sort of thing - and it doesn't fluff the password by inserting incorrect returns.  Still - it's a mini-bug.

 

Do you know of something that's accessible everywhere? I've also tried an encrypted text file in Dropbox.  That solution has the advantage of being able to be searched with Regular Expressions.  (Or searched at all for that matter... at this point the Evernote Android client has no search at all and the Windows client has a "Find text in Note" but it's busted as of this GA release.)

 

I wouldn't mind switching to a dedicated password manager if anyone can suggest a good one that's accessible everywhere like Evernote or Dropbox are

 

(Sorry, this is off topic!)

Share this post


Link to post

Depends on what you mean by "everywhere" - LastPass (forinstance) is available on Windows and Android (which selfishly is pretty good for me) though the Android LP doesn't work the same way as Windows.  You have to open the LastPass browser and go to your website in their browser to be automatically logged in.  I'm sure most password managers are (or will be trying to be) accessible from as many OS's as possible...

Share this post


Link to post

I wouldn't mind switching to a dedicated password manager if anyone can suggest a good one that's accessible everywhere like Evernote or Dropbox are

 

I use and really like 1Password.  It is available for Mac, Win, iOS, Android, and can sync using DropBox.

Share this post


Link to post

Chrome on iOS recently added lastpass support, and I have it running on Win7, iOS (phone and ipad) and Mac OSX. I am getting ready to convert my wife to it. We can "share" our account's with each other and access  stuff we need to. Normally it is me accessing her stuff to set something up for her or bank account info I need when doing taxes and whatnot..

 

But the Chrome integration is wicked cool.

Share this post


Link to post

Thanks for the feedback.

 

Back on topic, I've noticed the extra line-feed/carriage-return happening in copy/paste now in all Notes in 5.8.5-GA (not just in encrypted text like I previously noted).  I'm not sure what changed if anything.  It could be that I was on a home machine vs. a work machine but they're both Win7-64 so that's weird.

 

(And this would affect anyone trying to paste into a field of any sort I'd imagine.)

Share this post


Link to post

Hmmn.  Also on 5.8.5 but Win 8.1 64bit - no such extra items in my pastes - how exactly are you selecting your original text?  I'd highlight with the mouse,  or doubleclick to highlight a word,  triple-click to get a phrase;  and my pastes are right-click and select delete.  All of the above is working normally for me.

  • Like 1

Share this post


Link to post

# bug

note editing  lost  auto scroll   .   

 

# description

when move the  cursor  to  text end  ,  press "Enter" key  not make evernote auto scroll  , and i can't find the cursor . 

 

 

# env

Windows8.1 &  Microsoft Input method 

Evernote 5.8.5.7193

Share this post


Link to post

Hmmn.  Also on 5.8.5 but Win 8.1 64bit - no such extra items in my pastes - how exactly are you selecting your original text?  I'd highlight with the mouse,  or doubleclick to highlight a word,  triple-click to get a phrase;  and my pastes are right-click and select delete.  All of the above is working normally for me.

 

Good to know.  After hearing it's ok for you I tried other things like switching fonts and that appears to make a difference.

With Arial no problem, with something like the Ubuntu font I get the extra line-feeds before and after.

Share this post


Link to post

 

Hmmn.  Also on 5.8.5 but Win 8.1 64bit - no such extra items in my pastes - how exactly are you selecting your original text?  I'd highlight with the mouse,  or doubleclick to highlight a word,  triple-click to get a phrase;  and my pastes are right-click and select delete.  All of the above is working normally for me.

 

Good to know.  After hearing it's ok for you I tried other things like switching fonts and that appears to make a difference.

With Arial no problem, with something like the Ubuntu font I get the extra line-feeds before and after.

 

 

 

Actually the above does not appear to be entirely true.  Here's what I'm able to recreate: It looks like what's actually happening is that if the Note Editor Font (as set in Tools > Options > Note) matches the font in my note the extra line feeds before and after appear during copy/paste to Notepad++ for example.

 

If I change the font in the note manually to anything other than the default note font copy/paste works as expected!

 

A strange bug.

Share this post


Link to post

Depends on what you mean by "everywhere" - LastPass (forinstance) is available on Windows and Android (which selfishly is pretty good for me) though the Android LP doesn't work the same way as Windows.  You have to open the LastPass browser and go to your website in their browser to be automatically logged in.  I'm sure most password managers are (or will be trying to be) accessible from as many OS's as possible...

 

FWIW, Lastpass for iOS now gets around this. On iOS, you open your site in Chrome or Safari, then "share" the page with Lastpass. Lastpass then populates the fields for you, just like Windows. 

With iOS, it has the added benefit of being locked by TouchID if you so choose, or you can use a PIN on non-touchID devices, like most iPads.

This is only about a week or so old. so a pretty new update, and very welcome

Share this post


Link to post

Problem with presentation mode layout editor - Windows 7 desktop

 

The first time I tried to use it the right side panel slid out but it was completely blank.

 

Now I cannot even access it as when I hover the cursor over the right border, there is no response - the small drawer icon does not even appear!

 

Can you please look into it?

Share this post


Link to post

Problem with presentation mode layout editor - Windows 7 desktop

 

The first time I tried to use it the right side panel slid out but it was completely blank.

 

Now I cannot even access it as when I hover the cursor over the right border, there is no response - the small drawer icon does not even appear!

 

Can you please look into it?

 

Are you still using 5.8.5?  The most recent release is up to 5.8.12.  If you're on an older version,  it would be a good idea to update...

  • Like 1

Share this post


Link to post

×
×
  • Create New...