Jump to content
SoftwareMarcus

Evernote for Mac 6.0.8 Released

Recommended Posts

Evernote for Mac 6.0.8 is basically the same as 6.0.7 but we’ve fixed 4 issues that many of you brought up in these forums.  Like you, I want to make sure every new version of Evernote for Mac raises the quality bar.  The fixes we’ve made in 6.0.8 are:

  • Table vertical alignment is back to being top aligned and not middle aligned.
  • Dragging an attachment moves the attachment and doesn’t copy it.
  • Switching between notes would sometimes get in a state where the formatting toolbar remained and didn’t switch to the info toolbar.  This is now fixed.
  • Finally, we fixed a crash that occurred for a number of people during syncing.  
As always, thank you for pointing out Evernote issues in these forums.  I know there are other issues that you’d like us to fix.  We’re working through them. 

 

One last thing, I just released (3/30/2015) Evernote for Mac 6.0.8 on the Mac App Store.

  • Like 4

Share this post


Link to post

I'm a huge fan of the new customizable toolbar!

 

Did you get rid of Work Chat?

 

(don't answer that)

Share this post


Link to post

@Marcus:  Many thanks.  You know how I LOVE bug fixes!

   

thumbs-up-small.gif

  • Like 2

Share this post


Link to post

Two bugs still there:

 

paste may lose indent and space.

CMD-Z undo sometime does not work.

Share this post


Link to post

I raised a ticket on the loss of spaces/indents/formatting issue that arrived in 6.0.6 and was told that it would be addressed in a "(cross platform) rendering engine" to be released sometime later this year.

 

Given the highly publicised critique of Evernote by a long time supporter here:

 

http://jasonkincaid.net/2014/01/evernote-the-bug-ridden-elephant/

 

I find the response from Evernote somewhat disappointing - a new version introduces a bug but rather than fix the bug we get "oooh look, shiny shiny new version as some point"

Based on this I'm stuck/sticking to 6.0.5 until that bug is fixed.

Share this post


Link to post

Jayce, we are actively working on a fix for that bug. Expect it much sooner than promised by support.

  • Like 1

Share this post


Link to post

BUG - or possibly just a poor software design issue

 

I first noticed this using 6.0.7 and it seems to have translated to 6.0.8

 

When working within a saved search, annotating a PDF or note as a PDF causes the saved search to clear when closing the annotation window. The filter seems to return to all notes in the notebook in which the recently annotated note lies. This is particularly distruptive when using a saved search to filter all notes with a specific tag - the result requires you to either initiate the saved search again or comb through your notes to navigate to the other relevant notes (which could be numerous if using a tag centric system).

 

To replicate:

  1. Initiate a saved search (saved tag search if possible)
  2. Annotate a PDF in a note or note as a PDF contained in the saved search
  3. Close the annotation window
  4. Saved search is cleared and user is returned to the notebook containing the annotate note/PDF

I'm running OS X 10.10.2

Share this post


Link to post

Since the update, formatting randomly disappears from new text.

 

For example, I selected bold then began typing...six words in, the bold disappeared, leaving regular text. Re-bolded. A few words later, it reverted to non-bold again.

 

Decided to finish the paragraph, then bold all of it at once. The bold reverted to non-bold in about three seconds, with the exception of the first three words, which were now bold. Re-bolded entire paragraph again....now everything but the first three words are bold.

 

Tried keyboard shortcuts. Tried manually clicking the B icon in the toolbar. Finally had to copy/delete the entire paragraph, paste it to TextEdit (no formatting), copy/paste it back into EN, which (oddly) appeared all bold (at last).

 

There's not an active sync occurring at any time---kept an eye on the wheel, just in case that was part of the problem.

  • Like 1

Share this post


Link to post

I held off Evernote 6 because I don't really like the flat style in OSX, but bit the bullet yesterday because I wanted to remove the workchat link from the toolbar.

 

Alas, it appears that search is broken. I search for a term, but if I remove that term from appearing in a given note, then that note still appears when I search for the same term?

 

I'd consider search is pretty much the most important part of evernote, so I hope this can be resolved soon.

 

Edit: Is it possible to migrate back to the latest version of 5?

 

Edit2: I shutdown evernote, and restarted it. The notes no longer show up. Additionally if I try to reproduce the behaviour I can't, so I'm guessing this may be related to the initial search index migration/regeneration.

Share this post


Link to post

@Marcus:

 

The below posts were made in another thread that I thought you should be aware of.

Seems like the problems with performance and slow typing continue in Ver 6.0.8.

 

 

Just google "evernote mac slow typing" and you will see that is affecting quite a few people and for some time now.

 

Evernote employee @Jackolicious was nice enough to respond earlier in this thread, but the message has not changed for months:

 

"Have you tried to direct download the latest 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, ...." to ... "We are anticipating even more performance improvements in 6.0.8"

 

... sounds more like guesswork than acknowledgement of an issue and commitment to remedy. Makes it sound like: ignoring, ignorance, or issue profound/fundamental. Can't complain too much as, though I use quite a bit, I am not a paid user (at this rate, not sure I would ever be). Here's to hoping is resolved soon.

 

 

In case it helps anyone..

 

Now using 6.0.8 via direct download and still happening across all four of my macs (two iMacs, one macbook pro, and a mac mini). All kinds of typing, even clicking the cursor on another part of the note takes 3 seconds to register. Only thing that helps temporarily is restarting EN (every 5 min)

 

Share this post


Link to post

BUG - or possibly just a poor software design issue

 

I first noticed this using 6.0.7 and it seems to have translated to 6.0.8

 

When working within a saved search, annotating a PDF or note as a PDF causes the saved search to clear when closing the annotation window. The filter seems to return to all notes in the notebook in which the recently annotated note lies. This is particularly distruptive when using a saved search to filter all notes with a specific tag - the result requires you to either initiate the saved search again or comb through your notes to navigate to the other relevant notes (which could be numerous if using a tag centric system).

 

To replicate:

  1. Initiate a saved search (saved tag search if possible)
  2. Annotate a PDF in a note or note as a PDF contained in the saved search
  3. Close the annotation window
  4. Saved search is cleared and user is returned to the notebook containing the annotate note/PDF

I'm running OS X 10.10.2

 

I'm running same versions and can't replicate.  I tried accessing a Saved Search that is a shortcut and a Saved Search from the search popup.  In both instances I was able to click on the "a" in the PDF toolbar, annotate something, and close it without the search results changing.

 

Any other thoughts?  It might be helpful to record your screen and post to YouTube.  Just a thought.

Share this post


Link to post

Since the update, formatting randomly disappears from new text.

 

For example, I selected bold then began typing...six words in, the bold disappeared, leaving regular text. Re-bolded. A few words later, it reverted to non-bold again.

 

Decided to finish the paragraph, then bold all of it at once. The bold reverted to non-bold in about three seconds, with the exception of the first three words, which were now bold. Re-bolded entire paragraph again....now everything but the first three words are bold.

 

Tried keyboard shortcuts. Tried manually clicking the B icon in the toolbar. Finally had to copy/delete the entire paragraph, paste it to TextEdit (no formatting), copy/paste it back into EN, which (oddly) appeared all bold (at last).

 

There's not an active sync occurring at any time---kept an eye on the wheel, just in case that was part of the problem.

 

@PaperQeen, I tried (I hope) to replicate your issue, I cannot.  Using latest 6.0.8

 

As you say it wasnt showing an active sync, but the behaviour would indicate that sync (background?) was causing this strange behaviour?

 

https://www.evernote.com/l/AVtsEs-t4x9BfoapVhxRdGZYGEcdpshLzIg

Share this post


Link to post

I'm running same versions and can't replicate.  I tried accessing a Saved Search that is a shortcut and a Saved Search from the search popup.  In both instances I was able to click on the "a" in the PDF toolbar, annotate something, and close it without the search results changing.

 

When trying to quickly reproduce the action for a screencast, I couldn't get it to cooperate. There may be some pertinent step that occurs in my workflow when actually working in the annotation window that's required to make the behavior occur. I'll keep an eye on it as I'm continuing to use it and will screencast it when I'm able to reproduce it.

 

I appreciate your time looking into it righteousdork!

Share this post


Link to post

Alas, it appears that search is broken. I search for a term, but if I remove that term from appearing in a given note, then that note still appears when I search for the same term?

 

I'd consider search is pretty much the most important part of evernote, so I hope this can be resolved soon.

We changed search behavior slightly in more recent versions. If you have the term "abc123" in a note, search for "abc123" and then modify the note to read "abc124"... previously, the note would disappear immediately because it no longer matched the active search. We changed the behavior of search so that this immediate disappearing doesn't happen. If you redo the search for "abc123" then the note will no longer appear.

  • Like 1

Share this post


Link to post

Why don't you turn it off in the side bar?

 

(View menu - side bar options)

Share this post


Link to post

Yikes-a-rooney....

 

BUG

 

Out of nowhere, images (pdf and jpg) added to a note begin to flutter and twitch like crazy. At first, I though the mouse/pointer needed to be within the borders of the note for this behavior to surface, but as the video shows at the end, even when I drag it OUT of the note window, the flutter continues.

 

Here's a video (you'll need to click on the video link to view):

https://www.evernote.com/l/ACSBx8hedo9L2p5s2kxfYR3ykDb6aYMgFVM

Share this post


Link to post

@PaperQueen:   I don't know, that PDF looks a bit shaky to me.   :lol:

 

Wow!  Never seen anything like that.  I'm running EN Mac 6.0.6 on Mavericks, and 6.0.7 and Mavericks, and all PDFs look OK.

If this is a NEW BUG for Ver 6.0.8, I am very glad I have NOT updated yet.

 

What versions of EN Mac and Mac OS are you running?

Share this post


Link to post

That looks like a fun one! Does it still do that if you resize the window?

Share this post


Link to post

Jack, maybe it's a new breakthrough feature the Devs slipped in:  Animated PDFs   :lol:

  • Like 2

Share this post


Link to post

What versions of EN Mac and Mac OS are you running?

 

 

JMichael, am running EN 6.0.8 (451398 Direct) on Mavericks 10.9.5.

 

Jackolicious, haven't tried re-sizing the note/window (yet). I do know that while the pdf (or jpg, in some cases) jitters around like a jumping bean, all typing and other keyboard actions stop working in EN. Only way I've been able to stop the jitter is to close the note (which, thankfully, does work, using the red dot in the top left corner of the note window). When the note is re-opened, there's no more jitter.

 

Other apps work normally when I bring them forward during the jitter session.

 

This is definitely unique to EN. 

 

Also, I've checked to confirm nothing else is actively grinding away in the background when the flutter occurs (i.e., EN is not syncing, Dropbox and CrashPlan are sitting quietly, Time Machine's not backing up, nothing is being downloaded or uploaded, yada, yada, yada). Can't for the life of me find anything third party action that triggers this occasional bug.

Share this post


Link to post

@PaperQueen:  Do all PDFs behave this way?  If not, anything common among them?

Share this post


Link to post

@PaperQueen:  Do all PDFs behave this way?  If not, anything common among them?

 

No--not all, nor can I find a pattern, JMichael. Not in timing, size, original source, etc. Just seems to come out of the blue, which is why I first suspected common timing with another app's sync process (which was quickly disproven).

Share this post


Link to post

Spotlight indexing... not working again under 6.0.8.

 

From the log-

 
2015/03/30 20:27:06:260 W|**  -[ENAppController checkSpotlightImporter]  | mdimport reported no importer for Evernote

Share this post


Link to post

Bug Report

 

I am running Mac version 6.0.8. When I went into preferences to change the default notebook, the top notebook was not showing in the drop down list. Unfortunately, that was the notebook I wanted. 

 

I solved the problem by adding a new top notebook, @aaa, which pushed the one I wanted down to the #2 slot where I could then select it.

Share this post


Link to post

 

Spotlight indexing... not working again under 6.0.8.

 

From the log-

 
2015/03/30 20:27:06:260 W|**  -[ENAppController checkSpotlightImporter]  | mdimport reported no importer for Evernote

 

 

Some people are seeing Spotlight issues if they have multiple versions of Evernote on their machine such as in the trash and other places.  In these cases the operating system can't find the right importer to use.  If you use Console and search on Spotlight you should see an item for PM mdimport: Paths.  Expand this and you'll see all of the spotlight apps and their paths.  There should only be one for Evernote.  Can you make sure to delete other versions of Evernote on your machine.  Also try to log out and log back in to force the spotlight reindexing to re-occur.   Anyway, let me know if any of my suggestions help.

  • Like 2

Share this post


Link to post

Bug Report

 

I am running Mac version 6.0.8. When I went into preferences to change the default notebook, the top notebook was not showing in the drop down list. Unfortunately, that was the notebook I wanted. 

 

I solved the problem by adding a new top notebook, @aaa, which pushed the one I wanted down to the #2 slot where I could then select it.

 

We have a bug where notebooks that start with a symbol do not appear in the notebook drop down list under preferences.  The work around is to go to the notebook you want as your default and right click and set it as the default from the right click menu.

Share this post


Link to post

 

 

Spotlight indexing... not working again under 6.0.8.

 

From the log-

 
2015/03/30 20:27:06:260 W|**  -[ENAppController checkSpotlightImporter]  | mdimport reported no importer for Evernote

 

 

Some people are seeing Spotlight issues if they have multiple versions of Evernote on their machine such as in the trash and other places.  In these cases the operating system can't find the right importer to use.  If you use Console and search on Spotlight you should see an item for PM mdimport: Paths.  Expand this and you'll see all of the spotlight apps and their paths.  There should only be one for Evernote.  Can you make sure to delete other versions of Evernote on your machine.  Also try to log out and log back in to force the spotlight reindexing to re-occur.   Anyway, let me know if any of my suggestions help.

 

 

OK, yep. Only one there after updating to the 6.0.9 beta, and it's the 'right' one:

 

4/2/15 3:56:24.459 PM mdimport[996]: Paths: id(501) (

...
    "/Applications/Evernote.app/Contents/Library/Spotlight/EvernoteSpotlightImporter.mdimporter",
 
...
 
)
 
Now, I am seeing -some- of my notes indexed, and others not. And the log shows:

 

  Version: Evernote Mac 6.0.9 Beta (451460
 
2015/04/02 15:56:25:516 I|*   __49-[ENNoteIndexHelper queueNotesThatNeedReIndexing]_block_invoke_2  | 0 notes need spotlight re-indexing for store 8811008B-E522-4C94-878E-4C553962CD8B
 
I suppose I could do a full-on-spotlight rebuild. 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...