Jump to content
SoftwareMarcus

Evernote for Mac 6.0.7 Beta 1 Released

Recommended Posts

I’m excited to announce our new 6.0.7 Beta 1.  We’ve been working hard on a bunch of bug fixes and a few new features for this release.  

  • Top Crashing Issues - We’ve fixed a number of top crashing issues.
  • Performance - We put in a number of fixes for performance.  There’s still more work to do but we think this release will help some of you seeing performance issues.  
  • Yosemite Share Extension - We had a version of this in 6.0.6 beta but in the end decided not to ship it because the quality wasn’t quite where we wanted.  We think this version is a lot better.  This gives you the ability to clip web pages when in Safari or attach files to Evernote from the finder by using the Share button.  This share extension will automatically work for everyone who installs Evernote on Yosemite.
  • Customizable Toolbar -  I know many of you have wanted this functionality for awhile.  In this first version of the feature, we allow you to hide or rearrange the buttons on the toolbar.
  • Work Chat Improvements - We’ve added some great new work chat features including better addressing and a new attachment button so you can see all of the shared notes and notebooks from a thread in one drop down.  We are listening to all of your great feedback on how to improve sharing and you’ll see continued refinements in the near future. 
 

Some of the other bugs we fixed are:

  • Spotlight search was broken on the App Store build and this should now be working although it won’t be testable in this beta.
  • As discussed in the forums, a note’s update time will not change anymore when making tag changes.
  • The Save as Searchable PDF feature is working again.
  • There was also an issue when trying to annotate an image or PDF after opening in Preview.  This now works.
Finally, we’ve got a really cool new notebook view that we would love to get your feedback on.  This will not ship in the final release of 6.0.7 but we'd like to get your feedback early before we ship it in a future release. To turn it on, quit Evernote, go to the Terminal app and type:

 

defaults write com.evernote.Evernote ENNotebooksModuleUpdateEnabled YES


 


The new notebook view only works on Mavericks and Yosemite so don’t turn it on if you have Lion or Mountain Lion.  It’s complete and fully functional.  There’s a few bugs especially in sorting but I’m using it full time and don’t see many issues.  The goal of the new feature is to simplify navigation and to provide the foundation for showing more notebook information at a glance.  If you want to revert back to the old notebook view just rerun the command above but change YES to NO.  Please provide your comments and issues in the new Notebook View forum post.


 

Thanks again for helping us Beta test 6.0.7.  If you’d like to download it you can click on this link. http://bit.ly/1wvlqZp.

  • Like 4

Share this post


Link to post

 

I’m excited to announce our new 6.0.7 Beta 1.  We’ve been working hard on a bunch of bug fixes and a few new features for this release.  
  • Top Crashing Issues - We’ve fixed a number of top crashing issues.
  • Performance - We put in a number of fixes for performance.  There’s still more work to do but we think this release will help some of you seeing performance issues. 
 
Some of the other bugs we fixed are:
  • Spotlight search was broken on the App Store build and this should now be working although it won’t be testable in this beta.
  • As discussed in the forums, a note’s update time will not change anymore when making tag changes.
  • The Save as Searchable PDF feature is working again.
  • There was also an issue when trying to annotate an image or PDF after opening in Preview.  This now works.

 

Marcus, thank you very much for all the bug fixes.  Keep this up and I'll have to retract some of my bug-related statements make elsewhere!   :ph34r:

  • Like 1

Share this post


Link to post

Customisable toolbar - :thumbup: it's taken far too long but it's good that it's finally there.

 

I'm sure it's not what your product managers want to hear - but that ugly Work Chat button is gone....

  • Like 1

Share this post


Link to post

Marcus, is there any chance you guys could work in a small request in this beta cycle?

  • Add back the menu item for "Open Note in Separate Window"
  • While you're at it, please give it a shortcut key

 

Looks like it got dropped from Ver 5.5.2 when you went to Ver 6.

 

Thanks.

 

This is working for me in 6.0.1 on 10.8.5. I can assign shortcuts to top-level menu items like "New Audio Note", but not to "Open Note in Separate Window". Are you sure this technique works for context menu items?

 

I'll add that "Open Note in Separate Window" should really be in the main menu which would support this and also scripting. If Evernote were to add it that would be nice. Not sure how to do feature requests....

 

 

Here are the Mavericks instructions. Older versions will be similar.

1. Open System Preferences

2. Select Keyboard

3. Click on the Shortcuts tab

4. Click on App Shortcuts

5. Click the + button

6. From the Application popup select Evernote.app

7. In the Menu Title field type ‘Open Note in Separate Window'

8. Click in the Keyboard Shortcut field and type your desired shortcut

9. Click the Add button

 

Once you do that you should be able to type your desired key combination and open the currently selected note in a new window.

 

Share this post


Link to post

 

  • Customizable Toolbar -  I know many of you have wanted this functionality for awhile.  In this first version of the feature, we allow you to hide or rearrange the buttons on the toolbar.

 

 

Thank you! Took you long enough, but this almost changes everything. It's still the bleakest looking app I know of, but we're finally able to get the Activity Stream abomination and the Work Chat woe out of sight. Helps a lot.

  • Like 1

Share this post


Link to post

Thank you for the customizable toolbar!

 

I found a bug: the shortcut switching fullscreen mode on/off (shift-cmd-f) does not work.

 

I will try the new notebook view soon.

Share this post


Link to post

I also wish to add my thanks for at last restoring the customizable toolbar.

 

It would be wonderful if the team could give similar respect to countless users' wishes regarding the sidebar.

Please give us back highlighting for a selected tag.

 

For a long time now we have had to put up with having no visual clue of tag selection.

This is unique to Evernote. No other app with a sidebar behaves in this user-unfriendly way, It is graphically totally illogical and I cannot understand the team's long-term reluctance to restore tag highlighting. 

 

Is it so much to ask?

  • Like 1

Share this post


Link to post

FYI

Not sure what crash scenarios were fixed, but I'm still able to crash the app with column and note list resizing in the side list view.

I've already submitted 3 crash reports.  It did seem a little harder to get it to crash though, for what it's worth.

 

Customizable toolbar is working well.  Look forward to seeing more options available.

 

Thanks for listening to all of the feedback!  When we complain about Evernote, please don't forget that it comes from a place of love.

 

Share this post


Link to post

Hi Marcus,

 

The problems that although one sets "display as attachment" some attachments they are displayed inline and a wrong context menu ist shown persist. The workaround to drag the attachment a litte until the '+' sign appears still works but now it also does the expected, it copies the attachment. Therefore, another step - deletion of the copied attachment - is needed in the workaround, annoying! Why is it so difficult to fix these problems with attachments? In always every note with PDF attachments some of them always open inline. When I use the workaround to fix it, select another note, and go back to the one with attachments the same attachment are displayed as inline again. If needed I could share an note showing the problem or send an actviity log. Please let me know.

Share this post


Link to post

In Ver 6.0.6 on Mavericks, I continue to have lots of problems with attachments.  

 

Even though I have set the preference to show "As an attachment", and I have changed the attachment in the Note to "show as attachment", the attachments continue to (seems random to me) expand back to view inline after I click out of the Note to other Notes, and then back to the original note.

Share this post


Link to post

Anyone having issue with tables since the update to Version 6.0.7 Beta 1, finally it would appear Presentation mode is getting there, but it has screwed up the placement of text with no option to correct...

Share this post


Link to post

Please give us back highlighting for a selected tag.

 

For a long time now we have had to put up with having no visual clue of tag selection.

This is unique to Evernote. No other app with a sidebar behaves in this user-unfriendly way, It is graphically totally illogical and I cannot understand the team's long-term reluctance to restore tag highlighting. 

 

Is it so much to ask?

 

There's no reluctance to adding functionality or fixing issues but I have to prioritize what gets worked on based on a number of criteria including the number of people impacted, the frequency, severity and difficulty of fixing the issue and the strategic goals of the company.  I appreciate you bringing this up but there are number of issue that rank higher on my fix list for example the crash and the attachment issues reported below.  I'm not saying we'll never fix it but we're still working through a number of major issues.

 

FYI

Not sure what crash scenarios were fixed, but I'm still able to crash the app with column and note list resizing in the side list view.

I've already submitted 3 crash reports.  It did seem a little harder to get it to crash though, for what it's worth.

 

We have not fixed the column issue in 6.0.7.  This is one of those things that's been difficult for us to reproduce and unfortunately the crash information we're getting back is incomplete.  It's really strange that some people see the issue all of the time but most don't.  These are the toughest bugs to fix and take a really long time because there aren't any clues for us to go on and the developers can't reproduce the issue so they can see the reason for the crash but we'll keep plugging away.  I'll message you directly if we need additional information to help track it down.

 

The problems that although one sets "display as attachment" some attachments they are displayed inline and a wrong context menu ist shown persist. The workaround to drag the attachment a litte until the '+' sign appears still works but now it also does the expected, it copies the attachment. Therefore, another step - deletion of the copied attachment - is needed in the workaround, annoying! Why is it so difficult to fix these problems with attachments? In always every note with PDF attachments some of them always open inline. When I use the workaround to fix it, select another note, and go back to the one with attachments the same attachment are displayed as inline again. If needed I could share an note showing the problem or send an actviity log. Please let me know.

 

In Ver 6.0.6 on Mavericks, I continue to have lots of problems with attachments.  

 

Even though I have set the preference to show "As an attachment", and I have changed the attachment in the Note to "show as attachment", the attachments continue to (seems random to me) expand back to view inline after I click out of the Note to other Notes, and then back to the original note.

 

I think we've finally fixed the context menu being wrong on attachments in 6.0.7.  We fixed a majority of the issues in 6.0.6 but there was one more use case where the menu would still be wrong which is probably what you're seeing.  I don't think the fix is in the beta but will be in our final release.  

 

Unfortunately we still can't reliably reproduce and fix the issue with the attachment inline settings not being remembered.  You're right it feels random which makes it even more perplexing.  Out of everyone at Evernote, only 2 people run into this  issue and we have no idea why only those 2.  Again, these are the hardest issues to fix because we can't fix what we can't reliably reproduce.   Since it appears to be random and only a small group of people run into the issue it means there isn't something wrong in the logic of the code but it's more subtle than that.  For example it could be an OS incompatibility.  Are you both on Mavericks?  Anyway, we'll keep plugging away.  If you happen to figure out a way to reproduce this reliably or see a consistent pattern please send me a direct message.

 

Anyone having issue with tables since the update to Version 6.0.7 Beta 1, finally it would appear Presentation mode is getting there, but it has screwed up the placement of text with no option to correct...

 

I haven't seen any table issues in 6.0.7 or issues with presentation mode.   We actually didn't touch Presentation Mode in 6.0.7 so I'd be really surprised if it worked differently than 6.0.6.   If you are seeing issues, please provide more details about the issue you're seeing.  A screenshot would help a lot.  

 

Thanks to everyone who has tried the beta and commented here in the forums.  We are reading through these and it's helping me prioritize upcoming fixes. 

  • Like 1

Share this post


Link to post

Marcus, many thanks for your considered response.

 

If I may, I think your response points to the need for more intensive internal testing.

 

These issues that seem to affect some, but not all, are very concerning.  They contribute to an over all impression of Evernote that it is unreliable.

 

Back in the Ver 3 days, I don't remember worrying about any of this stuff.  I felt very confident that I could update to a new GA release with confidence.

 

I no longer have that confidence.  Now, I assume that the new release will introduce NEW bugs.

 

I'm sure you know, if you reflect on personal relationships, once trust is lost, it is VERY hard to regain.

Sorry, but I can no longer trust Evernote.  There was once a time when I would automatically update to a new (non-beta) version.

But no longer.

 

Evernote, you must prove your reliability to me all over again.

  • Like 2

Share this post


Link to post

I concur with JMichael - I have lost faith. For me, Evernote used to be an enjoyable product to use. Now, I cringe every time I see a prompt for an update. Undoubtedly, it's the bugs, questionable/unfortunate design decisions, and "features" no one asked for that have trained me to hesitate before updating.

 

Marcus mentions that they're "still working through a number of major issues" and I think this statement alone points to a problem with how software is developed and tested inside Evernote. Software with a number of major issues should have not been released to the masses in the first place. Not finding these issues before shipping reveals that the way software is tested internally is broken and should get more focus. Personally, I think the "strategic goals of the company" should be delivering a reliable, functional, and stable product - not worrying about fancy printers or socks.

 

I'm not planning to stop using Evernote anytime soon, but the Evernote ship has holes and is taking on water. The more time you all spend rearranging the deck chairs and not plugging the holes is more time that I'm (and others I'm sure) are open to exploring alternatives. Evernote needs to focus on stability and reliability first. I understand that some software bugs are hard to find and reproduce but that's not an excuse for continuing to ship software that you know has problems.

  • Like 1

Share this post


Link to post

I concur with JMichael - I have lost faith. For me, Evernote used to be an enjoyable product to use. Now, I cringe every time I see a prompt for an update. Undoubtedly, it's the bugs, questionable/unfortunate design decisions, and "features" no one asked for that have trained me to hesitate before updating.

 

Alco, well said.

 

@Marcus, and the Evernote Dev Team:

 

I really hope you guys get this point:  Us experienced EN Users no longer trust your updates.

 

Maybe you can ignore this for the short term having over a 100M FREE users, but over the long term this will be to your detriment.

  • Like 1

Share this post


Link to post

I am so disappointed in EN Mac 6.0.6.

 

I had not noticed before, but now I am consistently observing that when I forward emails to my Evernote account, the images (JPG) are NOT properly included.

 

When I right-click on any image, I do NOT get a context menu to OPEN that image.

Share this post


Link to post

BUG REPORT:  Unable to Get Standard Context (Right-Click) Menu on Images from Email

EN Ver:  6.0.6

Mac OS X:  Mavericks

 

No matter how many times I right-click on an image, I am unable to get the standard right-click context menu that provides options for "Open" and "Open with..." from Notes created by sending email to my Evernote account.

 

This a very serious bug, since I daily need to edit these images.

 

Screenshot from EN Mac 6.0.6:

 

EN-Mac-606-Image-Context-Menu.png

 

Share this post


Link to post

 

Please give us back highlighting for a selected tag.

 

For a long time now we have had to put up with having no visual clue of tag selection.

This is unique to Evernote. No other app with a sidebar behaves in this user-unfriendly way, It is graphically totally illogical and I cannot understand the team's long-term reluctance to restore tag highlighting. 

 

Is it so much to ask?

 

There's no reluctance to adding functionality or fixing issues but I have to prioritize what gets worked on based on a number of criteria including the number of people impacted, the frequency, severity and difficulty of fixing the issue and the strategic goals of the company.  I appreciate you bringing this up but there are number of issue that rank higher on my fix list for example the crash and the attachment issues reported below.  I'm not saying we'll never fix it but we're still working through a number of major issues.

 

FYI

Not sure what crash scenarios were fixed, but I'm still able to crash the app with column and note list resizing in the side list view.

I've already submitted 3 crash reports.  It did seem a little harder to get it to crash though, for what it's worth.

 

We have not fixed the column issue in 6.0.7.  This is one of those things that's been difficult for us to reproduce and unfortunately the crash information we're getting back is incomplete.  It's really strange that some people see the issue all of the time but most don't.  These are the toughest bugs to fix and take a really long time because there aren't any clues for us to go on and the developers can't reproduce the issue so they can see the reason for the crash but we'll keep plugging away.  I'll message you directly if we need additional information to help track it down.

 

The problems that although one sets "display as attachment" some attachments they are displayed inline and a wrong context menu ist shown persist. The workaround to drag the attachment a litte until the '+' sign appears still works but now it also does the expected, it copies the attachment. Therefore, another step - deletion of the copied attachment - is needed in the workaround, annoying! Why is it so difficult to fix these problems with attachments? In always every note with PDF attachments some of them always open inline. When I use the workaround to fix it, select another note, and go back to the one with attachments the same attachment are displayed as inline again. If needed I could share an note showing the problem or send an actviity log. Please let me know.

 

In Ver 6.0.6 on Mavericks, I continue to have lots of problems with attachments.  

 

Even though I have set the preference to show "As an attachment", and I have changed the attachment in the Note to "show as attachment", the attachments continue to (seems random to me) expand back to view inline after I click out of the Note to other Notes, and then back to the original note.

 

I think we've finally fixed the context menu being wrong on attachments in 6.0.7.  We fixed a majority of the issues in 6.0.6 but there was one more use case where the menu would still be wrong which is probably what you're seeing.  I don't think the fix is in the beta but will be in our final release.  

 

Unfortunately we still can't reliably reproduce and fix the issue with the attachment inline settings not being remembered.  You're right it feels random which makes it even more perplexing.  Out of everyone at Evernote, only 2 people run into this  issue and we have no idea why only those 2.  Again, these are the hardest issues to fix because we can't fix what we can't reliably reproduce.   Since it appears to be random and only a small group of people run into the issue it means there isn't something wrong in the logic of the code but it's more subtle than that.  For example it could be an OS incompatibility.  Are you both on Mavericks?  Anyway, we'll keep plugging away.  If you happen to figure out a way to reproduce this reliably or see a consistent pattern please send me a direct message.

 

Anyone having issue with tables since the update to Version 6.0.7 Beta 1, finally it would appear Presentation mode is getting there, but it has screwed up the placement of text with no option to correct...

 

I haven't seen any table issues in 6.0.7 or issues with presentation mode.   We actually didn't touch Presentation Mode in 6.0.7 so I'd be really surprised if it worked differently than 6.0.6.   If you are seeing issues, please provide more details about the issue you're seeing.  A screenshot would help a lot.  

 

Thanks to everyone who has tried the beta and commented here in the forums.  We are reading through these and it's helping me prioritize upcoming fixes. 

 

 

My table testing - https://www.evernote.com/l/AVsRwczC-PJBhYH_GHGzZn0r0rEjLLR5hxw

Share this post


Link to post

As one of the many who has complained about the toolbar that could not be customised: A BIG THANK YOU!!! This update is brilliant for that fact alone. Much better!

Share this post


Link to post

 

The problems that although one sets "display as attachment" some attachments they are displayed inline and a wrong context menu ist shown persist. The workaround to drag the attachment a litte until the '+' sign appears still works but now it also does the expected, it copies the attachment. Therefore, another step - deletion of the copied attachment - is needed in the workaround, annoying! Why is it so difficult to fix these problems with attachments? In always every note with PDF attachments some of them always open inline. When I use the workaround to fix it, select another note, and go back to the one with attachments the same attachment are displayed as inline again. If needed I could share an note showing the problem or send an actviity log. Please let me know.

 

In Ver 6.0.6 on Mavericks, I continue to have lots of problems with attachments.  

 

Even though I have set the preference to show "As an attachment", and I have changed the attachment in the Note to "show as attachment", the attachments continue to (seems random to me) expand back to view inline after I click out of the Note to other Notes, and then back to the original note.

 

I think we've finally fixed the context menu being wrong on attachments in 6.0.7.  We fixed a majority of the issues in 6.0.6 but there was one more use case where the menu would still be wrong which is probably what you're seeing.  I don't think the fix is in the beta but will be in our final release.  

 

Unfortunately we still can't reliably reproduce and fix the issue with the attachment inline settings not being remembered.  You're right it feels random which makes it even more perplexing.  Out of everyone at Evernote, only 2 people run into this  issue and we have no idea why only those 2.  Again, these are the hardest issues to fix because we can't fix what we can't reliably reproduce.   Since it appears to be random and only a small group of people run into the issue it means there isn't something wrong in the logic of the code but it's more subtle than that.  For example it could be an OS incompatibility.  Are you both on Mavericks?  Anyway, we'll keep plugging away.  If you happen to figure out a way to reproduce this reliably or see a consistent pattern please send me a direct message.

 

 

Marcus,

 

Thank you for your remarks. Maybe I can add some details which might help with this.

 

First, I am using Yosemite.

 

I have some notes with a larger number of PDF attachments and it seems that always the same attachments change their state to inline when switching to another note and back as JMichael described. If it would help I could possible share such a note with you or provide an activity log for the switch between notes.

 

Regards,

 

Bernd

Share this post


Link to post

Since the Beta update my tables are useless.. I can screen share with any EN Support Engineer who wants to look into this...

Share this post


Link to post

Evernote suddenly stopped working and I'm unable to restart the app. Very annoying. Hope I can get back to work on Evernote for Mac soon. Huge bummer. Restarting Evernote, nor the MacBook, do not work at all.

Share this post


Link to post

@JMichael I see my table bug is still present in 6.0.7 GA...

 

Now I am no experienced coder, but if you have BETA testers highlighting errors which are not being resolved or simply being ignored, told that they do not exist - yet we can easily reproduce, what is this forum for?  I have been highlighting errors around Table Testing since they released the adjustable tables and some are still there.

 

Worse it is getting and for one I agree with your post relating to the 100M users, I can assure you personally it is one less as my wife's premium subscription is up and I am not paying for it.  I have Premium personally and also Business.  I will let my Premium expire and look at OneNote for my wife's collaboration.  As far as Business is concerned, I cannot get buy in...

  • Like 1

Share this post


Link to post

My EN has crashed at least 2-4 times from yesterday up until today...

 

Sent crash reports..

 

One from memory was when I grouped two notes together to see if I could add Tags to both notes.. Can this be done?  Either way, it crashed.

 

Another was when I updated to GA and re-opened.. Crash... Seems to be working now.

Share this post


Link to post

I installed the latest beta. Unfortunately still unable to search for notes using spotlight.

Anyone else facing this problem?

Share this post


Link to post

I installed the latest beta. Unfortunately still unable to search for notes using spotlight.

Anyone else facing this problem?

 

You may want to update to the just released GA version.  See link above, or it should be available if you "Check for Updates" in EN Mac.

Share this post


Link to post

×
×
  • Create New...