Jump to content
oogabooga

mac Annoying behaviour of Undo (Cmd-Z) when autocorrecting

Recommended Posts

I am having an annoying 'problem' with Evernote on both my home and work Mac's, and wanted to know if this was something there was a fix for. It happens frequently enough that I thought of asking for help here.

 

When Evernote autocorrects something I've typed, the keystroke CMD-Z will not only undo the autocorrection, but will instead undo the last sentence or two of typing. This behaviour is not consistent with other Mac programs I used, including Textedit, Safari, or MS Word, where CMD-Z undoes the autocorrection only. It is annoying because when it tries to auto-'correct' some technical terms that I do not want fixed, I instinctively hit CMD-Z and Evernote deletes a sentence or so of text. 

 

 

To give a specific example, assume I want to type "I updated the mount points in fstab.", where autocorrect will 'correct' fstab to 'stab'. At this point, I hit CMD-Z. In Textedit/MS Word, it undoes the autocorrect, replacing stab with fstab and I move on. In Evernote, it deletes the entire sentence, and I have to type it all over again. 

 

Any help would be appreciated!

Sam

Share this post


Link to post
Sounds like part of this is an over-effective auto-correct.  Evernote doesn't have that built-in,  so if you're being annoyed by autocorrect,  it's not Evernote.  Check your OS settings if necessary to turn it off.
  • Mac System Preferences > Language & Region > Keyboard Preferences... > Text > deselect Correct spelling automatically - This turns off auto-correct across your entire desktop.
  • System Preferences -> Keyboard -> Text -> Use smart quotes and dashes - Make sure that checkbox is unchecked.

CMD-Z should work as you'd expect - which version of Evernote do you have and which Mac OS?

Share this post


Link to post

Thanks gazumped.

 

I am running Evernote 6.0.5 on OS 10.10.1. The problem is not an over-effective auto-correct, but an over-effective UNDO command in Evernote.

 

I did try what you suggest - of course turning off text correction obviates the need for me to hit CMD-Z so often but that is not a functional solution for me as I rely on auto-correct very heavily in other applications.  Unchecking smart quotes and dashes had no effect as well (although, I do thank you for pointing me to that as it solves another nagging problem I've been having over the years).

 

So, in short, I'm still at a loss as to why CMD-Z does more in Evernote than in other applications... and whether this is something specific to my setup.

Share this post


Link to post

Thanks gazumped.

 

I am running Evernote 6.0.5 on OS 10.10.1. The problem is not an over-effective auto-correct, but an over-effective UNDO command in Evernote.

 

I did try what you suggest - of course turning off text correction obviates the need for me to hit CMD-Z so often but that is not a functional solution for me as I rely on auto-correct very heavily in other applications.  Unchecking smart quotes and dashes had no effect as well (although, I do thank you for pointing me to that as it solves another nagging problem I've been having over the years).

 

So, in short, I'm still at a loss as to why CMD-Z does more in Evernote than in other applications... and whether this is something specific to my setup.

I have the same problem, and I agree that I should not have to disable my useful auto-correct system wide.  Evernote should be able to fix their undo command.

Share this post


Link to post

OK one report is happenstance,  two starts to move towards something that needs fixing..  I'd suggest both you gents submit a bug report by choosing "report a bug..." in the first dropdown after logging into this link > https://evernote.com/contact/support/  Since the guys are presumably still 'fixing' 6.0.x it might get some quick attention...

Share this post


Link to post

Hey folks - this has been the one thing that annoys me about Evernote for ages! It's so vindicating when you do a search and you find someone else with the same problem. What ended up happening here? Does anyone know if Evernote Support was contacted? If this is something they're interested in fixing?

Share this post


Link to post

Post #5 is how things ended up,  unless one of the version updates fixed the problem - what version of Evernote are you on?  They're up to 6.0.7 now I believe...

Share this post


Link to post

This is a frequent annoyance for me too. I have just followed gazumped's suggestion and submitted a support request. I'll try to update here once I hear back.

Share this post


Link to post

Evernote's support team requested a full Activity Log file from me, and then came back with this:

 

 

After discussing this issue further with the team, I can report to you that this behavior with cmd+z is to be expected. As it is, cmd+z is performing a regular undo, not undoing the last autocorrect (it will obviously remove that one as well).

At this time we will be happy to take on this issue as a feature request.

 

 

 

Share this post


Link to post

I also have the same problem and the overactive Undo is really annoying.

 

At least after update you can stop autocorrect with option+space, but if you do end up going with space accidentally and undo'ing, you still remove the whole sentence. 

Share this post


Link to post

I have the same problem. Using option+space does not work for me.

 

It would be much appreciated when Evernote undo's only the autocorrect when pressing Cmd+z, which is the default systemwide behaviour. 

Share this post


Link to post

 

Other people are having the same problem. See my post there. The answer of the Evernote team is just sad. Fire up OS X TextEdit and compare the behavior!

Share this post


Link to post

I have the same problem in version 6.7.1. I have submitted a bug report, too. It would be really nice to have this problem fixed.

Share this post


Link to post

Hi Everyone, and welcome to the Forums @jacobkrich!

If any of y'all have open support tickets regarding this issue, please let me know here and I will follow up on them. Thanks!

Share this post


Link to post

I must be dense, because I can't figure out how to open a ticket.  I go through the drop down wizards - Technical issue - other - User interface issue - and it tells me:

 

Please submit a ticket and provide as much information as possible so we can diagnose the problem. For example:

  • Steps to reproduce
  • Screen recording or screenshots
  • Device & operating system
  • Activity log

 

But there's no place to actually 'submit a ticket'

 

I'm a +1 on this over aggressive autocorrect and undo combo.    I have a fish name: knez that I want to write about.  I paste in the word 'knez' and hit space and it automatically changes it to 'knew'  I 'undo' the auto correct and it does an undo on both the autocorrect and the space.  What I've done personally is uncheck the correct spelling automatically which isn't ideal but it works.  The typos still get highlighted but I don't have to fight with words the dictionary doesn't recognize and tries to fix for me.  Having to go back and manually fixe all the 'teh' and 'THe' mistakes is toil I'd rather not do, so if we could improve this, I'd be grateful. 

uncheck.png

  • Like 1

Share this post


Link to post

Have you ever tried to write a list like this with EN Mac:
(a)
(b)
(c) x

Don't or else you'll go nuts. (c) x gets converted to copyright symbol. Undo removes the symbol and the (c). Even switching "Correct Spelling Automatically" off does not help in this case. In contrast, when doing the same in OS X TextEdit, Cmd+Z reconstructs the (c)...

 

Share this post


Link to post

This bug still hasn't got fixed? :'(  It's driving me mad too...

If it's just a few tech terms, though, adding them to the dictionary should avoid your mac from trying to correct them anymore.  But if you're like this user (post), then you'd have to switch to another software I guess, until Evernote fixes this bug... *sad*

Share this post


Link to post
On 6/19/2016 at 5:42 PM, BSR said:

Hi Everyone, and welcome to the Forums @jacobkrich!

If any of y'all have open support tickets regarding this issue, please let me know here and I will follow up on them. Thanks!

Hi @BSR. Thanks for offering to follow up. The ticket number I received was 1217022. I doubt it's "open" any more, since I did receive an answer, which was essentially what I posted above, plus a promise that the feedback would be passed on to the development team as a feature request. That was on 3/9/15, and I've not heard anything more since then.

If you have any updates, I'd love to hear them!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...