Jump to content
MaartenK

Changes not saved without warning (workaround for now)

Recommended Posts

Hi,

 

First of all - I love Evernote. But I noticed some worrying behaviour lately on my Mac (also in the Android version, but this is dealt with elsewhere).

I'm working on the latest version of Evernote (6.0.3). I noticed today that when I made a change to one specific note, Evernote refused to save the changes. When I made changes, selected another note and switched back, all changes where gone.

 

I read in an older post that this happens when there is some kind of "illegal character" in the note, making it impossible for Evernote to save the changes. It then reverts back to the last note. When I checked the Activity logfile I noticed the following contents:

 

2014/12/04 22:32:03:989 I|*   __52-[ENAppController(Sparkle) feedURLStringForUpdater:]_block_invoke main | Feed URL https://update.evernote.com/public/ENMacSMD/EvernoteMacUpdate.xml
2014/12/04 22:32:38:003 I|*   -[ENCommonEditorWebView setNoteContentNeedsCommit:] main | changing from 0 to 1
2014/12/04 22:32:39:079 I|*   -[ENMessageStoreWebSocket pingTimerFired:] main | sending ping
2014/12/04 22:32:40:744 E|*** -[ENCommonEditorWebView handleJavascriptLog:] main | ERROR: Exception: TypeError: null is not an object (evaluating 'a.nodeValue.charAt')
2014/12/04 22:32:40:745 E|*** -[ENCommonEditorWebView handleJavascriptLog:] main | ERROR: Exception in queryCommandValue <$>: TypeError: null is not an object (evaluating 'a.nodeValue.charAt')
2014/12/04 22:32:40:745 E|*** -[ENCommonEditorWebView commitEditingWithCompletion:] main | No HTML after processing for commit! 
2014/12/04 22:32:40:745 I|*   -[ENCommonEditorWebView setNoteContentNeedsCommit:] main | changing from 1 to 0
2014/12/04 22:32:53:152 I|*   -[ENCommonEditorWebView updateViewFromNoteContent] main | loading note content, dirty=0 usn=11364 c6386aff-c763-4110-b004-d9a2835f4421/p337 'xxx Tile of the note xxxx'
 
The note consists of some text and an embedded .docx document. I scrolled down the note (moved the cursor below the embedded attachment) and pressed the backspace key, basically removing an empty line below the attachment. Problem solved!
 
This issue is solved for now, but what I would like to know is why Evernote doesn't warn me when it is unable to save a document. At least a pop up error message or something! I have no clue how many changes I've lost over time because of this strange behaviour.
 
Can anybody explain to my why this happens (and how this can be resolved)?
 
 
Regards,
 
Maarten.
 
 
 

Share this post


Link to post

Sorry, I don't have any suggestions other than for you to submit a bug report to make sure Evernote is aware of this bug.

 

Submit a BUG report via an EN Support Ticket. In the Support Form, select "Report a bug, crash, or data lost", and start the Ticket Title with "BUG:  " to make it clear.  Reporting a bug should be available to all users, including Free Account owners.

Share this post


Link to post

I have just encountered this today and it is a real pain.  I don't exactly understand your workaround.  I don't seem to have any extra lines.  Could you let us know if you have still been experiencing this?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...