Jump to content
jimpogo

Text no longer wraps in Evernote

Recommended Posts

This morning I upgraded to Evernote v5.7.2 for Mac, and after notes were migrated, text no longer wraps.

  • Existing text no longer wraps in existing notes (boo).
  • New text, typed or pasted, DOES correctly wrap in new notes (yay).
  • New text, typed or pasted does NOT wrap in existing notes (boo).

I see that this has been sort of an on and off complaint for a couple years now. It never happened for me before today. Looks like reinstalling to an older version has mixed results too.

 

-- Jim

 

 

Share this post


Link to post

This clearly looks like a bug to me, as many users are reporting this issue.

You can find some of the other reports by clicking on the "wordwrap" tag/button at the top of this page.

 

You may also want Submit a BUG report via an EN Support Ticket. In the Support Form, select "Report a bug, crash, or data lost", and start the Ticket Title with "BUG:  " to make it clear.  Reporting a bug should be available to all users, including Free Account owners.

  • Like 1

Share this post


Link to post

Thanks -- I submitted it as a bug, but I'll also post here that text wrap or "word-wrap" on my other computer, at v5.6.2 works fine, its just the 5.7.2 laptop thats not wrapping.

Share this post


Link to post

Are there any news on this bug report? (Can we see the bug report and its status?)

 

I am suffering from the same problem in some of my notes (I have upgraded to version 6 yesterday night).

 

I could not fully understand why "some notes" do not wrap the text correctly... I have the feeling that in this last update some of those notes got "updated" and do wrap correctly, but not all of them! I know I have updated one note in particular some days ago from an Android Evernote... not sure if that could be a source of problems. But this happens in other notes too, so it may not be the cause of this bad behaviour.

Share this post


Link to post

This morning I grabbed the new update (v6.0.1) and the text wraps again (yay).

 

Looking at my original post about v5.7.2, I didn't realize they did a whole number jump until just now! Slightly flatter ui look, but with text wrap.

Share this post


Link to post

Hi there,

 

I have just found "one cause" of this problem - in the newly updated evernote (6.0.2). I have reported this as a new bug.

 

The issue (in my case) was a "huge link" I had in a note, e.g.: 

 

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0CCcQFjAA&url=http%3A%2F%2Fwww.comscore.com%2Fcontent%2Fdownload%2F22301%2F1136715%2Ffile%2FThe_Multi_Screen_Path_to_Purchasing.pdf&ei=jrEhU4H0DOGm0QXXnoGACg&usg=AFQjCNHQ1iq2bFkf9AiaPQC_tZyCs-FVxA&sig2=e58r5mOVzijDlNv-riVS8A&bvm=bv.62922401,d.d2k&cad=rja

 

Once I removed it (or placed it inside a "hyperlink text" in the note) the text got "correctly" displayed...

 

If you try copy-pasting this link as "rich-text" into a new note it will probably work, but if you paste it as "text" (no link) it is (probably) not wrap (at least that was what happened to me).

 

If I get some feedback on this problem I will drop a line here! 

 

Cheers!

Share this post


Link to post

I just tested your VERY long link in EN Mac 6.0.2 in Yosemite, and it wordwraps just fine, as does the rest of the Note.

 

Having said that, I have seen previously clips from some Web sites that do NOT wordwrap properly due to the unusual HTML structure of that web page.  Perhaps that is what you are experiencing.

 

Hi there,

 

I have just found "one cause" of this problem - in the newly updated evernote (6.0.2). I have reported this as a new bug.

 

The issue (in my case) was a "huge link" I had in a note, e.g.: 

 

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0CCcQFjAA&url=http%3A%2F%2Fwww.comscore.com%2Fcontent%2Fdownload%2F22301%2F1136715%2Ffile%2FThe_Multi_Screen_Path_to_Purchasing.pdf&ei=jrEhU4H0DOGm0QXXnoGACg&usg=AFQjCNHQ1iq2bFkf9AiaPQC_tZyCs-FVxA&sig2=e58r5mOVzijDlNv-riVS8A&bvm=bv.62922401,d.d2k&cad=rja

 

Once I removed it (or placed it inside a "hyperlink text" in the note) the text got "correctly" displayed...

 

If you try copy-pasting this link as "rich-text" into a new note it will probably work, but if you paste it as "text" (no link) it is (probably) not wrap (at least that was what happened to me).

 

If I get some feedback on this problem I will drop a line here! 

 

Cheers!

Share this post


Link to post

If you do "paste" of a long link directly from your browser (in HTML format) it will do correct wrapping... however in a new note if you do "paste and match style" it does not wrap correctly (I have just made that test).

 

In my case - in the old note I made my tests - I do not have "unusual HTML" structures, simple long URLs... I don't think this is a "normal" thing to expect on Evernote. I suppose this should be researched further, as it would be extremely frustrating "migrating manually" all the past notes that have this kind of text (that breaks the correct text wrapping)... furthermore, this did not use to happen few versions back.

 

Cheers.

Share this post


Link to post

×
×
  • Create New...