Jump to content
Br1

Passcode requirement disappeared

Recommended Posts

Hi - has anyone had the issue of the need for their passcode stopping ?  I had a passcode set up and have just now gone in to evernote without the passcode being required !  I have not removed or changed the passcode requirement and am now seriously worried about the security of this app.  Have I been hacked ?

Share this post


Link to post

Hi.  It would help if you told us what Evernote client you're using and exactly how you exited the app and how you opened it again.  You haven't been "hacked" if the only problem is that you weren't asked for a passcode.

Share this post


Link to post

Just replying here that I'm experiencing the same problem. Its happened on both my iPad mini iOS 8 app and iPhone 5c, but it seems to not have happened as much on the iPad recently. It's still a problem on the iPhone.

 

It's not clear what I was doing every time just before leaving the app—probably a multitude of things—but the common occurrence (probably once every couple of days) is that once I open the app again, I notice that I was not asked for a passcode after my preset 5 minutes had elapsed. I go into my settings in the app, tap "Premium," and sure enough, passcode lock is listed as "off." I then reset my passcode until it happens again.

 

Please help in whatever way you can to get this issue looked at—it's definitely disconcerting, since I have no way of knowing when the app will unlock itself. I haven't submitted a support ticket yet. Since I don't know if I can reproduce the issue, do you recommend that I do, @gazumped?

Share this post


Link to post

There's another thread around here somewhere with similar passcode problems,  so yeah - support tickets,  definitely.

Share this post


Link to post

Had same issue. Reported it to Evernote support, and sent along a log.  Following is their response:

 

Thank you for your patience and working with me on this.

I have gathered enough details to determine that this appears to be a bug. I am going to pass this along to my product team to further investigate.

In the meantime, I will need to wait for the quality assurance lead to finish testing and then assign it a priority. Based on their priority they will implement a fix. Due to the nature and way software changes and processes are implemented it may take sometime to implement a fix. I do understand how this can be frustrating and I am hopeful that a fix will be ready shortly. I also recommend following the discussions in our user forums (https://discussion.evernote.com) for the most up-to-date info on when fixes are released. Finally, it is advised to download our latest updates when they become available, so you don't miss out on any of our latest features and bug fixes.

Again, thank you very much for helping to bring this issue to our attention, I hope that we can get this resolved quickly and let me know if you have any further questions.

Thank you for your feedback and being a valued Evernote user.

  • Like 1

Share this post


Link to post

Awesome, thanks so much for sending this along, @metrodetroiter. I'm glad it's a part of the regular process now and they're working on it. That's half the battle sometimes!

Share this post


Link to post

I just ran into this bug today in iOS 8.1.2. Opened the app and my passcode was inexplicably disabled. I submitted a support request via the app.

 

I've had this bug occur a handful of times in the past, but in all previous instances the passcode was disabled when the app was updated from the App Store. This is the first time I've experienced it just turning itself off without an app upgrade.

 

It's a shame that the Evernote team continues to let this security issue fester.

Share this post


Link to post

Just confirmed that this issue is still present in the latest version of Evernote (7.6.4.313631).

 

Q: How hard is it to remember an app setting?

A: Not hard at all.

 

It's inexcusable that this privacy and security issue keeps cropping up version after version.

Share this post


Link to post

Just for the record for any Evernote support folks reading this thread, this problem went away for me when I upgrade to the iPhone 6. Not at all a fix for this really serious problem, but maybe it adds a layer of information that can help squash the bug?

  • Like 1

Share this post


Link to post

Adding my name to the list of people who have been experiencing this for months now. I have an iPhone 5S, currently running iOS 8.1.2, and Evernote 7.6.4.313631.

 

I thought (hoped) that it would be fixed after an update or two, but there have been quite a few bugfix releases since it started, and this basic security flaw remains, which is disappointing.

 

I've logged a ticket with support now, hopefully it will help.

 

 

Share this post


Link to post

Just had this happen to me (again) - latest iOS (8.4) on an iPhone 6 plus.

 

Looks like the tickets from earlier have been ignored, since this has been a known issue for a while and is still occurring. I'm increasingly concerned with Evernote's lack of urgency regarding security.

Share this post


Link to post

×
×
  • Create New...