Jump to content

Recommended Posts

This bug really affects workflow when you are trying to quickly tag with the GTD (Getting Things Done) method which uses a lot of tagging. 

 

 

Problem: If you start typing a part of a tag name (not the first letter) it will appear.  If you try to click the tag or tab, highlight, and hit enter it creates a new tag of whatever you typed. 

 

 

Example:

 

Say your tag was @home and you started to type "ho".  Every tag that has the letters "ho" appear in autocomplete.  But, no matter what tag you click, it will not choose it (unless the tag began with "ho") it will just create a new tag of "ho".

 

Example 2:

 

The tag is "Things to Buy".  If you type "Bu" the tag appears in autocomplete.  If you click the tag "Things to Buy" it creates a new tag called "Bu"

 

 

 

I have a bunch of these tags created all the time because you have to remember to type exactly what the tag begins with for it to work properly.  This is not how search autocomplete is supposed to work.  This has been an issue for a long time and I see others report it on the Mac.

  • Like 1

Share this post


Link to post

I agree. It creates bogus non-existent tags.

  • Like 1

Share this post


Link to post

YES!  Please fix this!!!  I have 50+ tags.  Since a recent update, I have been having an awful time assigning tags.

 

Is there any way to move this up the queue to be fixed??????

  • Like 1

Share this post


Link to post

Is there any way to move this up the queue to be fixed??????

There is none that a user can do as far as I know. Evernote will hopefully recognize that it's a bug and schedule a fix as their priorities dictate.

  • Like 1

Share this post


Link to post

I've started getting this as well. Like the OP said, you find a tag by doing a partial search, the correct tag appears but when you click on it, the partial string gets entered.

This is on Windows 5.6.4.5632

  • Like 1

Share this post


Link to post

I just discovered this problem as well and it's very counter productive.  The more I use EV the more I find it to be very antidemocratic; i.e. buggy!

  • Like 1

Share this post


Link to post

Here's a simple workaround I used to solve the same problem described in the posts above :
Here's what I did and from then on I had no problem with this tag (though another tag started to have the same problem):

 

I had a tag named tt-todo. Suddenly a few weeks ago typing the regular tt for auto-completion and choosing tt-todo created a new tag called tt .

1. Add a third tag called tt_todo to all the notes having tt-todo or tt.
2. Delete tag tt-todo
3. Delete tag tt

 

That's it. Now it works correctly again. Typing tt and clicking tt_todo works now correctly without Evernote creating again a new tag called tt.

  • Like 1

Share this post


Link to post

Here's a simple workaround I used to solve the same problem described in the posts above :

Here's what I did and from then on I had no problem with this tag (though another tag started to have the same problem):

 

I had a tag named tt-todo. Suddenly a few weeks ago typing the regular tt for auto-completion and choosing tt-todo created a new tag called tt .

1. Add a third tag called tt_todo to all the notes having tt-todo or tt.

2. Delete tag tt-todo

3. Delete tag tt

 

That's it. Now it works correctly again. Typing tt and clicking tt_todo works now correctly without Evernote creating again a new tag called tt.

Great, thanks.  I'm guessing I would, eventually, have seen that result since I'm been deleting tags EN created in error when I tried to select the desired tag from the dropdown.

Share this post


Link to post

Here's a simple workaround I used to solve the same problem described in the posts above :

Here's what I did and from then on I had no problem with this tag (though another tag started to have the same problem):

 

I had a tag named tt-todo. Suddenly a few weeks ago typing the regular tt for auto-completion and choosing tt-todo created a new tag called tt .

1. Add a third tag called tt_todo to all the notes having tt-todo or tt.

2. Delete tag tt-todo

3. Delete tag tt

 

That's it. Now it works correctly again. Typing tt and clicking tt_todo works now correctly without Evernote creating again a new tag called tt.

Thank you for the reply, but that workaround does not work for me.  Not only would I have to change hundreds of notes, it doesn't address the problem of tags that appear that don't begin with what you type.  I use many tags for the GTD method that begin with a number (for priotiziation) or an @ sign (to signify where I do this task), or it is just not intuitive with what it starts with.  Example:  tag called "@Online Shopping"  I type in "sh" and under no circumstances will it choose the tag even though it shows and is highlighted, unless I remember to type "@online" first.  It will only create a new tag for "sh", even though @Online Shopping is a highlighted tag that appeared in search suggestions.  If there was a tag that began with "sh" I can choose any of those and it would work.  But, if I just hit enter on any that appear in the drop down that just have "sh" in them but don't begin with them, a new tag of sh is created.

Share this post


Link to post

I reported this on 9-9. It was confirmed as an error and put into the queue of the developers. No idea when to expect a fix.

  • Like 2

Share this post


Link to post

I reported this on 9-9. It was confirmed as an error and put into the queue of the developers. No idea when to expect a fix.

 

FYI: The fix is checked in. Just a matter of when we do the next release.

  • Like 4

Share this post


Link to post

 

I reported this on 9-9. It was confirmed as an error and put into the queue of the developers. No idea when to expect a fix.

 

FYI: The fix is checked in. Just a matter of when we do the next release.

 

 

dconnet, thank you very much for sharing this with us.  It really helps.  Please continue to share.   :)

Share this post


Link to post

×
×
  • Create New...