Jump to content
mds386

Waiting on filtering notes as you type

Recommended Posts

I have a good number of notes, but I'm sure others have even more.

 

When I'm typing into the search box at the top ("Search the current context"), and especially when my current context is all notes, as soon as I type a character, it starts to search, which immediately starts to slow down my typing as I try to type in the rest of the word that I'm looking for.

 

It would be nice if there was some sort of delay that holds off the search from beginning until I have finished typing the word the word and maybe a pause of 500ms or longer has occurred in my typing.

 

The reason I find this troublesome is that sometimes I'm typing and the searching activity delays my keystrokes, but I think that I just missed typing that key for some reason, which results in me actually double typing in the character, and the search string is updated and a new search begins and then I have to backspace, which seems to cause it to start searching for the shorter string as I'm making my corrections...  Bad user experience.

 

FYI, I'm on a Windows 7 PC with an Intel 64-bit Core i7, 8 GB RAM, so I don't think CPU usage should be an issue. Another option is to let the search threads run at a lower priority level and let the typing happen at a higher priority level so that your typing is unaffected by the CPU usage of the search that is running.

 

Just suggestions/ideas. Does anybody else have this happening to them?

 

Share this post


Link to post

That is awesome. Thank you Jeff. I should have been smart enough to look in the registry first, but I'm glad that I asked it here if it helps other people who want to solve the same problem and have control over that feature. I just bumped it from 50 to 500 and I'm much happier so far.

 

-mark

Share this post


Link to post

That is awesome. Thank you Jeff. I should have been smart enough to look in the registry first, but I'm glad that I asked it here if it helps other people who want to solve the same problem and have control over that feature. I just bumped it from 50 to 500 and I'm much happier so far.

 

-mark

 

Changing the Registry seems like a good work-around for EN Win, but since the Mac doesn't have a Registry (thank goodness!) we have no way of making this adjustment in EN Mac.

 

Also, the Windows Registry was not really designed as an end-user tool for setting preferences.  So what we really need for both EN Win and EN Mac is a EN Preference setting to change the Search-as-you-type setting.  Frankly, my preference would be to turn it OFF until I hit either the TAB or ENTER key.

Share this post


Link to post

×
×
  • Create New...