Jump to content
  • 0
jbignert

firefox Web Clipper 6 for Firefox - beta

Idea

Hi all,

We have a release candidate version for the new Firefox Web Clipper that we'd like to invite a few select people to start testing.

It is a complete re-write and doesn't share any code with the previous version so we expect some turbulence in the beginning. 

 

When you report issues please post your OS, Firefox versions, URL where an issue can be observed and as much details as necessary for us to reproduce the problem. 

 

Not expected to work in this version:

- Sharing 

 

Get the latest build here: 

https://addons.mozilla.org/en-US/firefox/addon/evernote-web-clipper/versions/

 

And feel free to post both design & performance feedback as well as straight up bugs. 

  • Like 1

Share this post


Link to post

Recommended Posts

  • 0

Well, Wikipedia clips broke again. Can't get anything beyond the title.  Same effect on a handful of other sites I frequent, while others clip same as before.  Did an update slip in there when I wasn't looking?  If so, how easy would it be to revert to previous versions so I can get back to work?

 

EDIT:

 

Well, it's only apparent with selective clipping. If I blindly clip the whole page without selection, it still grabs it.  Not sure what caused this change, but at least....(getting tired of saying this) ....there's a work-around.

Share this post


Link to post
  • 0

Hi all,

We have a release candidate version for the new Firefox Web Clipper that we'd like to invite a few select people to start testing.

It is a complete re-write and doesn't share any code with the previous version so we expect some turbulence in the beginning. 

 

When you report issues please post your OS, Firefox versions, URL where an issue can be observed and as much details as necessary for us to reproduce the problem. 

 

Not expected to work in this version:

- Sharing 

 

Get the build here: 

https://www.evernote.com/shard/s13/sh/2549631c-cebf-4b21-9518-95a2081bbc15/0c8e2fd9221398e819b141a600acf7dc

 

Note: The beta version will NOT update to newer beta's when they become available. That has to be done manually. 

 

And feel free to post both design & performance feedback as well as straight up bugs. 

 

Hi JB,

 

Well, I guess what you thought last year was a "Release Candidate" turned out to be an early Beta.

 

It is now rapidly approaching ONE YEAR since the above announcement.  Any chance we will get a solid, well performing, no-material-bugs production release any time soon?

 

I know you've been working hard, and I really appreciate your participation in the forum.  But, as you can see from the many above posts, we really need a solid V6 for Firefox very soon.  Yesterday would have been better.  ;)

 

Thanks for all your support.  I suspect the issue is lack of resources, out of your control.

  • Like 1

Share this post


Link to post
  • 0

Hi JM,

My biggest issue has been that its taken 4 months of waiting for a review by Mozilla. We submitted our new build in November 2014 and last week they started the review process which is required before it can be released to the public. We are now working on the final steps of the review process and it hopefully shouldn't be much longer until it gets approved. 

 

Obviously stability and 'solidity' is all on us and I think the most recent versions are good. 

 

At this point I recommend anyone who has been helping out testing our beta versions to uninstall then re-install from this location if you were previously using the manual download:

https://addons.mozilla.org/en-US/firefox/addon/evernote-web-clipper/versions/

 

This version will get you on the production release channel and future automatic updates once it gets approval from Mozilla. 

  • Like 1

Share this post


Link to post
  • 0

JB, thanks for the very quick and informative reply.  I had no idea that Mozilla takes 4 months just to start a review.  That seems very unreasonable.  

 

OK, based on your statement that "the most recent versions are good. ", I'll go ahead and update to it now.

 

Thanks again for all your hard work.

Share this post


Link to post
  • 0

JB, I have it installed, and have read the FF Extension description, but I'm still unclear about the difference between Sending to Web vs Sending to Desktop.

 

Is there anything in one that is missing from the other?

Share this post


Link to post
  • 0

Sending to Web creates the clip on the Evernote Web servers and only has access to your synched notebooks. It may also take somewhat longer depending on your connection etc. 

 

Sending to desktop creates clips in your local database within Evernote for Mac or Windows. Clips typically gets done faster and are then synced up at the next time your client syncs to the Web Service. 

For this setting you can also clip to local notebooks if you desire. But we do not have suppor for tags being added in the clipper UI in this mode and there are a few other things you don't get such as related notes, sharing etc. the entire post clip dialog f.a.e will not display (it matters to some but not all...)

 

With Sending to desktop the process for converting HTML to ENML is also a different codebase for technical reasons (this is one reason why developing for Firefox takes longer for us because we write this code for 2 versions essentially...) and in general the clip quality is somewhat worse when clipping to desktop. 

 

Going forward we will focus most efforts on the Sending to Web experience, so my recommendation is to use that one. 

 

Hope that helps, feel free to follow up. 

Share this post


Link to post
  • 0

OK, thanks for the detailed explanation, JB.  That was very helpful.

 

So, I guess I'm going with "Send to Web" based on these two statements:

 

. . . in general the clip quality is somewhat worse when clipping to desktop. 

 

Going forward we will focus most efforts on the Sending to Web experience, so my recommendation is to use that one.

 

Share this post


Link to post
  • 0

Well... i installed 6.0.11 and it seems it doesnt work at all. I dont see any button or context menu entry which triggers Web Clipper...

 

running on FF 38.0a2

Share this post


Link to post
  • 0

I installed 6.0.12 on FF 36.0.4 on Linux Mint Debian (LMDE) and no button as well, sure I tried to customize toolbar, but can't even see the evernote icon in the available shortcuts.

 

 

Well... i installed 6.0.11 and it seems it doesnt work at all. I dont see any button or context menu entry which triggers Web Clipper...

 

running on FF 38.0a2

Share this post


Link to post
  • 0

Thanks for providing the link to the new Evernote Web Clipper.

 

The new Web Clipper has some features which are very similar to Evernote Clearly. Is the intention to merge the two products? This would be nice, as it would simplify my browser. Less is more.

 

-= Stefan

Share this post


Link to post
  • 0

Hi,

 

And thanks for working on porting the evernote extension to FF.

 

I've been trying to install this extension on my laptop for a few months, but each time, the extension makes my browser completely unresponsive, I'm not even able to exit correctly and have to kill the process.

 

I'm using other extensions that may interfer, such as session manager, ABP, disconnect, Pocket, Omnibar, PassIFox...

I've tried to disable them but it didn't change the behavior.

 

Upon restarting the browser, it does the same thing, that is my whole browser is completely unresponsive.

 

I have to start the browser in sage mode to disable the extension before being able to use my browser again.

 

I have an important number of tabs open (+100) and I'm using groups (previously panorama) to organize then and not have everything loaded at once.

 

I'm a web developer, so if I can do anything to help investigate the issue, I'm all open to instructions. Is there any log file to check out which is the offending script / which line is causing the hang ?

 

Thanks in advance,

 

Mathis.

Share this post


Link to post
  • 0

Dear All,

 

I realised a difference between the Chrome and the Firefox Version that always makes me switch to chrome for easier use.

 

When Im on Facebook, and I save a photo to Evernote the following happens:

 

in Chrome: The title for the Note is the the title of the Facebook Page / Profile etc

in Firefox: The title of the Note is the picture name (10388633_488702011277301_270133631673027246_n.jpg)

 

Can that be changed?

Share this post


Link to post
  • 0

Hello, Using firefox 36.0.4 on windows 7, i just installed the latest beta clipper 6.0.15, I am unable to see the icon for the menu bar. 

 

If I go to customize, restore defaults, i see evernote web clipper in text, but the icon art is missing. If I try to drag this to the menu bar, it dissapears completely.  This done not happen with the standard install. Do you have any ideas of what i can do to get this back?

Share this post


Link to post
  • 0

I just got notice that FF Mac Ver 37.0 was just released.  Anyone running the latest EN Clipper on FF 37.0 Mac?

Share this post


Link to post
  • 0

I'm having trouble getting the clipper to work for me in Firefox. I'm running the latest version of firefox. I have reinstalled both firefox and clipper and I am running the latest version of Evernote. Anyone else having issues?

Share this post


Link to post
  • 0

What versions of OS, FF, and EN clipper are you running?

 

 

I'm having trouble getting the clipper to work for me in Firefox. I'm running the latest version of firefox. I have reinstalled both firefox and clipper and I am running the latest version of Evernote. Anyone else having issues?

Share this post


Link to post
  • 0

Hello, Using firefox 36.0.4 on windows 7, i just installed the latest beta clipper 6.0.15, I am unable to see the icon for the menu bar. 

 

If I go to customize, restore defaults, i see evernote web clipper in text, but the icon art is missing. If I try to drag this to the menu bar, it dissapears completely.  This done not happen with the standard install. Do you have any ideas of what i can do to get this back?

 

 

HI everyone, i solved my problem. this has to do with your History settings.

 

If you choose not to remember history, the icon does away. 

 

Also, if you choose to run in private browsing mode, it is also not avaiable. 

 

so, i now use a custom history setting.  i hope someone can use this info. 

  • Like 1

Share this post


Link to post
  • 0

I am experiencing the same behaviour as noted by matgardon above.

 

I recently switched from the old clipper to the new. Once I installed, Firefox experienced a massive increase in the amount of RAM and CPU it uses; even with 35% of my cpu and over 2 gigabytes of memory, firefox is unresponsive.

 

It is clear that the new Evernote clipper is responsible for this behaviour.

 

I have a couple of hundred tabs "open" in Firefox, but I have the browser set to only load tabs once they are viewed. I can only imagine that Evernote is trying to load information about all of the unloaded tabs...

 

I am very happy with the design of the new clipper otherwise and I do hope that this issue can be addressed. I also tried to use Clearly, but the ability to use tags is essential.

 

Many thanks for all of your hard work.

Share this post


Link to post
  • 0

Thx for the feedback lsmmchug,

We are looking into the reports about excessive CPU usage. We did many fixes to mitigate that already but we'll look into if we missed something with the setting 'Load tabs once they are viewed'.

Share this post


Link to post
  • 0

FYI, I also tested the extension on 2 different i7/8gb/SSD machines (from work), both with 100+ tabs open and splitted into FF groups (thus not loaded all at once, maximum 10 tabs per group), and the behavior is pretty similar to my previous report, with too much CPU usage and an unresponsive FF, sometimes with the evernote icon not even appearing in the upper bar.

 

A few of my colleagues tried to install the new extension on their FF, but none succeeded, with problems similar to mine or similar to other reports in this thread.

 

I'm afraid the extension may not pass the FF plugin validation step with those problems still there :-/

 

Again, I'm a web developer and can investigate or send you specific logs / profillings etc if needed.

Share this post


Link to post
  • 0

A quick note: I am running FF 37.0.1; in the FF options dialog, under the "Tabs" tab, the option is called "Don't load tabs until selected."

  • Like 1

Share this post


Link to post
  • 0

FYI, I also tested the extension on 2 different i7/8gb/SSD machines (from work), both with 100+ tabs open and splitted into FF groups (thus not loaded all at once, maximum 10 tabs per group), and the behavior is pretty similar to my previous report, with too much CPU usage and an unresponsive FF, sometimes with the evernote icon not even appearing in the upper bar.

 

A few of my colleagues tried to install the new extension on their FF, but none succeeded, with problems similar to mine or similar to other reports in this thread.

 

I'm afraid the extension may not pass the FF plugin validation step with those problems still there :-/

 

Again, I'm a web developer and can investigate or send you specific logs / profillings etc if needed.

 

As much as I can see (using about:memory) the problem is that the web clipper creates three windows, event targets & event listeners per tab (whatever the tab is loaded or not), and causing a lot of heap allocations [that do seem like a mem leak of sorts] along the way.

 

The CPU usage climbs peaks to 100% in three cases - on initial launch, on oppening a new tab and when another mem allocation occurs and firefox pages out (which happens quite a lot - as I see a mem usage increase of about ~6GB after enabling the web clipper).

 

Edit: Here is a Firefox memory report, after enabling the web clipper and minimizing memory.

Share this post


Link to post
  • 0

It's been more than 2 weeks without any news, is this issue still under investigation ? Can we expect something at some point ? Is the code open source so that we can fix it ourselves if evernote is not willing to take care of this ?

Share this post


Link to post
  • 0

We're still working on it. What issues are you affected by?

The code is not open source. 

Share this post


Link to post
  • 0

My main issue ATM is the one discussed in all previous posts : CPU usage climbing to 100% when opening my browser with extension enabled OR enabling the extension when browser already loaded, making my whole computer completely unresponsive until I kill my browser and restart it in safe mode to disable the extension.

 

So, considering I cannot use the extension, I can't really list any other "basic use case issue" at the moment.

 

I'm a heavy evernote web clipper user, and for this reason only I keep a chrome tab open at all times, and I have to switch to it everytime I need to clip something from the web : it's either that or using a really limited and deprecated v5 extension on firefox. 

 

As you can see, the situation is not ideal.

 

My configuration may differ from nominal case only for the reason already stated multiple times above by Drag0nR3b0rn, Ismmchug & myself : I have a lot of tabs open in tab groups, but not much tabs open at any given time as I split them in a lot of groups to prevent heavy memory & CPU usage (FF option "do not load tabs until selected" enabled).

 

I'm available for any further investigation if needed.

Share this post


Link to post
  • 0

FYI, the user reviews of this extension (6.0.15) on the firefox add-on page lists many users with a similar problem, for example :

 

"Well, I have to say that the functionality that it provides is pretty nice and certainly helps with gathering information versus manually doing it. However, the way the add-on was implemented drags my browser into the performance realm of a snail and I have a 4th gen Core-I7 with 32GB of ram.

Hopefully they can address this issue, but until then I have to leave this add-on disabled."

 

----------------------

 

"Restoring my session without this addon installed takes 20-40 seconds (I have way too many tabs). With it installed it take 3-6 MINUTES? wtf?"

 

---------------------

 

"The worst part of this add-on, and the reason why I removed it, is that if you have a lot of tabs, it will bring Firefox to grinding halt due to ridiculously large memory and CPU usage, even after a restart, when Firefox doesn't actually load the tabs until they are selected by the user.

Functionally, the interface is based on a pop-up window that is shown when the Evernote button is clicked, but disappears whenever you click outside of it. What's the point of highlighting the content that is being clipped, if you can't scroll and see the extent of the highlighting, when the content is long?"

 

----------------

 

 

And this is just taken from the first page !!! So if I had to guess, i'm not the only user with this problem ... And if you had a userVoice or some platform to tracks bugs & feature requests (just a suggestion), I'd guess this bug would show up on the top of this list.

  • Like 1

Share this post


Link to post
  • 0

The web clipper is no longer showing up in the context menu of firefox on Mac. I've installed the latest beta from the first page of this thread and that's not working either. Suggestions?

Share this post


Link to post
  • 0

The web clipper is no longer showing up in the context menu of firefox on Mac. I've installed the latest beta from the first page of this thread and that's not working either. Suggestions?

I had the same issue under Linux. You were signed out. Click on the toolbar button, it'll ask you to log back in. After that you'll see the Evernote options in the context menu.

Share this post


Link to post
  • 0

 

The web clipper is no longer showing up in the context menu of firefox on Mac. I've installed the latest beta from the first page of this thread and that's not working either. Suggestions?

I had the same issue under Linux. You were signed out. Click on the toolbar button, it'll ask you to log back in. After that you'll see the Evernote options in the context menu.

 

Thanks for the reminder. That has happened to me before and this time, like last time, the sign in area within the toolbar was greyed out and unavailable to sign in. I was able to sign in the right Evernote sidebar in google search results.

Share this post


Link to post
  • 0

If I add the Web-Clipper from Firefox, wil my info from  Windows Evernote Preium transfer over from  the Firefox version? If not, what can be done?

 

Share this post


Link to post
  • 0

Yes, your account info and access will be accessible from the FireFox EN Clipper.

The first time you use it, you may have to log in to your EN account.

 

 

If I add the Web-Clipper from Firefox, wil my info from  Windows Evernote Preium transfer over from  the Firefox version? If not, what can be done?

  • Like 1

Share this post


Link to post
  • 0

I'm using the latest web clipper and am having the same problem is the person quoted; CPU usage on OSX (very latest Mavericks) goes through the roof. I've disabled the clipper and Firefox works great again. Evernote and webclipper have been part of my workflow for many years and I hope there is a fix soon. Is anyone else still having this problem with multiple tabs open?

 

Latest 38 and latest web clipper from their extension site.

 

 

 

FYI, I also tested the extension on 2 different i7/8gb/SSD machines (from work), both with 100+ tabs open and splitted into FF groups (thus not loaded all at once, maximum 10 tabs per group), and the behavior is pretty similar to my previous report, with too much CPU usage and an unresponsive FF, sometimes with the evernote icon not even appearing in the upper bar.

 

A few of my colleagues tried to install the new extension on their FF, but none succeeded, with problems similar to mine or similar to other reports in this thread.

 

I'm afraid the extension may not pass the FF plugin validation step with those problems still there :-/

 

 

Share this post


Link to post
  • 0

Thank you for the useful, effective advice: a quick improvement when I installed the version recommended in jbignert's post.

 

In addition, I commend the civility in the string of posts, especially those of jbignert and Viv Ilo Veith.  Too bad this is not common.

 

Thanks.  - Tom Figel

Share this post


Link to post
  • 0

1,5 year, still it not working :) Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://e0b8c461-f8fb-49b4-8373-fe32e9252800/web_clipper/lib/net.js :: sendXhrBinary :: line 97"  data: no]

Share this post


Link to post
  • 0

Hi.  So when you say 'still not working',  does that mean you can't install it,  upgrade it,  clip a specific web page or clip any web page?

Share this post


Link to post
  • 0

Hi. i have last version (%Version:%6.0.15), I can't clip article as simplified article (not all web page). I'm getting error, as shown in my previous post.

Otherwise I like Evernote very much

Share this post


Link to post
  • 0

I noticed there is a difference in notes being clipped with the Chrome webclipper and the Firefox-clipper, specifically Wikipedia articles. Is this a normal things to be happening? Or is this perhaps a bug?

Share this post


Link to post
  • 0

Hi.  Any differences will be down to the different browsers and clipper functions.  Chrome being -I believe- a mini operating system,  it's possible to do more within it for instance than with the relatively locked-down Firefox.

 

If you prefer one to the other,  you could report differences back as a feature request to see whether Evernote can add better functionality to one or the other.  If you're solely concerned about the appearance of your clips - just stick to one browser if you can.

Share this post


Link to post
  • 0

Can someone explain why the reminder from webclipper is missing on firefox. I have used chrome and there once I save a clipped article there is a window that shows up after the article is saved. there is  a small clock icon to set reminder directly from that window. Now I just found out that it is not available on firefox. Very disappointing! EN's Firefox extension is nothing...

Share this post


Link to post
  • 0
7 hours ago, Taziz said:

Can someone explain why the reminder from webclipper is missing on firefox. I have used chrome and there once I save a clipped article there is a window that shows up after the article is saved. there is  a small clock icon to set reminder directly from that window. Now I just found out that it is not available on firefox. Very disappointing! EN's Firefox extension is nothing...

Hi.  Different clippers in different browsers have different capabilities,  based on how easy it is to achieve certain operations in the mini operating system that runs the browser's add-ins.  Chrome is a complete OS in itself,  so has the most functionality.

-And please don't cross-post.

Share this post


Link to post
  • 0
5 hours ago, gazumped said:

Chrome is a complete OS in itself

@gazumped:  I think you are confusing the Chrome Browser with the Chrome OS.  They are completely different.

The Chrome Browser is NOT an operating system, not even a "mini-OS".  It is a web browser just like  FireFox, Internet Explorer, Safari, etc.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...