Jump to content
DN34

windows 8 OCR - suddenly stops working on desktop client

Recommended Posts

Curiously, OCR was working fine on a notebook with images in it, then stopped working suddenly, but Evernote online OCR works fine.   I have a premium account.  Anyone know why this would happen? 

Share this post


Link to post

Sorry but that doesn't make sense - OCR doesn't ever work on your desktop, notes are OCR'd online (unless you do it yourself when scanning) and the indexed notes are saved to desktop.  If it works online,  it should be working locally. I'm guessing that your search isn't working on the desktop client,  which is a different issue.  Is your desktop syncing with the server OK?  Have you exceeded your monthly upload allowance?  Can you give more details about this issue?

  • Like 1

Share this post


Link to post

Desktop client is syncing fine.  I am also under the monthly allowance limit by a wide margin.  Running latest updated version of EV.  

 

If I do a search on the desktop client it will not return results from an image, but it will work fine online.   However, it used to work just fine on the desktop.  Nothing has changed between the time it was working and stopped working.  

 

Very strange, if I figure it out I will update. 

Share this post


Link to post

OK - if you've not already raised a support request;  see below...

Share this post


Link to post

I did a complete shut down last night and this morning I opened the desktop client and the images are still not registering in searches.  In fact...just as I suspected I lost another note that used to be searchable.   

 

I originally had 3 different notes and at one point they were all searchable, then one stopped working and I thought nothing of it, then two stopped working and that is when I posted on this forum, finally today the third one stopped working.

 

I think I will open up a ticket and report back. 

  • Like 1

Share this post


Link to post

DN34,

 

Got the same issue on the first day of using the windows client. Created new note with an image from an android client - it is searchable through the web and android . After initial sync on the windows client it was searchable as well. After the second sync the attachments (images) change the status to un-indexed.

 

Pretty easy to reproduce, just exit from the windows client, delete the files from Users\<User name>\AppData\Local\Evernote\Evernote\Databases and start/login into the client. The note will be searchable. Now press the sync button again - search stops working and the status of attachments change to un-indexed.

 

If you already created the support request, this might help them to reproduce.

Share this post


Link to post

Olaf

 

I have not created the support request yet, but your reply reminds me to do so.  Doing it NOW. 

 

EDIT: I just created my ticket and referenced this post.  I hope there is a solution because this bug basically breaks OCR for the Windows client.  

Share this post


Link to post

I also just experienced this same issue today.  It was really weird.  I searched for a business card I saved long ago and was worried it was in Evernote.  Luckily the Evernote client found it based on some text in it that it OCR'd.  Then later in the day I could not find it again and panicked that somehow I had deleted it.  Then I logged into the website ran the search and it came right up.  Then I went back into the client software but this time searched for the title (which I knew since I found it with the web page) and it loaded but none of the text was in yellow and searchable.  My client app is fully updated to version 5.3.1.3363.

Share this post


Link to post

Hi guys,

 

Time for an update.  I was busy so I did not immediately return Evernote's reply.  They got back to me saying that they could not recreate the bug and asked for more info.  So I submitted the following album.  http://imgur.com/a/BHONA#0

 

I also explained that in order to recreate the bug, some amount of time needs to pass before the windows client no longer registers the images.  Just like how Royboy3 described above.  The online application remains working.  Furthermore, this only happens to some images.  

Share this post


Link to post

I also am having the same issue on win7 desktop client- multiple conversations with support has not gained a solution - no answers yet

Share this post


Link to post

If anyone is feeling keen enough it might be instructive to rename an existing database and recreate it from the server - which forces the index to be refreshed.  It takes a few hours if you have lots of notes (5,000+) and there are some precautions you need to take - please search the forums for more details for your specific OS.

Share this post


Link to post

Evernote just responded to my support request saying that they have now been able to replicate the bug on their end.  It is in their hands now, not sure how long it will take to sort this bug out, but if they update me I will update this post.    

  • Like 1

Share this post


Link to post

Great to have recognized the problem. Just when I decided to test Evernote already come across this situation. I'm also looking forward to the feature to scan business cards into the Android version ...

Share this post


Link to post

I am having this same problem on two different Windows 7 computers.  Search of OCR text on mobile app and web app work fine, but on my PCs it doesn't.  I can clear the database and allow it to be recreated to temporarily fix the issue, but the problem just comes back again (usually the same day).  Has anyone heard if there is a permanent is a fix for this?

Share this post


Link to post

I am having this same problem on two different Windows 7 computers.  Search of OCR text on mobile app and web app work fine, but on my PCs it doesn't.  I can clear the database and allow it to be recreated to temporarily fix the issue, but the problem just comes back again (usually the same day).  Has anyone heard if there is a permanent is a fix for this?

 

The only permanent fix I have is to run 4.6.7 as detailed here:

https://discussion.evernote.com/topic/58846-cant-search-ocr-in-en-for-windows/

It's frustrating since according to comments EN has been able to reproduce since April.

Share this post


Link to post

×
×
  • Create New...