Jump to content
jbenson2

windows (Archived) Any idea what evernoteNW.exe does?

Recommended Posts

Running Evernote Windows client version 5.2, but for the past couple hours, Evernote has slowed to a snail's pace. It takes over 30 seconds to click from one note to another note. And my hard drive is constantly running.

 

When I force Evernote closed, everything goes back to normal. Other programs run fine. The hard drive is quiet.

 

The task manager shows the two biggest memory usages are for:

evernote.exe

and

evernoteNW.exe

 

1.) Does anyone know what evernoteNW.exe does? I have not seen it before.

 

edit: even with Evernote shut down and closed (using the Evernote icon at bottom of screen), the evernoteNW.exe is still running according to the Task Menu.

 

 

2.) Just prior to the problem occurring, I changed the name of a notebook on my secondary Evernote account which is shared with my primary account. I wonder if the constant hard drive access was caused by this change.

Share this post


Link to post

Given it's location and the name/contents of the items around it, I would guess it is responsible for the Presentation Mode. That and the fact that when I start a presentation, that is when it is run :D

C:\Program Files (x86)\Evernote\Evernote\NodeWebKit

 

Seems it doesn't close when you exit presentation mode, but I see no issues like you do here, and it closes when I quit Evernote via the tray.

Share this post


Link to post

Thanks for the insight, spg SCOTT.  It makes sense. Appreciate the assistance.

 

Support is working on the other issue.

Share this post


Link to post

Hi jbenson2,

 

EvernoteNW.exe is a group of processes that run the annotation and presentation mode features. They should go away when you fully quit Evernote by File->Exit or CTRL+Q. If not, you can manually kill all of the EvernoteNW.exe processes and then restart Evernote.

 

You may see this issue if you use pre-release builds of presentation mode. Did you have presentation mode enabled when you saw the issue?

 

Thanks!

Share this post


Link to post

Hi jbenson2,

 

EvernoteNW.exe is a group of processes that run the annotation and presentation mode features. They should go away when you fully quit Evernote by File->Exit or CTRL+Q. If not, you can manually kill all of the EvernoteNW.exe processes and then restart Evernote.

 

You may see this issue if you use pre-release builds of presentation mode. Did you have presentation mode enabled when you saw the issue?

 

Thanks!

 

I believe you are correct. Because of the problems I've been having, Support asked me to install a pre-release.

 

Regarding the presentation mode - sorry, but I don't see any option to enable it.

Share this post


Link to post
If not, you can manually kill all of the EvernoteNW.exe processes and then restart Evernote.

 

I see three separate EvernoteNW.exe processes open.  Is three expected?

Share this post


Link to post

 

If not, you can manually kill all of the EvernoteNW.exe processes and then restart Evernote.

 

I see three separate EvernoteNW.exe processes open.  Is three expected?

 

I see three as well. Looking at them in ProcessExplorer, I can see that one instance is spawned by Evernote.exe, and 2 instances are spawned from that. They all have different command-lines, so they are all doing different things. One of the command-line sets indicates it's talking to my GPU.

Share this post


Link to post

 

If not, you can manually kill all of the EvernoteNW.exe processes and then restart Evernote.

 

I see three separate EvernoteNW.exe processes open.  Is three expected?

 

 

Yes, three are expected.  Sometimes killing one of them will also kill the other two, but you should make sure all three are gone before restarting Evernote.  This should only be an issue in pre-release builds of Evernote -- please let us know if you see this on public releases.  Thanks!

Share this post


Link to post
Buggy!!!Buggy!!!Buggy..

 

 

Even the latest beta is not working for annotation :

 

I don't know if there is a co-relation between bringing in Presentation Mode and annotating an image built into the Evernote client. But for the past few builds, this feature is just not working. The earlier release was throwing out an error - evernoteNW.exe and failing, while the latest beta, simply opens out the edit window, and it just keeps looping. The image doesn't even load.

 

I am willing to pardon the errors with Presentation Mode, since it is releatively new and might have some teething troubles, and after all, it is only a 'Bells and Whistles' feature. However, Image annotation is parallel to the core Evernote process.I am now forced to re-install Skitch for Windows, and open the image and annotate using Skitch. Releasing code with few bugs or teething problems is fine, but these are such essential services that how could they release new builds without even testing such essential services. ?

 

Unacceptable..

 

Build Release - 5.3.0.2999 (Pre Release )

 

P.S : I am sure that i may get vague replies like 'Evernote never said that Image annotation is not central to their workflow' (or) even some even more stupid ***** like Evernote is not even an Annotation Software. It is always better to ignore such replies. My message is clearly intended for people like Dlu, who i think has some senior position in development of the Windows Client. Well, never mind these kind of replies seen in the forum, but the underlying point was that many of us thought that things would improve, thanks to Phil Libin's message a few months ago. Sadly, I dont think things have improved much.

Share this post


Link to post

 

Buggy!!!Buggy!!!Buggy..
 
 
Even the latest beta is not working for annotation :
 
I don't know if there is a co-relation between bringing in Presentation Mode and annotating an image built into the Evernote client. But for the past few builds, this feature is just not working. The earlier release was throwing out an error - evernoteNW.exe and failing, while the latest beta, simply opens out the edit window, and it just keeps looping. The image doesn't even load.
 
I am willing to pardon the errors with Presentation Mode, since it is releatively new and might have some teething troubles, and after all, it is only a 'Bells and Whistles' feature. However, Image annotation is parallel to the core Evernote process.I am now forced to re-install Skitch for Windows, and open the image and annotate using Skitch. Releasing code with few bugs or teething problems is fine, but these are such essential services that how could they release new builds without even testing such essential services. ?
 
Unacceptable..
 
Build Release - 5.3.0.2999 (Pre Release )
 
P.S : I am sure that i may get vague replies like 'Evernote never said that Image annotation is not central to their workflow' (or) even some even more stupid ***** like Evernote is not even an Annotation Software. It is always better to ignore such replies. My message is clearly intended for people like Dlu, who i think has some senior position in development of the Windows Client. Well, never mind these kind of replies seen in the forum, but the underlying point was that many of us thought that things would improve, thanks to Phil Libin's message a few months ago. Sadly, I dont think things have improved much.

 

 

Are you seeing the issue when presentation mode is disabled? It is possible that the beta builds of presentation mode are conflicting with image annotation -- please try a clean start of the Evernote application (after a File->Exit) and only use image annotation -- and let us know if you still see the issue.

 

Thanks!

Share this post


Link to post

Annotation and Presentation Mode are working fine for me (5.3.0.2999 Prerelease).

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...