Jump to content
Sign in to follow this  
Yeraze

(Archived) PDF's in EverNote for Mac

Recommended Posts

When I'm at work I routinely email PDF's into EverNote, since I'm forced to use the Web Interface. However, I've recently noticed that when I get home and fire up EverNote on my Mac, about half the PDF's I've added that day do not preview. All I see is a generatic "Attached File" icon with the PDF name, and a "Quick Look" button.

Any idea what's going wrong here? I really liked seeing the first page of the PDF's in thumbnail view.

Share this post


Link to post

My best guess is that your mail client may not be sending the file type information correctly for the PDF files you're mailing. This means Evernote thinks those are "some random file" rather than PDF documents. I'd check to make sure that the files end in ".pdf" before you send them.

What mail client are you sending from?

Share this post


Link to post

I'm sending them from Microsoft Outlook.. They all end in pdf, and about half of them come through fine and half of them wind up as "unknown attachments". It's easy enough to fix on my mac, I can simply download the file & then drag-n-drop it back onto evernote to create a new note, that works just fine by then the note eats 2x my monthly allocation. I'm on premium, so I've got the 500MB so it's not _that_ big of a deal but it's annoying.

Share this post


Link to post

Ok, thanks for the report. Do you see any obvious difference between the files that are handled correctly vs. the ones that aren't? E.g. file name contains spaces or odd punctuation, different capitalization on ".pdf" vs. ".PDF", etc.? Anything obvious that stands out?

Thanks again

Share this post


Link to post

Nope, nothing, although I'm conducting an experiment currently that might yield some results.

My theory is that there is a difference between manually attached the PDF to an Email, and clicking the "Email PDF" button inside Acrobat which creates the email for me.

I've sent 3 or 4 emails to my evernote account, and I'll be able to login tonight and check out the results.

Share this post


Link to post

Nope, that's not it.. All the PDF's show up just fine.. Still no clue why some of the older ones won't show previews tho.

Share this post


Link to post

Ok, new theory: PDF's that are forwarded through an email address don't show up correctly. This problem started when I created a GMail Filter rule using the special "+junk" syntax to forward email into evernote, so I didn't have to remember the autogenereated address. PDF's sent directly to Evernote seem to come in find, but PDF's that I Forward to evernote (Either by clicking "Forward" in Outlook, or using the gmail rule to do it automatically) don't come through correctly.

To replicate:

1) Get a PDF.. Email it to Yourself & Evernote directly.

2) Fire up client (Mac client for me) and Sync.

3) See your PDF preview working just fine.

4) Take the email you just received, from yourself, and Forward it to Evernote.

5) Fire up client, and Sync.

6) See the PDF show up as an unknown attachment, with the black paper icon.

So something is getting mangled in Forwarded emails. As it seems to be email-agnostic (I repeated this with GMail & Outlook), I think it's something on Evernote's end.

Share this post


Link to post

Not just an email problem. I get this when I select 'print' for a webpage and select 'pdf to evernote' (using safari and EN for Mac). I'm just full of previews now, which is not ideal on the move when viewing from an iPhone.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...