Jump to content
mattbytes

windows (Archived) Beta 5.2 - Search Using Tags Issue

Recommended Posts

When I use the search bar to perform a search using tag + keyword, it searches using keyword only.  For example, I have several articles tagged as gmail.  So if I want to search for articles tagged as gmail with a calendar keyword, Evernote will display everything with the keyword.

 

"tag:gmail calendar"

 

Perhaps my syntax is wrong?

Share this post


Link to post

That's the correct syntax. I just tried a search, and this works fine. You might want to open up the search explanation panel to see what Evernote thinks it's searching for (View / Show Search Explanation).

Share this post


Link to post

Thanks for that! It was adding any: to my query instead of all:

 

I think this is a bug.  In prior versions, the default search was that ALL terms must be matched, UNLESS the user specifically entered "any:" at the beginning of the search box.

Share this post


Link to post

Now why does it keep defaulting to any:??  Can I change this behavior?

I'm not seeing this behavior. See whether F6 will clear the "any:" setting.

Share this post


Link to post

Yes, F6 works.  I think I know what's causing this now.  I have a Shortcut that has "any:".  This basically replaces the all notes shortcut that I used to have prior to v5.  Anyway, when I select the All Notes shortcut and then enter the tag+keyword, that's when it inserts any:.  Keep in mind, any: doesn't appear in my search bar so I think this is still a bug.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...