Jump to content
Tim Nicholls

Evernote 5.5 for Mac - Descriptive search not working?

Recommended Posts

I am running Evernote 5.5 (402491 Direct) on Mac OS X 10.9.1 and have been trying to get the new descriptive search feature to work. I have tried various searches using the syntax described in the blog post and each time get no results and none of the "Are you searching for" suggestions shown. Instead the search highlights notes/content containing text in the search string and the search pop-up shows only "Search suggestions appear here" - see attachment.

 

Are any configuration steps needed to make this feature work?

 

Thanks!

post-180110-0-64071200-1391687129_thumb.

Share this post


Link to post

Using exactly the same syntax as you, I was able to achieve the desired result. I even tried using it with a different letter case (using 'anaerobic', which is incorrect case for the tag 'anaerobic digestion'). See screenshot below:

https://www.evernote.com/shard/s25/sh/11afb5cd-a6ad-4d8d-becf-1112764c42e5/c26f219d42a51a5b8977beed418ed63d

 

It seems like you have done everything right, at least with the information we have here!

 

I have not done any configuration or anything like that in order to make it work. Have you tried:

1) Closing and re-opening the application (full close, cmd-q)

2) Perhaps you need to log out, then back in (Not sure why, but troubleshooting instincts tell me this might help)

Share this post


Link to post

Scott,

 

Thanks for the feedback. It's encouraging I'm not doing anything wrong. I've tried restarting Evernote and signing out of my account and back in again, with no change.

 

Am I likely to get a response from Evernote on this forum (my first posting) or do I need to file a support request?

 

Tim

Share this post


Link to post

Scott,

 

Thanks for the feedback. It's encouraging I'm not doing anything wrong. I've tried restarting Evernote and signing out of my account and back in again, with no change.

 

Am I likely to get a response from Evernote on this forum (my first posting) or do I need to file a support request?

 

Tim

You need to file a support request.

Share this post


Link to post

Request submitted, thanks.

 

Let us know how it turns out. I'd be interested to hear the explanation.

Share this post


Link to post

If you don’t type anything but just click in the search field, do you see the ‘You can also search by…’ section at the bottom of the popup?

I’m just wondering whether descriptive search is completely disabled for you, or just for this particular search.

Share this post


Link to post

If you don’t type anything but just click in the search field, do you see the ‘You can also search by…’ section at the bottom of the popup?

I’m just wondering whether descriptive search is completely disabled for you, or just for this particular search.

 

No, I don't see that either. Descriptive search seems to be completely disabled, I don't see it with any search terms.

Share this post


Link to post

I am having same issue using new natural language search on two separate Macs, same account. 

 

Updated Mac Air on 10.9.1. restarted. No luck. Updated family's iMac, 10.9.1. Same behavior on both machines.  Type in new search commands, and I get odd results (very few results or none at all).  I do see the new suggested search examples in the drop down. I'll submit a ticket to support. 

 

 

Update:  If i type slowly, I found if I stop at "Notes tag" --- right there, the suggestions come up. But, if I type "Notes tagged", as soon as I hit the second g in tagged, the new search suggestions disappear!

 

Notes tag

http://d.pr/i/bTJ7

 

Type in one more g (tagged) and suggestion goes away

http://d.pr/i/9Vha

Edited by Clarknet

Share this post


Link to post

I am having same issue using new natural language search on two separate Macs, same account. 

 

Updated Mac Air on 10.9.1. restarted. No luck. Updated family's iMac, 10.9.1. Same behavior on both machines.  Type in new search commands, and I get odd results (very few results or none at all).  I do see the new suggested search examples in the drop down. I'll submit a ticket to support. 

 

 

Update:  If i type slowly, I found if I stop at "Notes tag" --- right there, the suggestions come up. But, if I type "Notes tagged", as soon as I hit the second g in tagged, the new search suggestions disappear!

 

Notes tag

http://d.pr/i/bTJ7

 

Type in one more g (tagged) and suggestion goes away

http://d.pr/i/9Vha

I have noticed very similar behaviour to this as well. 

Share this post


Link to post

I've had some interaction with Evernote support over the last few days through the ticket I posted. After trying several steps to resolve the problem, including deleting and reinstalling Evernote and sending a screen capture video of the problem, they have come to the conclusion this is due to a bug in the current version. A bug report has been filed and this will hopefully be resolved in an upcoming release.

 

If I hear any more from them I will post an update here.

Share this post


Link to post

Just in case anyone else runs into this: Descriptive Search will not work if your preferred language is set to Australian English, British English, Canadian English or US English.

We already have a fix for this, but as a workaround, you can set your system’s preferred language to “English”.

Many thanks to Tim for helping identifying this issue.

  • Like 1

Share this post


Link to post

Shepard, thanks for the update. I assume you are talking about the OS's settings. Mine is set to "English" in Sys Preferences.  http://d.pr/i/MraF   I still have the issue. 

Share this post


Link to post

Just in case anyone else runs into this: Descriptive Search will not work if your preferred language is set to Australian English, British English, Canadian English or US English.

We already have a fix for this, but as a workaround, you can set your system’s preferred language to “English”.

Many thanks to Tim for helping identifying this issue.

 

Thanks Adjusting! That resolved the issue for me. Though, I've change my language setting back and will wait for the update - it's nice to know what the issue is though.

Share this post


Link to post

Well, I have to say that I am very surprised that when I tried the exact search suggested in the Release Notes it did NOT work as expected.

 

My Search:  "notes with PDFs"

 

The Results were Notes that contained the text "notes with PDFs" instead of Notes that had a PDF attachment.

 

Yes, I did see the suggestion in the dropdown of "Notes with PDF Files", which does work when selected.

 

But that is NOT how the Descriptive Search was described during the Beta testing.

If you want the User to select from the Dropdown list AFTER typing in the Search box, then I suggest that you provide that exact instruction in the Release Notes and Evernote documentation (if any exists).

 

Release Notes:

 

 

Version 5.5 (02/04/2014) build 402489 

New Feature: Descriptive Search
Find what you want in the most natural way ever. Search your notes by place (“Tokyo”), file contents (“Documents” or “Images”), date ranges and more.
Searches to try:
"notes with PDFs"
"notes from Paris"
"recipes created last week"
This feature is currently available in English only.

 

Share this post


Link to post

Descriptive Search does NOT properly interpret tags containing decimal point, with or without quotes.

 

Search-EN5.5-Tag.gif

 

I also tried:

  • notes with "sym.slv"
  • notes tagged with sym.slv
  • notes tagged with "sym.slv"

Of course I have verified that I have notes with the tag "Sym.SLV"

 

EDIT:

It is VERY important to me that this type of search work, since I have MANY, MANY tags that contain "."

I consistently use the decimal point to name/organize my many tags.

Edited by JMichael

Share this post


Link to post

OK, I'm finding the Desc Search very frustrating.  NOT intuitive at all.

 

How would I do a complex search like:

Notes with TAGS tagA, tagB BUT NOT TAG tagC that contains TEXT macbook air

Share this post


Link to post

BUG:  Can't Clear Tag Filter

 

I was testing the Desc Search, and did a Tag Filter.  But now I can't clear it.

I cannot find any way to show ALL my notes.  I have nearly 10,000 notes.

Clicking on the "Clear" button does NOTHING, and the "Clear Tags" button is missing.

 

Cant-clear-tags.gif

Share this post


Link to post

Descriptive Search does NOT properly interpret tags containing decimal point, with or without quotes.

 

Search-EN5.5-Tag.gif

 

I also tried:

  • notes with "sym.slv"
  • notes tagged with sym.slv
  • notes tagged with "sym.slv"

Did you try “notes tagged sym.slv”? (without quotes)

Share this post


Link to post

OK, I'm finding the Desc Search very frustrating.  NOT intuitive at all.

 

How would I do a complex search like:

Notes with TAGS tagA, tagB BUT NOT TAG tagC that contains TEXT macbook air

 

Descriptive search does not currently support this query. Not because it is too complex, but because descriptive search does not have support for negative searches yet.

Share this post


Link to post

 

Descriptive Search does NOT properly interpret tags containing decimal point, with or without quotes.

 

Search-EN5.5-Tag.gif

 

I also tried:

  • notes with "sym.slv"
  • notes tagged with sym.slv
  • notes tagged with "sym.slv"

Did you try “notes tagged sym.slv”? (without quotes)

 

 

YES.  That's my second example above.  LOL

Share this post


Link to post

 

OK, I'm finding the Desc Search very frustrating.  NOT intuitive at all.

 

How would I do a complex search like:

Notes with TAGS tagA, tagB BUT NOT TAG tagC that contains TEXT macbook air

 

Descriptive search does not currently support this query. Not because it is too complex, but because descriptive search does not have support for negative searches yet.

 

 

Adjusting, can you please provide comprehensive documentation of the Descriptive Search with many examples, and what doesn't work now, but is planned?

 

Thanks.

Share this post


Link to post

 

 

Descriptive Search does NOT properly interpret tags containing decimal point, with or without quotes.

 

 

I also tried:

  • notes with "sym.slv"
  • notes tagged with sym.slv
  • notes tagged with "sym.slv"

Did you try “notes tagged sym.slv”? (without quotes)

 

 

YES.  That's my second example above.  LOL

 

No. Your second example is “notes tagged with sym.slv"

Share this post


Link to post

 

 

 

Descriptive Search does NOT properly interpret tags containing decimal point, with or without quotes.

 

 

I also tried:

  • notes with "sym.slv"
  • notes tagged with sym.slv
  • notes tagged with "sym.slv"

Did you try “notes tagged sym.slv”? (without quotes)

 

 

YES.  That's my second example above.  LOL

 

No. Your second example is “notes tagged with sym.slv"

 

 

Sorry, overlooked the "with".

But it still does NOT work.

Yields same result as the image of results of my original post:

 

Search_EN5.5-Tagged.gif

Share this post


Link to post

×
×
  • Create New...