Jump to content
OwenKelly

windows 8 Evernote (Not Responding)

Recommended Posts

I am using Windows 8.1 on an Asus Zenbook.

 

For the past few versions of Evernote I have had times when the application has got stuck, with the title bar saying Evernote (Not Responding). In the past this has usually fixed itself after thirty seconds or so. The latest upgrade, which arrived this week, has made the program completely impossible to use for me. It is now "not responding" almost every time I try to do something, and it is not always recovering. 

 

I have just reinstalled the application and tried to open it, and it has got stuck not responding at the point where it says in the bottom right corner "Synchronizing Promotions: 100% done". It has been stuck for five minutes. I have now told Windows to close it. I have closed it in the system tray. I have now reopened it. It has opened immediately straight to the notebook I was in last time it worked. I have clicked on a note in the notebook to open it. It has gone into Not Responding again.

 

Is anyone else having this problem?

 

I use Evernote every day, many times a day, on both my laptop and my iPad. I am a premium customer and have been for several years. Evernote is important to me! Does anyone have any suggestions, tips - and is this a recognised bug?

 

Any help appreciated,

Owen

Share this post


Link to post

Okay, done it!

 

I am still interested in whether anyone else has been having this problem, though, because I remember it being mentioned a while back in the beta group.

 

Cheers

Owen

Share this post


Link to post

I am using a  Asus desktop with Windows 8.1 and cannot get the Evernote 5.1 to work.  It downloads and then when you try to open it, it won't respond.  The Evernote touch works, but the desktop version won't.  I wrote Evernote support but haven't heard back from them.

Lisa

Share this post


Link to post

I am using a  Asus desktop with Windows 8.1 and cannot get the Evernote 5.1 to work.  It downloads and then when you try to open it, it won't respond.  The Evernote touch works, but the desktop version won't.  I wrote Evernote support but haven't heard back from them.

Lisa

 

Hi - welcome to the forums.  There seems to be quite a body of people who can't get Evernote Touch to work but Desktop will - you're bucking the trend...

 

Support work weekdays and prioritise premium and business users,  though you should get a support reference within a few hours.  If you didn't get a reference,  please report your problem again (see below).  Meantime I'd suggest using Revo Uninstaller to remove all traces of Evernote from your system,  and do a clean reinstall from scratch.  If you have any unsynced or purely local notes please have a search around here for details of how to backup your data first.

Share this post


Link to post

Same problem here, runing Windows 8.1 and the latest version of evernote for desktop. Loads then takes another couple of mins before the "not responding" disapears and I can then use the prog. I'll try re-installing.

Share this post


Link to post

Hello,  I'm getting this problem too (in Windows 7) with the latest version of Evernote (as at 16/4/2014).  Usually (but not always) happens when I open a note in a separate window about 5 minutes later.  Also happened once when I opened "About Evernote" and twice when I was doing nothing at all with it - just open in the background.  There must be a conflict with something else either in the Windows system or another app on my laptop.  Obviously I can use the online version in a browser but the app is good to have when I can't get on line.  No solution so far from the Evernote help desk

Share this post


Link to post

I had a ticket running on this,  and most likely cause for my situation (I believe) was the background auto-indexing that goes on locally for the search function to work.  

 

That process was improved in the last update which seems to have shortened the period for which my Evernote locks up,  and reduced the number of occasions;  but it is still happening,  so I hope there's more tweaking going on in a dark room somewhere...

Share this post


Link to post

Evernote updated today and "Not Responding" does not seem to last as long as it did with the prevoius version as Operative mentions above. However, it does not make much sense to return a "Not Responding" when it appears to be doing something.

 

Confused from Gloucestershire

Share this post


Link to post

Evernote updated today and "Not Responding" does not seem to last as long as it did with the prevoius version as Operative mentions above. However, it does not make much sense to return a "Not Responding" when it appears to be doing something.

 

Confused from Gloucestershire

 

Hi!  I'm just down the road (and across the border) from you in Newport..  I think the 'not responding' equates to "stop bothering me, I'm busy"..

Share this post


Link to post

I seem to have finally solved this problem, at least the version I have been suffering, so I thought I should post here to tell people.

 

A week ago I decided for entirely unrelated reasons to reformat the disk where Evernote saves its data. (I have it set to save to the root level of a D drive.) Before I did this I attempted to copy the Evernote folder to avoid having to download it all again. I made several attempts and at each attempt it stopped copying at 59%.

 

Eventually I gave up, reformatted the dsik, and left Evernote to download all my data again.

 

From that point on Evernote has worked perfectly. I have not had one occurence of "not responding" in the last seven or eight days, and I have been using EN at least three or four times a day. I can only conclude, therefore, that something in the Evernote data folder had become corrupted, preventing the database from being copied and playing havoc with the application whenever it tried to access the database.

 

I have no idea if forcing EN to redownload its database will solve every occurence of the "not responding" issue, but it certainly appears to have solved mine.

 

Cheers

Owen

Share this post


Link to post

Thanks for the input @OwenKelly - as a general rule either a clean reinstall of the desktop Evernote app,  using something like Revo Uninstaller to remove all the tortured history of your current installation,  and/ or a re-download of your database from the server will cure a lot of problems.  You should always backup your database before you replace it (unless as in your case it's completely unbackuppable) and ensure that you export any local notebooks or unsynced notes,  otherwise you'll lose the data.  The downside of a database reinstall is that it can take a long time if you have a lot of notes or if your connection is slow.  You'll also see us recommending regular local backups of your database which in this case for example would have raised warning flags as soon as the backups started to fail because the file was unreadable.

Share this post


Link to post

I'm having this problem as well.  I use Evernote on OSX, iOS, and Android, and just updated my PC to Windows 8.1 and installed the desktop version of Evernote.  I have a long text note with an inventory of items in a collection and it opens immediately in Android, OSX, and iOS.  But on Windows 8.1, Evernote stops responding when I click on this note.  If I wait several minutes control eventually control comes back to me, but if I click on the note to open it in its own window once again Evernote (latest version, I just downloaded it and installed it on a fresh WIndows 8.1 installation) stops responding for many minutes (I have yet to get control back in that instance), still waiting.

This is a long note (only text, though -- no attachments), but all those other OSes (including mobile devices with presumably less memory and processor than my Windows machine) can open this note without problems.

Share this post


Link to post

Well the problem persists for me too.  I'm in a dialog with Evernote support who have been great so far if a little slow.  I've done everything: reinstall, clean install, deletion and rebuild of databases, previous version current version but, whatever I do, the "not responding state" returns (I'm using Windows 7 SP1 all fully up to date).  I've just done some investigation for Evernote support and sent them the entire Evernote folder for analysis.  The only thing I can see is that, in the log folder, the Evernote clipper log consistently reports an error but, because clipper is integrated with the latest version of Evernote, I can't uninstall it. 

 

I await the support response with interest.   In the meantime I can safely use Evenote in a browser but having the offline app is a huge benefit for the occasions when I can't get on line.  Looks like a bug to me.

Share this post


Link to post

I exited the non-responding, Closed the sync down in the right taskbar area.  And reran the installer.  (Yes, Outlook is on this computer, it required me close it to finish the install, so I suspect there is the collision.)

 

Its working . . . for now.  I guess my one remaining question.  Several (in other forum entries) mention "turn off indexing".   (You mean indexing inside Evernote?  Because I don't see that in any option area.)

 

---

(update) . . . nope, about 15mins later, brought it full screen from the task bar and . . . spinning circle.  Its not-responding again.

 

Guess I'll just stick to the web version.

Share this post


Link to post

I exited the non-responding, Closed the sync down in the right taskbar area.  And reran the installer.  (Yes, Outlook is on this computer, it required me close it to finish the install, so I suspect there is the collision.)

 

Its working . . . for now.  I guess my one remaining question.  Several (in other forum entries) mention "turn off indexing".   (You mean indexing inside Evernote?  Because I don't see that in any option area.)

 

---

(update) . . . nope, about 15mins later, brought it full screen from the task bar and . . . spinning circle.  Its not-responding again.

 

Guess I'll just stick to the web version.

 

Not sure what others mean by 'turning off indexing' - that's kind've how Evernote finds your notes,  so indexing is a bit important.  Windows does quite a bit of indexing if you have that option turned on,  and you can turn off Windows attempts to index your files for 'faster' finding if you search - there's a lot on the web about that and I can only advise you to do some research if you want to try switching it off.  If you're on a work computer that's a non-starter as the IT staff will get quite excited if you mess with the settings (even if you can).

 

Rather than submit to the mercies of the web client on a full time basis I'd strongly recommend that if you have a problem you raise a support ticket (see below).  You'll get to do a whole lot of annoying standard stuff that may or may not help your situation immediately,  but longer term it will mean the techs have enough information to finally kill this particular bug.

Share this post


Link to post
I have had this "not responding" issue for a while (see earlier posts in this topic).  After some helpful exchanges with Evernote Support, I backed up all my notes, deleted all the notes from the Evernote app  on my laptop and from the Evernote web service - basically going back to the very start, a clean slate.  Did another clean reinstall of the Evernote windows app, starting adding all sorts of content and it has been stable ever since for about a month.

 

I sent the original Evernote data folder to the support team and they were able to replicate the problem I had been experiencing.  It seems that there is something about some of the notes that initiates this bug.  These notes had come from an earlier version.  I asked Evernote to let me know what they think had been going on but, so far, have not heard anything.

 

So, if you are still experiencing this problem, a cleanout and a re-start from scratch might be the answer.

Share this post


Link to post

 

I have had this "not responding" issue for a while (see earlier posts in this topic).  After some helpful exchanges with Evernote Support, I backed up all my notes, deleted all the notes from the Evernote app  on my laptop and from the Evernote web service - basically going back to the very start, a clean slate.  Did another clean reinstall of the Evernote windows app, starting adding all sorts of content and it has been stable ever since for about a month.
 
I sent the original Evernote data folder to the support team and they were able to replicate the problem I had been experiencing.  It seems that there is something about some of the notes that initiates this bug.  These notes had come from an earlier version.  I asked Evernote to let me know what they think had been going on but, so far, have not heard anything.
 
So, if you are still experiencing this problem, a cleanout and a re-start from scratch might be the answer.

 

 

Thanks for the feedback - please remind Support for more information if you can and/ or post your ticket number here so we can get someone to follow up.

 

Did you export your notes to ENEX and then re-import them?  Or just start over from scratch?

Share this post


Link to post

 

Did you export your notes to ENEX and then re-import them?  Or just start over from scratch?

 

Yeah, that's what I'd like to know.  I'm a free Evernote user at this point, and doing this would require me uploading my stuff over the course of months due to the data upload limit for free users.

Share this post


Link to post

 

 

Did you export your notes to ENEX and then re-import them?  Or just start over from scratch?

 

Yeah, that's what I'd like to know.  I'm a free Evernote user at this point, and doing this would require me uploading my stuff over the course of months due to the data upload limit for free users.

 

 

Exporting the notes would be the way to go if you want to try this.  You'd need to export individual notebooks to separate files (another good reason for keeping the total number as low as possible) and when you re-import them,  Evernote will default to creating a local (unsynced) notebook unless you specify otherwise.  If you're stuck with a low upload limit you could prioritise the information you need for access via other devices and sync that first,  or you could go Premium for a short while - which gives you a higher limit and the ability to top it up even more in any given month - and kill your uploads in a month or two.

  • Like 1

Share this post


Link to post

I cannot claim that this is a solution for the not responding problem with the desktop client in Windows but it works for me.

 

Just disconnect your PC from the internet (unplug ur lan cord, remove ur dongle whatever) and you should see the desktop client work like a well oiled machine. I guess the problem is with their ad engine.. though not sure.

  • Like 1

Share this post


Link to post

Just disconnect your PC from the internet (unplug ur lan cord, remove ur dongle whatever) and you should see the desktop client work like a well oiled machine. I guess the problem is with their ad engine.. though not sure.

I just tested this and it doesn't solve the problem for me.  I tried printing out the note that Evernote is struggling with and it's only four and a half pages of plain text.  Seems pretty ridiculous that it's freezing up for many minutes at frequent intervals when I try to edit the text.

Share this post


Link to post

Original poster updating . . . Did switch to Premium, just now filed a support ticket (from home computer, can't from here at work, that site is blocked.)

 

Client works great (Windows 7) at home . . . hours on end, no issues.

Client works great (Windows XP) on Dad's old computer . . . hours on end, no issues.

WEB (Chrome) works great from work . . . hours on end, no issues.

Android (Samsung Infuse 2 year old OS) Client works great.

 

Always fully synced between those sites.

 

Its . . . "Microsoft Outlook" on the work computer that seems to conflict with the Client on the work computer.

 

I've removed/reinstalled the Client on the Work computer.

I've backed up (at home via the client enex dump) . . . then cleared the Databases and LocalStorage dir's on the Work computer.

Client worked for about 10 minutes then . . . Not Responding.

 

The Work Computer is . . . owned by them of course, so Microsoft Outlook is mandatory.  And part of the reason I'm using Evernote is . . . because they utilize OneNote and I wanted my Personal and Professional lives (electronically at least) separate.  So if the Professional life ever goes "poof" . . . Evernote will keep on cruizing for me elsewhere.

 

I'll file a problem ticket, but . . . since no one is leaping forward with "oh yeah, Outlook and Evernote don't mix, here's how you fix that . . ." in the forums, and I'm not finding that on Google Searches . . . I'm thinking its a hopeless conflict and nothing I can do.

 

My only other thought (that might eliminate Outlook as the culprit) is . . . as I said, I can't file a support ticket from here.  Site is blocked by routers.  (Personal storage type sites are blocked.)  I guess its "possible" that the freeze comes when Evernote goes to sync.  But, this seems unlikely . . . because, nuking the Database/LocalStorage . . . Downloaded Just Fine.  And I'd assume whatever site/IP address I'm downloading from . . . is the same one I Sync back to . . . so if the Download worked, then its not the company routing getting me.

 

If I start Evernote (and use my phone for email) and try not to load Outlook on the company computer until I absolutely have to  . . . Evernote runs until just about 10 minutes after Outlook is active.

 

So . . . all indications are, Evernote + Microsoft Outlook (Outlook/Office 2013 on Windows 7) . . . sure seems to be the point of conflict.

 

Likely then . . . Its "web only" at work.  There will be no cure unless Evernote finds some way around the conflict.

 

Thanks for those that responded.

 

---

 

Updating the update (2014.06.18) . . . Filed problem ( 586897 ) sent logs.

 

Don't see anything in the logs to indicate an error (other than access blocked to "Announcements" IP site . . . but that occurs some minutes before the Not Responding freeze occurs.)

 

Yet another test . . . Outlook + Evernote seems to be the culprit.  (I know . . . it works for others, and Evernote Tech email said it should work . . .)

 

I saw this page . . .   http://support.microsoft.com/kb/2817430     which mentions Microsoft disabling Evernote, if you have Win7 64bit SP1 (which I do).

 

I removed the Evernote Add-In from Outlook . . . exited/reloaded Outlook.  Loaded Evernote Client . . . Evernote Starts Up . . . Not Responding.

 

Every test I perform seems to indicate . . . the conflict is Outlook (Or the OS preemptively killing Evernote, on Outlook's behalf, to keep Outlook running.)

 

I sent the logs to Tech as requested . . . I await a response.

 

---

 

2014.06.19 update:

 

Went through the entire Revo Uninstall and reinstall . . . whatever the conflict is, all indications point to either the Outlook installation on the work computer, or router (ip/port/protocol) blocking by the company.  (Large Corporate networks block many sites like Dropbox and such . . . afraid you'll dump company secrets to any "Cloud" storage site.)

 

The sync itself usually goes through, but then something else (announcements. . .) is blocking and everything goes Not Responding.

 

So . . . I'll just use the Web Client (until they block that IP too) at work, and the Client elsewhere.  I asked Tech Support to just close the issue.  Its going to be unresolvable due to the limitations on my end.

 

On the flip side . . . I am using Evernote more every day, for personal use.  The Left-Right  (Notebooks->Notes->Note) nature is far better than the main competitor.  Too much "drill down" and "bubble up" to get anywhere with the product I'm required to use at the office.

 

Thanks.

Share this post


Link to post

 

Every test I perform seems to indicate . . . the conflict is Outlook (Or the OS preemptively killing Evernote, on Outlook's behalf, to keep Outlook running.)

 

 

 

Agree that the problem seems to be related to Outlook.  don't see the problem with Outlook not running.  I have reported the same thing on various threads over the past year and like you say, EN support doesn't care / doesn't acknowledge.  This problem makes EN Windows basically worthless so you would think they would take it seriously but it's obvious that Windows is not the primary environment for developers at EN and they certainly don't use outlook so their ignorance of this overwhelmingly common user configuration is no surprise.  

Share this post


Link to post

 

 

Every test I perform seems to indicate . . . the conflict is Outlook (Or the OS preemptively killing Evernote, on Outlook's behalf, to keep Outlook running.)

 

 

 

Agree that the problem seems to be related to Outlook.  don't see the problem with Outlook not running.  I have reported the same thing on various threads over the past year and like you say, EN support doesn't care / doesn't acknowledge.  This problem makes EN Windows basically worthless so you would think they would take it seriously but it's obvious that Windows is not the primary environment for developers at EN and they certainly don't use outlook so their ignorance of this overwhelmingly common user configuration is no surprise.  

 

(Original poster again) Well . . . as I use Thunderbird at home . . . Windows 7 isn't useless here.  Just at work.   EN made several responses, had me send them logs.  Escalated it to the dev's . . .

 

Last word was . . . yes, its an Outlook-EN conflict, they probably will have a fix in the next update but, that could be some time away.  (In all fairness to them, that email came about TWO DAYS after their most recent client update so . . . I wouldn't expect one for a while.)

 

I told them to close the issue, when I saw the client update at home (and knew there was a new version available) I'd try that at work and see if there was any change, and reopen if it still existed.

 

So . . . sounded to me like they're working on something to fix it . . . I'm giving them the benefit of the doubt until next release.

 

But, I'm not doubting your experience YMMV.

Share this post


Link to post

Well, my problem now seems to have gone away but I don't know why or how.  I did the clean re-install plus the deletion of all the Evernote folders on my laptop and so on a couple of times but, sooner or later, the problem came back.  However, as I say, the problem seems to have sorted itself now and this is alongside Outlook. 

 

The only major change I made was to dump the desktop search tool - Copernic - which I had been using for quite a while.  I dumped it because it had started to behave erratically in a way in which Copernic did not seem to be able to help me with.  I replaced it with X1 search which works just fine and is really quick and, as far as I understand it, uses the inbuilt Windows indexing service to do its work (but I may be wrong).

 

I guess that Evernote is sensitive to very specific local software and system setups which are difficult to pin down.  But it does smell a bit of an indexing issue. and it really should not be beyond the Evernote developers to sort it out.  Maybe updates in the near future will do this.

Share this post


Link to post

Original poster again (2014.08.08).  

 

Noticed new update at home, installed . . . at home (where Client has always worked on Windows 7 64bit with Thunderbird . . .) works great.

 

So tried it at work (Windows 7 64bit with Outlook 2013/Lync . . .) still fails.  Install loaded easy enough.  Started Evernote.  Started Outlook.  Updated from central server to Client.  I entered a line or two to an existing note.  After about 15 minutes of doing other things, came back to Evernote . . . goes dull-white "Not Responding."  Closed not-responding program.  Went back to Web version, the two sentences I entered via StandAlone Client didn't update through.

 

So . . . with Outlook 2013 . . . Web client through Chrome works great.  Stand alone executable Client Evernote_5.5.3_4236.exe from desktop . . . still goes Not Responding after a few minutes (approximately at the first outbound update.)

 

Maybe a future update will resolve the issue with Outlook/Lync.  (I only mention Lync, since it came with the entire Microsoft 2013 package and is running all the time.  Testing indicates Outlook seems to be the real conflict.)

  • Like 1

Share this post


Link to post

Testing indicates Outlook seems to be the real conflict.)

 

You might be right.

It consistently takes me a frustrating 7 to 8 minutes to open Evernote Windows 7 64 bit (after a reboot with cache clearing).

 

Last month, I spent 3 weeks working with Evernote Support with no success. The usual drill - send activity log, uninstall, reinstall, sync from the cloud, send activity log, debug, optimize, send another activity log, etc. But I noticed they added a new line to their standard sequence of instructions prior to the reinstall:

"Close Internet Explorer and Outlook (if present)"

 

The last communication was:

"I've filed this as a bug with our development team. I'll let you know when I have more information."

Share this post


Link to post

 

Testing indicates Outlook seems to be the real conflict.)

 

 

The last communication was:

" ... I'll let you know when I have more information."

 

It is nice and encouraging that the support team states this, but in my experience EN either has no mechanism in place to actually follow through, or they choose not to.

 

My most recent journey through the support system resulted in "we will keep the ticket open and notify you when we have a fix."  I never heard another word and the issue was fixed in the next beta drop.  I've experienced this enough to believe there is no follow up.

  • Like 1

Share this post


Link to post

(Original poster again)

 

2014.08.28 Today's version 5.6.4 Still no joy . . .

 

Installed at home (Win 7 64bit - no Outlook) came up fine . . .  

At Work, exited Outlook, installed 5.6.4, reopened Outlook, . . . Evernote Client froze on initial opening.

Again, it could be Lync, but Outlook or Lync (or some part of the Office 2013 package that's serviced/running all the time) . . . seems to be the killer.

Web . . . still works great.

Share this post


Link to post

It's not because of Outlook or IE:

 

I also want to report that every time I boot up (at least for the last 15 times), Evernote 5.6.4 is not responding and stays minimized to the task tray for 7-8 minutes. Also, whenever I create a new notebook, Evernote also hangs/freezes for 3-4 minutes.

 

 

I do not have the time to go through the re-installs which don't apparently help. And, it looks like from other forum user experiences, it's useless to place a trouble ticket for this.

 

In none of these circumstances do I have Outlook or Internet Explorer running when this happens. Clearly for me, the problem is not Outlook or IE.

 

I'd love for the Evernote developers to solve this widespread problem. And, I'd love to keep using Evernote. I have enjoyed using Evernote and have about 4000 notes in it.

 

However, I am losing patience with it and am looking for something to replace it.

  • Like 1

Share this post


Link to post

[Portion deleted]

 

In none of these circumstances do I have Outlook or Internet Explorer running when this happens. Clearly for me, the problem is not Outlook or IE.

 

[Portion deleted]

 

 

But it sounds like you at least have Outlook "installed" (which installs more *.DLL's and . . . could be conflicting).   At home (where 5.6.4 works for me) I don't even have Microsoft Office or Outlook installed.  At work (where it freezes) I have them installed.

 

I know . . . that doesn't prove it one way or the other.  But . . . just having it installed (and overwriting shared/common DLL's . . . ) could be an issue.

 

I still away a magical fix (and continue to use the Web version at work).  

Really, for what I use it for, other than the Backups (which I do at home) . . . the Web version is all I need at work.

 

Good luck to you . . . 

Share this post


Link to post

I am also on Windows 8.1. It is now September 5, 2014 and I am running the latest version of Evernote.  For the first time I now see the problem reported last January by this post.

Share this post


Link to post

I've been battling this beast for years now. I haven't even used the EN desktop client recently because the 'not responding' errors are too frequent and too annoying. I've tried everything suggested in various threads. Stumbled upon this one and find that I'm interested in the potential Outlook conflict. I don't have Outlook, but I do have, and regularly run Live Mail, ugly twin to the old Outlook Express. I'm going to kill all running instances of Live Mail and give it a go. Boy, would I be happy to find out that this is the problem. I'd have no issue with ditching Live Mail altogether and switching to T-bird. I'll be sure to report back if I find anything interesting. Starting to look like we'll all be old and decrepit before Evernote figures this out on their own.

 

UPDATE: Well, that worked well for ten minutes. Evernote frozen up like a puddle in December. I've uninstalled so many programs trying to pin this down, I'm starting to wonder if it's worth it. Back to the web interface with me.

Share this post


Link to post

Posted previously (Aug 2014) . . . tried a few updates, but Stand Alone client at office where I have Win 7.1 and Outlook and Lync . . . locked up Not Responding, so have been using Web Client at work since then.  (Never had a problem with Windows 7.1 at home, but no Outlook there.)

 

New laptop now (June 2015), still Windows 7.1, still Outlook, Skype for Business instead of Lync . . . saw Evernote 5.8.8.7837 release, decided to try it again . . . An hour yesterday, two hours today.  No lockups.  No "Not Responding".

 

Don't know if it was flipping Lync to Skype, or the upgraded Evernote client, either way . . . the conflict seems to be resolved.

 

Nice to be using the client both at Home, and now finally, at Work.

 

Thanks, and good luck to everyone else.

 

jkh

  • Like 1

Share this post


Link to post

Evernote (Windows) not responding - try turning off "Note Context" via Tools --> Options --> Context Tab then CLEAR Show Context Checkbox - it seems to have worked for me at home - will try same at work!

  • Like 1

Share this post


Link to post

×
×
  • Create New...