Jump to content
fast_learner

mac Em dash autoformatting

Recommended Posts

I'm fairly new to Evernote (which I'm running in Mac OS X Mavericks), so my apologies if this is a naive question...

 

I would like to get into the habit of using Evernote to keep track of command snippets from Unix sessions.  Oftentimes when running Python/Perl scripts, program flags will require double dashes (--) when specifying a particular option.  For example,

 

test_script.pl --option=blahblah

 

Unfortunately, Evernote will always assume when you type a double dash (--) that what you REALLY want to type is an em dash (—), and it will replace the double dash with the em dash accordingly to help you out.  This is unacceptable for the type of record keeping I would like to perform, but I haven't been able to find any way to turn off this behavior.  Does anyone know of a workaround or some way I might turn off this autoformatting 'help' that Evernote is providing?

Thanks,

Nate

Share this post


Link to post

This also really bothers me.  As someone who likes to use evernote to keep track of linux command line snippets, the automatic conversion of -- to emdash is a real problem.

 

I'd love to figure out how to disable this too.

Share this post


Link to post

This also really bothers me.  As someone who likes to use evernote to keep track of linux command line snippets, the automatic conversion of -- to emdash is a real problem.

 

I'd love to figure out how to disable this too.

 

Hi. It's easy.

 

Apple System Preferences -> Language and Region -> Keyboard Preferences -> Text -> uncheck "Use smart quotes and dashes"

  • Like 3

Share this post


Link to post

I never stopped to think that an OS-level tweak might be what was required.  Worked like a charm.  Appreciate the assistance!

Share this post


Link to post

I never stopped to think that an OS-level tweak might be what was required.  Worked like a charm.  Appreciate the assistance!

Glad I could help :)

Share this post


Link to post

For Evernote Windows

What I did was add the following reference info to my default note.

 

———————————————————

standard dash: -
         en dash: –   (width of N) Alt + 0150
        em dash: — (width of M)  Alt + 0151

———————————————————

 

If I needed one of the special ones, I did a copy and paste.

Share this post


Link to post

Go into a terminal, and write:

defaults write Evernote SmartDashes -bool false

This will turn off smart dashes for Evernote, but not change other autocorrect, or other apps.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...