Jump to content
nle

mac Two problems: 1. Missing file extension from URL on upload to FTP. 2. Share options reduced to mail only.

Recommended Posts

I have a Macbook Pro Retina 15" connected to a 24" monitor. So a dual monitor setup (internal and external).

 

Running Skitch Version 2.7.1 (263266)

 

My two problems:

 

1. Problem with file extension when uploading to ftp.

When I upload to FTP (I have unique filename checked) I get an URL copied to the clipboard simular to this: "http://domain.com/folder/image_name_uniquekey_png/". If I change the URL to .png instead of _png it works (on previous beta version it actually did name the file just "_png", but I just updated and that seems to be fixed)

 

2. Dissappearing sharing options

If I quit Skitch.app, but have the helper running in the background I can take skitch screenshots by pressing "cmd + shift + 5", but when I want to upload this to my FTP the only option I have is Mail. To fix this I can go into settings, add and remove a dummy ftp account, and the settings is back.

 

Feature request:

- Shortcut for uploading to FTP. If I remember correctly this was cmd + enter in Skitch 1.

 

(And for the record: I've been a long time skitch user, but just recently dared upgrading to the new version. It's getting there, but still not top notch.)

 

Share this post


Link to post

nle,

Can you clarify some things for me?

  1. You say, "When I upload to FTP (I have unique filename checked) I get an URL copied to the clipboard simular to this: "http://domain.com/fo..._uniquekey_png/".  However, Skitch does not copy a URL to the clipboard when you upload to FTP. Can you please clarify the steps that you are taking? When I FTP or "Share, Copy & Open" a direct image URL using 263266, I get a file extension in both cases (example: https://www.evernote.com/shard/s314/sh/3c7db0dc-3cad-4988-a329-5e4a89c16a4a/db88aad37d88d77ed481991ffda91a82/deep/0/rainier.jpg)
  2. When you quit Skitch, are you logging out first? Or, are you not checking the "Stay logged in" check box on the login screen when you do login? If you launch Skitch in non-logged in mode the only sharing option you get is email. I suggest you stay logged in and your sharing options won't disappear. :-)

Thanks,

Lester

Share this post


Link to post

Same problem, since last update; this is a BUG in Skitch. 

 

BUG = Skitch replaces in the filename for FTP-upload all spaces AND DOTS to UNDERSCORE !!

 

This should be corrected as soon as possible. 

  • Like 1

Share this post


Link to post

@idekay

 

Sorry for the late reply, I thought I had subscribed to this thread.

 

  1. Skitch does indeed copy the URL when you upload to FTP. It is the last option on the FTP settings page. Mine says: "Clipboard: Plain URL". The problem is that the filename in the URL is wrong. It ends with _png instead of .png (basicly what @DirkVos said).
    (In the previous version it also uploaded the file without the file extension since it also replaced the filename with _png – but that seems to be fixed in this version. It is only the copied URL that is wrong)

    The steps I do is:
    1. Keyboard shortcut. Take screenshot.
    2. Press on the share button and select the FTP account I want to use.
    (I really want a shortcut for the different sharing options, or the option to set the default sharing option so I could use the default cmd + shift + m)

    I have also tested this on two different FTP servers on different hosts. Same problem on both.

     
  2. I am not logged in. I only use Skitch with FTP, so I have no need for being logged in. But it could be that logging is an easier bug workaround than adding and removing a dummy FTP account. Because this is clearly a bug.
  • Like 1

Share this post


Link to post

Any idea on when this will be fixed?  it's a major bummer for those of us who use this xx times a day! :)  

  • Like 1

Share this post


Link to post

Yup, ditto.... this has been happening since last update, a few months now... when 1st installed Skitch this was not an issue and thought it was about the most badass tool of it's kind.... a week later I updated to the latest vsn and ever since then, I've been disappointed that the automatically copy-url-to-clipboard function of Skitch that happens during the FTP process changes....

THIS:  http://mydomain.com/folder/filename.png

 

to

 

THIS:  http:/mydomain.com/folder/filename_png

 

....since this is effectively a broken link, I can't share it with anyone without 1st correcting the string.

 

This is not going to result in me never using the tool (for now anyway) but it's a constant annoyance. I used to tell everyone about Skitch. I no longer do that due to this little bug. It's borked....

 

Great great great product... but, please fix it!

Thanks!

Share this post


Link to post

You have a drop down menu bottom left of the skitch window. Please don't take this thread of it topic. So if you have any more off topic questions, start your own thread. :)

Share this post


Link to post

Same issue here with FTP Upload

 

- URL in the clipboard is always ending in "_png" instead of ".png".

- Also the format selected in the little dropdown menu at the bottom left of Skitch window is not respected (whatever you choose it always upload a PNG file)

 

Please fix asap. Thx

  • Like 2

Share this post


Link to post

I have the same issue.

 

Skitch uploads to my_file.png, however when it copies to the clipboard, I get instead: my_file_png.

 

Please Fix!

Share this post


Link to post

Same issue here. I'm actually surprised there's been no update on this after two months...

 

First of all, I agree, there should be some way to add a shortcut to the SFTP share account (having to click the menu, then the option is annoying) and when it uploads it, the clipboard paste is borked, getting a _png instead .png

 

I've also tried changing the extension down below, next to the filename, but it refuses to upload anything other than .png, and there's no obvious way to change this. (Another bug?)

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...