Jump to content
  • 0
jbignert

chrome Chrome & Safari Clipper BETA - with Gmail clipping rewrite

Idea

Hi all,

We have new beta versions for Chrome & Safari Clippers. Version 6.0.7.1 with a rewritten Gmail clipping function. A few notes:

- No longer need to expand the thread to get all messages in it. 

 

Please post feedback and report issues back on this thread - remember to post:

- OS version number
- Safari version number
- URL where issue happens
- Description of the problem and steps to reproduce it
- If you're tech minded feel free to send logs to me in a PM, JSConsole and Web Clipper internal logs are usually most useful to us.

 

-- UPDATE --

This has now been released as version 6.0.7.

If you have been testing the beta version - please reinstall the production version from https://chrome.google.com/webstore/detail/evernote-web-clipper/pioclpoplcdbaefihamjohnefbikjilc?hl to make sure you get future updates.  

  • Like 2

Share this post


Link to post

45 replies to this idea

Recommended Posts

  • 0

Hi all,

We have new beta versions for Chrome & Safari Clippers. Version 6.0.7.0 with a rewritten Gmail clipping function. A few notes:

- No longer need to expand the thread to get all messages in it. 

 

 

Looks to be working so far, thanks :)

Quick question... if I have received an email, and I make a reply, there does not appear to be a way to collapse my reply in the email "conversation" (the last message in the conversation does not collapse). This means when I clip the email I'm getting both their email and my reply. Is there any way to only get their email? I thought before that you could clip only one email at a time. I didn't use the feature too often though so maybe I'm wrong...

Share this post


Link to post
  • 0

I keep getting an error pop-up on every single email I try to clip:

post-47222-0-21843700-1385600793_thumb.p

 

There are lots of 404 errors in the console. Is this interference with some other extensions?

 

 

Share this post


Link to post
  • 0

I click the button, but nothing happens.  I've tried uninstalling and re-installing to no avail.  It's totally non-functional for me.

Share this post


Link to post
  • 0

Work with a gmail thread with no attachments. But a thread with attachments got the error "could not parse. check console for more details"

 

- OS version number

Windows 7 Build 7601


- Chrome version number

31.0.1650.57 m
- URL where issue happens

https://mail.google.com/mail/u/0/#inbox/14208a858e7501f3

 

- Description of the problem and steps to reproduce it
Three email thread with first two having PDF attachments.

 

- If you're tech minded feel free to send logs to me in a PM, JSConsole and Web Clipper internal logs are usually most useful to us.

Did not see anything in Chrome's JSConsole, but happy to look. Where can I find the Web Clipper internal logs.

Share this post


Link to post
  • 0

Win7 64bit, Chrome  31.0.1650.57 m,

 

The gmail clipping isn't working right. I opened an email in Gmail that was the 4th email in a thread. In this email, the sender removed 2 people from the previous email in the thread. WHen I clipped it, visually, it showed the previous email in the thread, not the one I have opened, and that is what got sent to Evernote. The one actually open in my Gmail inbox when I clipped did not get sent to EN.

 

I just tested with another email. 4 emails - one from me to person X, one from X to me and me to X and X back to me. I opened the last one and clipped. It grabbed the 3rd email in the thread, from me to X.

 

I would turn off this "no longer need to expand the thread" thing. I don't thread emails in Gmail (turned off - so that may be the issue) and even if I did, if EN grabbed all emails in the thread by default, it would have a TON of redundant data as each email body has content quoted from the last. In a 10 email thread, I can see getting the first email content 10 times, the 2nd 9 times, the 3rd 8 times, etc.

 

I'd like it to just clip the message I have open. Right now, it isn't even doing that.

 

None of my tests had attachments either in the emails. All pure text.

  • Like 1

Share this post


Link to post
  • 0

When clipping from Gmail, how do I get the clipper UI to just go away? I don't want a confirmation or a dialog box blocking my screen telling me about related notes. I would only want a notification if the clip failed.

Share this post


Link to post
  • 0

Where do I drag the downloaded file? I don't know what is meant by the "Manage" page. 

Share this post


Link to post
  • 0

@dsus

You open the 'Manage extensions' in Chrome by going to Windows > Extensions (Mac, more or less the same thing on Windows) then drag the file onto that page and a popup will ask you if you want to install.

Share this post


Link to post
  • 0

@dsus

You open the 'Manage extensions' in Chrome by going to Windows > Extensions (Mac, more or less the same thing on Windows) then drag the file onto that page and a popup will ask you if you want to install.

 

Worked like a charm. Thank you.

Share this post


Link to post
  • 0

I install the plugin on Safari 6.1 (8537.71) & iMac with Mountain Lion, and do not work.

Evernote Web Clipper 6.0.7.0 is active on Safari/Preferences/Extensions, but clicking on the elephant icon do nothing.

Share this post


Link to post
  • 0

@rbianchi

Did you restart Safari after you installed it? It's important to restart so the new extension code can run on all tabs. Please let me know if that doesn't take care of it. 

Share this post


Link to post
  • 0

Hi EdH,

Yes and No, we have verified we have some trouble in the current beta when threading is disabled but we don't get exactly the same effect that you described where it clips the wrong message. We are working on resolving that and we hope we can support that setting as well.

 

As for the UI to go away this will come as a user preference but not in this next release. 

Share this post


Link to post
  • 0

Thanks. For me, it is very consistent. Disable threading and it always clips the 2nd to last message. This is on a business account too, vs a normal Gmail account. My regular Gmail account is threaded and it works fine there.

Share this post


Link to post
  • 0

Thx Ed for the added details, that will help us troubleshoot it. One follow up:

- When you click the WC button and we show the preview of the clip, does it at that stage also load the wrong message into the preview?

Share this post


Link to post
  • 0

Thx Ed for the added details, that will help us troubleshoot it. One follow up:

- When you click the WC button and we show the preview of the clip, does it at that stage also load the wrong message into the preview?

Yes, both the preview and actual clipping show the same thing, the 2nd to most recent email.

Share this post


Link to post
  • 0

@jbignet, I restart Safari many times. Also I turn off & on my iMac.

I click on elephant icon & nothing happens in gmail or any web page.

Share this post


Link to post
  • 0

Hell. Yes. It's working again. Man I love this feature.

 

- OS version number: 10.8.5
- Safari Chrome version number: 31.0.1650.57

Share this post


Link to post
  • 0

@Rbianchi

Yeah we can now reproduce the issue you are describing where the toolbar button doesn't respond. 

Please uninstall the Safari 6.0.7.0 Clipper and go back to the production version from www.evernote.com/webclipper for the time being. We will work on fixing it in the next few days.

Share this post


Link to post
  • 0

I click the button, but nothing happens.  I've tried uninstalling and re-installing to no avail.  It's totally non-functional for me.

Did you remember to restart Chrome or Safari? I had this problem until I restarted...

Share this post


Link to post
  • 0

Hi all, 

We just pushed a new update with several bug fixes and UX improvements to the Gmail clipping:

- You can now select what messages to be part of the clip.

- A backlink that opens the conversation in Gmail from the note. (we've noted some issues with this when you view the gmail clip in the Webclient views, desktop clients handle it well so far)

- General UI improvements

 

Issues reported by EdH and cswilly should be fixed in this update. (thx for reporting)

 

Important: To get the new build you will have to uninstall then reinstall from this note:

https://www.evernote.com/shard/s13/sh/4a961fb9-6f66-4a79-856b-d0776939e423/6d5c44e22f19d660a02e60d9e2e945cc

 

As usual feedback is greatly appreciated, especially if this build resolved your issue. 

  • Like 1

Share this post


Link to post
  • 0

Just ran a few quick tests and it appears to be fixed. I will use it a lot more this afternoon so will report any problems I find.

Share this post


Link to post
  • 0

Ok, still working ok, but the UI is a bit off for non-threaded configurations.

When I click a message to clip, it asks if I want the entire thread or just a specific message with those checkboxes. If Gmail is set up as non-threaded, then there is only one message to clip. EN won't go find other messages in the conversation. I am 100% fine with that, but it shouldn't give me the choice. It should just clip the message, so logic is:

 

if conversation view is on, then ask user which messages to clip via checkboxes

if conversation view is off, then just clip the the selected messages and don't show checkboxes.

 

The UI is a bit confusing the way it is now for non-threaded views.

 

I like how when conversation view is on and you uncheck "all messages" it collapses all messages so you can get the one you want quickly. I use conversation view in my personal gmail, but not work email.

Share this post


Link to post
  • 0

Thanks EdH for testing and providing feedback, I'll see if we can detect that user is having no threads and then directly clip the single message without showing the preview state. 

  • Like 1

Share this post


Link to post
  • 0

Thanks EdH for testing and providing feedback, I'll see if we can detect that user is having no threads and then directly clip the single message without showing the preview state. 

 

Now that I have some notes in Evernote, the header is a bit busy. Here is how it comes out, with my comments in blue next to it. 

 

 

EMAIL SUBJECT  the subject should be the note title, why is it repeated in the note?
Participants: list of all email addresses
 
 
Open conversation in Gmail (this is unnecessary. the link is in the note URL, and it has three flaws. 1) it doesn't work right if you don't have conversation view turned on so there is no "opening the conversation" and 2) if a user has 2 Gmail accounts in their browser (work and personal, as I do) the link may not work at all. This is a Google issue, but EN is compounding it. Leave the URL in the note header, not in the body. 3) this doesn't do anything on a mobile device as few use Gmail in a browser on their phone or tablet. Furthermore, the horizontal line and the arrow are just taking up space. I'd remove all of it Just stop with the recipients.
FROM ADDRESS This shows who it is from, repeating info in the Participants section above. Again, extra line, unnecessary information. I'd much rather just see the "TO:" and "FROM:" lines with minimal/no formatting (plain text) at the top the way it used to work to maximize what is seen in the preview window and the full window of mobile devices.

Share this post


Link to post
  • 0

Ok, this is odd. I clipped something from my Gmail business account. it goes into EN, then I click "Open in Evernote" and I have it set for the web. The title of the note is "Re: MFD Return - Nov GL"

 

When it opens, it briefly shows this note, but then quickly switches to "MiFi rebate for Verizon" - which is a note that hasn't been touched or edited since October 2009.

 

Somehow it is getting its wires crossed. the email had 6 PDF attachments totaling about 3.5MB. It isn'tthe first note though I've opened in Evernote Web from the clipper with an attachment, just the first one that has gotten it way wrong like this.

Share this post


Link to post
  • 0

1. I think the web clipper is a wonderful tool

2. I loved the clip from Gmail function when it worked originally. Maybe needed some tweaks. But helpful part of my daily workflow.

3. I am pleased Evernote is paying attention to this issue with the clipper

4. However this beta did not work for me.  Windows 7, Chrome Version 31.0.1650.63 m. Seemed to load fine. I restarted Chrome. It shows as enabled. But I get the puzzle-piece icon for the Evernote web clipper and it does not work for me.

 

Please keep at this! You had it working before. I hope this is not a case of Google throwing curve balls at Evernote! Support of Keep?

Share this post


Link to post
  • 0

@slamont, thanks for posting this. We haven't heard this report before so I have a couple of follow ups for you:

- Did it install correctly? Did you download the CRX file to your disk and then dragged it onto the chrome://extensions view?

- Where do you see the puzzle piece icon? If possible can you provide a screenshot of your chrome://extensions view?

 

Feel free to send reply as a PM message if you don't want to post stuff for the entire forum. 

Share this post


Link to post
  • 0

@jbignert

Now I see that this version works on Safari.

However, the tools (highlighted, marks, etc) only work with screen capture, not with Gmail clipping.

This is correct?

 

Using Chrome Versión 31.0.1650.63, and Safari Versión 6.1 (8537.71), OS Mountain Lion

Share this post


Link to post
  • 0

Yes, it appeared to install correctly. I got the pop-up tutorial that I get every other time I install it. I downloaded the CRX file and dragged it to the Chrome/extensions. All appeared to do well. I checked it was on the extensions list and enabled.

 
The puzzle piece icon was on the top of my Chrome page, where I usually see the Evernote elephant and all my other extensions.
 
I have gone back to using the regular web clipper because I enjoy it for other uses, even if it will not work with gmail. So I cannot show you a useful screen clip.
 
Is there a chance of a conflict with other extensions?  I had trouble with new MetroTab, and had to re-install Chrome on one machine to get rid of it. I use Lastpass, Chromecast, Feedly, Pandexio, JetBlue, and The Great Suspender extensions. Might one of them conflict?

Share this post


Link to post
  • 0

 

Yes, it appeared to install correctly. I got the pop-up tutorial that I get every other time I install it. I downloaded the CRX file and dragged it to the Chrome/extensions. All appeared to do well. I checked it was on the extensions list and enabled.

 
The puzzle piece icon was on the top of my Chrome page, where I usually see the Evernote elephant and all my other extensions.
 
I have gone back to using the regular web clipper because I enjoy it for other uses, even if it will not work with gmail. So I cannot show you a useful screen clip.
 
Is there a chance of a conflict with other extensions?  I had trouble with new MetroTab, and had to re-install Chrome on one machine to get rid of it. I use Lastpass, Chromecast, Feedly, Pandexio, JetBlue, and The Great Suspender extensions. Might one of them conflict?

 

 

It isn't the Great Suspender or Lastpass as I use those too.

Share this post


Link to post
  • 0

Can you move or get rid of the dialog box that says "clipping" and has the spinning graphic? Twice today it never went away, even though the note was properly clipped.

 

Either move it down a few hundred pixels so it isn't covering other Gmail controls in the upper right (apps, settings, etc) or do away with it entirely like the old clipper, just assume it is clipped and have a little notification in the toolbar if it isn't. The current method not only tells you it hasn't finished (even if it has!) it blocks you from getting work done, like looking at your calendar, launching Google Drive, etc since those are all hidden beneath it.

Share this post


Link to post
  • 0

Hi all,

We have new beta versions for Chrome & Safari Clippers. Version 6.0.7.1 with a rewritten Gmail clipping function. A few notes:

- No longer need to expand the thread to get all messages in it. 

 

Get the build here:

https://www.evernote.com/shard/s13/sh/4a961fb9-6f66-4a79-856b-d0776939e423/6d5c44e22f19d660a02e60d9e2e945cc

 

Please post feedback and report issues back on this thread - remember to post:

- OS version number

- Safari version number

- URL where issue happens

- Description of the problem and steps to reproduce it

- If you're tech minded feel free to send logs to me in a PM, JSConsole and Web Clipper internal logs are usually most useful to us.

So far, gmail clipping is restored in Chrome Ver 31.0.1650.63 m

Nice job!  Will have to try with attachments (never needed to clip email with attachments so far, however) this afternoon.

Share this post


Link to post
  • 0

I'm not sure whether to report this issue here or start a new thread but the default Evernote Web Clipper extension for Safari activation keyboard shortcut (the back tick "`") is the same shortcut that gmail uses to move between the inbox tabs (https://support.google.com/mail/answer/6594). I tried to change the keyboard shortcut in the well hidden extension but wasn't able to. Are the keyboard shortcuts not customizable? 

Share this post


Link to post
  • 0

Crashing for me here... Can't get this one (3 attempts).

 

22:31:17 GMT-0500 (Eastern Standard Time) (WARN) https://mail.google.com/mail/u/0/?shva=1: Some frames seem stuck, continuing with what we've got.
at LogDispatcher.warn (/js/common/Log.js:5:378)
at c (/content/frame_loader.js:1:346)

 

Version 6.0.7.1

Share this post


Link to post
  • 0

I'm not sure whether to report this issue here or start a new thread but the default Evernote Web Clipper extension for Safari activation keyboard shortcut (the back tick "`") is the same shortcut that gmail uses to move between the inbox tabs (https://support.google.com/mail/answer/6594). I tried to change the keyboard shortcut in the well hidden extension but wasn't able to. Are the keyboard shortcuts not customizable? 

 

There's a discussion about keyboard shortcuts here: http://discussion.evernote.com/topic/42350-please-allow-editing-keyboard-shortcuts/page-2#entry247238

 

Sadly there doesn't seem to be much response to it. Which is annoying, because I can't write "It's" or "they're" or anything with a comma because it sets off the keyboard shortcuts (well, currently have shortcuts turned off). I think it was supposed to be `, the backquote (it's on the key to the left of 1 on the UK keyboard), but it's actually an inverted comma ' that sets it off...

Share this post


Link to post
  • 0

Hey. I've done the beta install but it is still is not working. When I click on the icon nothing happens. I'm using a MacBook Pro OS 10.6.8 with Chrome and still no luck. Super frustrated. Any help would be awesome.

Thanks.

Share this post


Link to post
  • 0

Ok, two major issues with the clipper as it stands now. When the evernote service goes down, as it is right now (see my post here on it) the clipper behaves one of two ways:

 

  1. It fakes clipping and I get a yellow number designating something didn't clip. That number never goes away until you restart the browser. it will never send that clip. Once the service comes back online, the clipper will resume working, but those queued clips never get sent.
  2. The clipper just logs out and it is gray with a red dot and asks you to log in. However, it will not bring up the login dialog box until you restart chrome, which is a MAJOR pain in the posterior in the middle of the day when you have multiple tabs open trying to get work done and you have to close everything and reopen it just to get the EN Clipper to log in.

Oh, and when it does relog in again after restarting the browser in #2 above, you have to go through the 2 factor authentication again, even though I have done that 2-3 times in the last 48 hrs.

 

The clipper needs better resiliency when the service is down.

Share this post


Link to post
  • 0

Still not working. When I'm in gmail and try to clip an email, I receive a popup that says:

 

The page at https://mail.google.com says:
could not parse settings. check internal clipper logs for more details 

 

OSX 10.9.1

Chrome Version 32.0.1700.77

 
I then get a revolving disk until I hit escape.

Share this post


Link to post
  • 0

 

Still not working. When I'm in gmail and try to clip an email, I receive a popup that says:

 

The page at https://mail.google.com says:

could not parse settings. check internal clipper logs for more details 

 

OSX 10.9.1

Chrome Version 32.0.1700.77

 
I then get a revolving disk until I hit escape.

 

Same here:

 

Windows 8 64bit

Chrome Version 33.0.1750.146 m

Clipper v6.1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...