Jump to content
AndreaLR

mac Blocked Plug in?

Recommended Posts

Hi all!  

After updating Evernote yesterday, I am unable to view any of my PDF files.  Instead, I get a message stating "blocked plug in".  

I have uninstalled and reinstalled Java, Flash player, and Evernote directly from Evernote.com.  It is working fine on my macbook, but not on my imac.  Has anyone encountered this problem?  Any suggestions for how to access these files on my desktop once again?

 

Thanks!

ETA:  
 

In addition to the above, I have found that I am able to view the PDF when using the full screen presentation mode, but I am unable to view it inline or even as an attachment.  

I also receive the same "blocked plug-in" message when attempting to add check boxes.  

I am currently attempting to download the app store version to see if that will work, but even if it does, I would ideally prefer to have the full functionality of the app as downloaded from the web.  

Share this post


Link to post

In addition to the above, I have found that I can view the PDF when viewing in full presentation mode, but I am unable to view it inline in the note or even select to view it in Preview.  

Share this post


Link to post

Yes, I'm seeing the same thing here this morning after updating to the most recent version.  I can see it in the web interface and in presentation mode, but not in the mac application.

Share this post


Link to post

I am having the same issue.  Says blocked plug in for any file I try to attach in the MAC version.  I can, however, see files for that note on the web version.

Share this post


Link to post

Count me in. I'm getting the same "Blocked Plug-in" on my MacBook Pro, just after updating to 5.3.0.

 

I used the Chrome extension to 'clip' a PDF document into Evernote, and I attached the PDF document to an existing note. Both notes show the PDF preview, but the PDF does not appear in the full version (see the attached screenshot).

 

I look forward to a fix.

 

(FYI the PDFs are showing up just fine on my iPhone.)

 

post-153536-0-75258700-1380062311_thumb.

Share this post


Link to post

Same thing here... It happened to me after using the new presentation mode. Once I closed that out and came back to view a list with checkboxes, I am now seeing the "Blocked Plugin" message on both older ones, as well as when i try and add new ones.

Share this post


Link to post

Well, I am sorry we are all having this problem, but I am also glad I am not the only one!  Has anyone sent a support ticket?  I sent one on September 22nd, but not being a premium member, I am sure it will take a while to hear back.  

Share this post


Link to post

We have found that some old Finder plugins behave very badly and cause Evernote to crash. Do you have a Finder plug-in installed?

Share this post


Link to post

We have found that some old Finder plugins behave very badly and cause Evernote to crash. Do you have a Finder plug-in installed?

 

Thanks for the suggestion!  I do not have any finder plug-ins installed.  

Share this post


Link to post

My evernote is not crashing... I just can't add a check box, or see/update ones that I had before in notes.

Share this post


Link to post

We have found that some old Finder plugins behave very badly and cause Evernote to crash. Do you have a Finder plug-in installed?

 

 

I use a third party finder "Path Finder" but not sure if that is classified as a plug-in.  I reported this problem to support as well.

Share this post


Link to post

These are only some of the plugins that will cause issues:

1passwd
ClamXav
Toast It
Google GearsEnabler
Google Notifier
Tigris.org SCPlugin

Share this post


Link to post

 

These are only some of the plugins that will cause issues:

1passwd
ClamXav
Toast It
Google GearsEnabler
Google Notifier
Tigris.org SCPlugin

 

 

I do not any of these enabled.  Like Dane mentioned, my EN is not crashing.  I can not view PDF, work, or PPT in Evernote like I could previously.  I only see a message saying blocked plug in.  When using card view, I can see the little preview of it, and when viewing it in presentation mode I can see them as well.  I am also unable to add checkboxes.  Instead I get the same blocked plug in message.  

Share this post


Link to post

Just upgraded to 5.4.0 for Mac and I still see the "blocked plug-in" placeholder where my old and new checkboxes should be.

post-153468-0-86795600-1380917463_thumb.

Share this post


Link to post

I am getting really frustrated with this problem!  I have emailed support as well as a chat session and no one can figure out what the problem is.  Have any of you found a fix?  

Share this post


Link to post

I am getting really frustrated with this problem!  I have emailed support as well as a chat session and no one can figure out what the problem is.  Have any of you found a fix?  

 

No fix on my end.  My assumption is that we need to wait for an updated client.  Support's response was that it is a known issue and that I will have to wait on them for a fix.

Share this post


Link to post

FYI, I don't believe this is an issue solely with Evernote. I am getting the same "blocked plugin" errors/blocks in Mail when trying to view an embed'd image I sent myself, PDF's there too. I think it's a java issue on the mac somewhere... I have my IT dept. looking into this too.

Share this post


Link to post
This is most likely caused by conflicting third-party software such as a third-party Safari/WebKit plugin in either:
/Library/Internet Plug-Ins
/Users/xxxx/Library/Internet Plug-Ins
 

We're waiting on system logs from support tickets. If you have some, feel free to respond to support or submit a new ticket. Click on a note that exhibits this behavior, and then send system Console logs via support to Jack, that might give us some clues.

Share this post


Link to post

I'm having this issue as well. Are people who pay to subscribe experiencing it? If I were to pay to subscribe, would the problem go away for me?

 

I'd be happy to send in the log you're requesting, Jackolicious, but I don't know how. If you post a step-by-step of where to submit tickets and how to get a log and add it to the ticket, I'll do it. Thanks!

Share this post


Link to post

I'm having this issue as well. Are people who pay to subscribe experiencing it? If I were to pay to subscribe, would the problem go away for me?

 

I'd be happy to send in the log you're requesting, Jackolicious, but I don't know how. If you post a step-by-step of where to submit tickets and how to get a log and add it to the ticket, I'll do it. Thanks!

 

This is affecting premium users too.  A subscription wouldn't help.

 

 

Is there any update to this issue?  This has been persistent for awhile now and really need a resolution soon.  All of my PDF archives are not viewable with my Mac client.  

Share this post


Link to post

I think this is a permissions based issue. There is a similar issue that plagues Apple Mail. To fix that issue you run fix permissions from the disk utility application. What I have noticed however, is that if you are also running the Evernote DAEMON, the fix from the disk utility "fix permissions" function lasts only about one minute. Then the permissions are again corrupted, and the plug-in is blocked in Apple Mail. Perhaps the reason why it never gets fixed in Evernote, is that Evernote itself is causing the permissions problem. If this is the case, then you will never see the plug-in get resolved by using fix permissions in disk utility.

Share this post


Link to post

If corrupt permissions are indeed the problem, and Evernote is the culprit, it is doubly annoying because it is causing a blocked issue in Apple Mail's plug-in functionality as well.

Share this post


Link to post

Ryan Hunt, that is not correct. Blocked plug-ins in Mail are likely caused by the same incompatible Finder extensions that cause issues with Evernote. 

Share this post


Link to post

I am not saying Evernote is or is not the culprit for the Apple Mail issue.

 

What I am saying, is that fixing permissions fixes the Apple Mail blocked plugin problem.

 

When running Evernote, the permissions become corrupted again quickly. 

 

This phenomenon may or may not be related to other applications or extensions that are running.

 

Regardless, this may give the Evernote QA team some food for thought as they try to identify what exactly the problem is, and how to fix it since it seems to be a common and widespread problem.

Share this post


Link to post

I hesitate posting this here because I am not sure it is going to help anyone, but my evernote is back up and running on my iMac (as of now!) 

 

A few days ago, my Safari attempted to update to version 7.0 which is currently meant for Maverick.  I have Mountain Lion.  When looking at my version number of Safari it said I had version 6.1 but talking with the apple reps, she said it was functioning like version 7.0.  

Anyway, I had called into Apple support last night because no matter what I did, I couldn't use Flash or Silverlight on any webpages.  It kept telling me they were out of date.  This was a new problem, had only been happing for a couple days or so.  

After an hour, we figured out the Safari issue and she had me re-install the OS X (by shutting down the computer and holding down CMD+R while it rebooted).  It took about 4 hours to do, but this morning, while testing everything, my websites are working again and so is my Evernote!  

 I know nothing about reinstalling your operating system and only attempted it because the Apple rep was walking me through it.  But, I did want to post this here in the event that it gives the Evernote support staff some insight on to what might be going on with the blocked plug in issue.  

Share this post


Link to post

@Jackolicious - If you can provide a set of step-by-step instructions on what we can provide (System logs, etc.) that may help diagnose the issue I would be happy to assist.  This is becoming a bigger issue everyday and has lingered for way too long.

Share this post


Link to post

I have the same problem everyone is reporting here. 

 

I get blocked plug-in for the following:

 

PDFs attached to a note

To do items

Microsoft office documents attached to a note

 

This has rendered my Mac version of Evernote almost unusable, so very keen to hear about a resolution.

 

Many Thanks

Share this post


Link to post

It didn't work for me but I had to try and create the file rather than copy it from another machine.  Perhaps I created it incorrectly?  I will look around to see if I can find a copy of the file from a friend.

Share this post


Link to post

I had this issue forever.    I looked in /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources and found that I had the files but the we both marked as .bak

 

I renamed them and all is good now.   Even iMessage was throwing missing plugins and now that is working as well.

 

Pat

Share this post


Link to post

It didn't work for me but I had to try and create the file rather than copy it from another machine.  Perhaps I created it incorrectly?  I will look around to see if I can find a copy of the file from a friend.

 

 

I recreated the file using a different text editor and it worked!!!!  Thanks everyone for sharing the solution.

Share this post


Link to post

vanduse, what did you put in the text file?

 

It is here in the apple support forum: https://discussions.apple.com/message/23420190#23420190

 

For ease of use I have copied the context listed on the apple forum.  

 

File Contents Below: 

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

          <key>JavaWebComponentVersionMinimum</key>

          <string>1.6.0_45-b06-451</string>

          <key>LastModification</key>

          <string>Tue, 08 Oct 2013 23:00:00 GMT</string>

          <key>PlugInBlacklist</key>

          <dict>

                    <key>10</key>

                    <dict>

                              <key>com.apple.java.JavaAppletPlugin</key>

                              <dict>

                                        <key>MinimumPlugInBundleVersion</key>

                                        <string>13.9.7</string>

                                        <key>PlugInUpdateAvailable</key>

                                        <true/>

                              </dict>

                              <key>com.apple.java.JavaPlugin2_NPAPI</key>

                              <dict>

                                        <key>MinimumPlugInBundleVersion</key>

                                        <string>13.9.7</string>

                                        <key>PlugInUpdateAvailable</key>

                                        <true/>

                              </dict>

                              <key>com.macromedia.Flash Player.plugin</key>

                              <dict>

                                        <key>MinimumPlugInBundleVersion</key>

                                        <string>11.8.800.94</string>

                              </dict>

                    </dict>

          </dict>

          <key>Version</key>

          <integer>68</integer>

</dict>

</plist>

  • Like 1

Share this post


Link to post

I'd like to see if this helps others too. Please post your results.

Worked for me too. Thanks richESPN !!!

Share this post


Link to post

@richESPN this did the trick for me too. Copied the text into a .txt file, saved as XProtext.meta.plist, and copied to the folder. When I reopened Evernote (Premium) my PDFs were back. 

 

Thanks so much!!!  :wub:

Share this post


Link to post

I tried creating the file from scratch, but didn't work.

 

I had to copy the actual file. I have posted it here if anyone needs to download a copy of it:

 

http://rxh.cc/1bkGcPM

Thank you Ryan Hunt. I have had to use this fix twice since December 2013. 

Share this post


Link to post

I found the following solution on the Apple Forums which solved the issue for me:

 

https://discussions.apple.com/message/23420190#23420190

 

Basically,  I was missing the "XProtect.meta.plist" file whch is located in /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources

 

Holy *****; this worked for me as well!

 

In my case, I had a file named `XProtect.meta_OLD.plist` just sitting there, so I did `sudo ln -s XProtect.meta_OLD.plist XProtect.meta.plist`, restarted Evernote and it's all working!

 

I assume the company I work for moved that file, but who knows why. If it gets reverted I will set up a cron task to make sure it's never broken again :P

Share this post


Link to post

I just installed Mac Security Update 2014-003 and the blocked plug in problem happened again.

As I have done multiple times in the past, I copied an new Xprotect.meta.plist (from earlier in this thread) file into the /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources folder. This time the fix did not work. Does anyone have a fix for this recurring problem? Do I need to to install Java for OS Update?

 

I have done some looking around and found the following.

 

I found this,

 I am running mac os x 10.8.3.As apple disabled java plugins older than 1.7.11 i am getting blocked plug-in for java 1.7.7 plugin.But My Applications work with java 1.7.7 plugin only as there is gh security in later versions of java 1.7.09 my applets wont work with gher java plugin of 1.7.09.So have to make work/enable java plug-in 1.7.7 in mac os x 10.8.3.I tried to do change in XProtect.meta.plist.But it is not allowing to login as root give write access. Everytng worked fine with mac os x 10.8.2.After upgrading to mac os x 10.8.3 only i am getting ts problem.Can anyone please help me to resolve ts.It would be great if anyone have solution or workaround for this.

 

 

on Likely Answer.

 

Do I need to to install Java for OS Update:

About Java for Mac OS X 10.5 Update 10 Java for Mac OS X 10.5 Update 10 delivers improved reliability, security, and compatibility for J2SE 5.0 and Java SE 6. Java for Mac OS X 10.5 Update 10 supersedes all previous updates of Java for Mac OS X 10.5. This release updates J2SE 5.0 to 1.5.0_30, and updates Java SE 6 to 1.6.0_26.

J2SE 1.4.2 is no longer being updated to fix bugs or security issues and remains disabled by default in this update.

Support for out-of-process Java applets on Mac OS X 10.5 Leopard has been removed with this update.

This release is only for Mac OS X 10.5.8 or later versions of Mac OS X 10.5.

This release of J2SE 5.0 supports all Intel and PowerPC-based Macs. Java SE 6 is available on 64-bit Intel-based Macs only.

 

Share this post


Link to post

×
×
  • Create New...