Jump to content
E-NoteForum

mac Extra Line Breaks w/ Copy/Paste

Recommended Posts

There was a golden era for a few months, maybe even a year, when Evernote's text formatting was pretty solid, but now the extraneous line breaks have returned. It makes using Evernote with any other text-accepting program incredibly frustrating.

 

I haven't been able to find a solid repro path, but I have found that in notes that have nothing but text, and which have no formatting of any kind, sometimes when I copy/paste the text from Evernote into other apps there will be extraneous line breaks. There will frequently be an extra line break above the first line of the note, and sometimes extra line breaks are inserted randomly in between lines of text.

 

They aren't inserted mid-sentence, they are always inserted where there is a line break. It's as if you hit Enter twice when starting a new line, not just once.

 

In my experience, this is 100% caused by Evernote. I have tested it with numerous other text-handling apps, and Evernote is always the culprit. Here's a probably-not-comprehensive list of other apps that interoperate perfectly with each other, but not with simple text from Evernote:

  • Firefox
  • NotesTab
  • Pages
  • Scrivener
  • Sparrow
  • TextEdit
  • Unity3D Editor

I have notes that look correct in Evernote (i.e. no extraneous line breaks) that will have line breaks if I copy them into any of the above programs. The text always looks right in Evernote and is always busted in the same way in any other app I paste it into.

 

If I recreate the exact same text in any of the programs above and paste them into any of the other programs above, the integrity of the text is preserved perfectly.

 

It seems that Evernote still doesn't have a clean text formatting engine, and that there are some non-standard ways it handles text for itself that are incompatible with the rest of the text formatting world. It's super frustrating not to be able to rely on WYSIWYG formatting. Despite all of the features that have been piled into Evernote over the years, it is a text-based program. The first thing you see when you create a note is a blank text note with a blinking cursor.

 

It's disappointing that after years of struggles, Evernote still doesn't have acceptable text handling for basic, raw, formatting-free text.

 

I'm using Evernote 5.2.1 on Mac and Evernote 5.4.3 on an iPad 2 and iPhone 5. I wouldn't be surprised if these extra line breaks were introduced in notes that have been edited by multiple Evernote clients.

  • Like 2

Share this post


Link to post

+1.

 

It makes Evernote untrustworthy.

 

It's not just line-breaks.  Clip (afaict _anything_) from the Web, and play around with deleting line-returns (if that's what they are) by forward-deleting with the cursor at the end of the line, and deleting with the cursor at the start of a line.  Mayhem.

 

I also like when I paste with the cursor at the end of the Note and the clipboard contents are inserted at the beginning of the Note.

 

Evernote.mac 5.5.1 on OS X 10.8.5.

Share this post


Link to post

Still a bug. Any progress?

There haven't been any public statements specifically regarding this behaviour. However, EN staff have commented on these forums that they are reworking the text editor, so this might be something they will address in these revisions, which I am sure we will see sooner rather than later... at least I hope!

Share this post


Link to post

 

EN staff have commented on these forums that they are reworking the text editor.

 

This is promising (and much-needed). Is there anywhere I could look for more details, or is this more of just a thing that's been mentioned here and there?

Share this post


Link to post

 

 

EN staff have commented on these forums that they are reworking the text editor.

 

This is promising (and much-needed). Is there anywhere I could look for more details, or is this more of just a thing that's been mentioned here and there?

 

Just posts here and there. As is typical of Evernote, they are tight lipped, so it is surprising we have as much info as we do on this. We'll just have to hang in there! Once it hits the betas, details will start to appear on the forums. 

Share this post


Link to post

This problem has been going on got literally a decade yet the Evernote team has yet to do anything about it. It is utterly maddening  that they still can't get simple formatting to work in notes- a problem they have never been able to resolve while the simplest text editors don't have an issue with it.

I put up with it because of the rest of their features, but the makers should really be ashamed about this one. It's literally been around since the product was conceived. I cannot roll my eyes hard enough through the back of my head for this one!

  • Like 1

Share this post


Link to post
On 11/11/2015 at 1:37 AM, Metrodon said:

The latest version contains the new editor

That may be so, but what should come as no shock to anyone, the problem is not fixed. As I said previously, it has been broken for over a decade. Don't expect it to take less than another decade for it to ever get fixed- if ever!

  • Like 1

Share this post


Link to post

This just caused me and my team several hours of headaches as we had stored a couple key/secrets that we use for AWS in evernote.  Big mistake.  When we copied the keys out and put them into use in our application... boom, unexplained errors.  Took us hours to figure out evernote had inserted the extra character.  

I've been a big evernote supporter for years.... probably wouldn't be able to recommend evernote anymore for technical teams until this is fixed.

  • Like 1

Share this post


Link to post

Any solution about this? when I want to copy some commands(on evernote) to the shell I need to copy into another editor before that!

Share this post


Link to post

Nope, not as far as I can tell. Just today I cut and pasted some file names into file namer in TextMate and I couldn't figure out why the file name wouldn't appear to paste, but it was because it was throwing a carriage return in the name. Good thing "git status" caught the weirdness.


This is pretty unacceptable as far as I am concerned, but the folks at Evernote clearly don't seem to care.

Share this post


Link to post

Yes, this still drives me nuts. Extra line return even when the copy contains ONLY the text wanted (not just on double-click selections).

The the issue is with the copy function in EN which must override standard OS copy. If I have for example:

Quote

this is my text to copy

and I highlight ONLY "this is my text" then Cmd+C, I end up with on the paste:

this is my text
(newline)

Buggers.

  • Like 1

Share this post


Link to post

This does remain a problem - perhaps one more post will push it into the queue to actually be solved?

Seriously Evernote.  Are you even a little ashamed?  A response even?

Disgusted

Share this post


Link to post

At least for me, this problem was eliminated in version 6.12 b2.

Share this post


Link to post

There must have been an Evernote version that fixed this problem, because I'e only started experiencing this problem in the last month. It is really annoying when you need to copy/paste something technical. I am using desktop version 6.7.5.5825

Share this post


Link to post

august 2018. same problem, even when i format the note as plain text.

ideas ? workarounds ?

Share this post


Link to post

Yes I'm having this issue with version 7.8, anyone has a workaround?

Share this post


Link to post

I'm having this issue with version v7.8 on Mac. I think it was okay with previous version. I hope it will be fixed in the next version.

Also whenever I use code-blcok (control + command + b), it makes two additional blank lines, which is annoying.

Share this post


Link to post

Upgraded to 7.8 and sure enough I'm seeing the same thing. This pretty much makes pasting from Evernote "dangerous" and unusable for rerunning saved system commands. The word is going around and nobody here (apart from yours truly) will be upgrading Evernote until this is remedied. And if it isn't soon then we'll have no choice but to find a more suitable alternative.

  • Like 1

Share this post


Link to post

I'm having this issue with version v7.8 on Mac

Share this post


Link to post

Same here, the issue is back since 7.8

any plan to fix it?

Share this post


Link to post

This issue is making Everote difficult for me to use day to day as I use it to copy & paste bash terminal commands. I believe it may have started for me after an update in the last quarter of last year, maybe a bit earlier. I'm using Mac OS 10.14.2 and Evernote Version 7.8 (457453 Direct) Editor: 62.1.7539 (b406110). 

I also notice text formatted as code in notes using { } has blank lines added at the end, maybe a related issue?

If this is not fixed soon I will have to find an alternative solution.

Share this post


Link to post

When you copy and paste system commands, the last thing you want is to have a carriage return inserted automatically!

Also wasted 2 hours wondering why a piece of text pasted into a password field wasn't working. Turns out it's because of the extra carriage return.

Please please fix this bug guys.

 

Share this post


Link to post

I have v7.7 on my home mac mini, and there is no problem with copy/paste into terminal.

So you may try delete the app and install v7.7.

Also, check this out. I will test it on Tuesday.

 

a

Share this post


Link to post

Just tested 7.9 Beta 2, it doesn't fix the problem.

 

Share this post


Link to post

This serious bug is STILL not fixed. It destroys my workflow and i've had to resort to mac stickies for cut & paste operations. madness!

Share this post


Link to post

Version 7.9 is out and the bug still remains! I don't get cheesed off by a lot of things but this is getting beyond a joke. I have a TON of commands in Evernote I copy from and this is messing with me big time.

 

Share this post


Link to post

given the attention that evernote is giving to this critical issue it is time to move on and use something else apparently... 

Share this post


Link to post

I keep hoping each update I install is going to fix it.  It seems like such a simple problem to address, but alas, it persists.  Over the years, I developed a habit of pasting commands I have in evernote into Atom to get rid of the newline, and then into the terminal.  Sometimes I forget though, and its always dangerous. 

I think I'm over it.

Bye Evernote, its been real.  

Share this post


Link to post

I’m close to that point too. I had forgotten about this bug (certainly it’s not a feature) and recently once again struggled to login to our servers with long, 14+ digit password that was copied and pasted from Evernote. I ended up alerting our web host, we chased our tails for a few hours before I realized it was this old big biting me on the butt again.

Why is Evernote injecting text/code into our notes even if and when we selectively select limited text? No clue, but it’s clear they aren’t seeing these discussions so we need to find another way to reach them for a simple fix or find a new widget.

Share this post


Link to post

@cmoriarty,@Sabbione, @Dave Darby the fix for this is available in the 7.10 Betas 1 & 2 (more info here) and will be released in the next full 7.10 GA update if you're not a fan of betas. If you want to try a beta, keep in mind you'll need to first be on the direct download version of Evernote from www.evernote.com, not the Mac App Store version. 

Share this post


Link to post
Posted (edited)

I have 7.10 for Mac installed, and I'm still seeing the problem with the extra newlines being inserted.

 

It appears the problem is not with the Evernote editor but with the what Evernote is doing with the macOS clipboard when it detects text is copied to the clipboard. I'm seeing this problem with extra newlines when I'm trying to copy and paste lines of text between MacVim and Excel, not involving Evernote in any way. If Evernote is running, I have the newline problem. If Evernote is not running, I don't see the newline problem, at least in my 30 min of testing with Evernote not running. But I haven't had the time to run and document a series of comprehensive tests to figure out all the edge cases.

Edited by nomaded
fixed typo and clarity

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...