Jump to content
Dennis Moul

android (Archived) "Sync Notes" option greyed out / disabled on Android

Recommended Posts

I upgraded my Sprint Epic 4G to Android 4.1 Jelly Bean (via Cyanogenmod 10.0), and when I installed Evernote, I couldn't get automatic syncing to work. The "Sync Notes" and "Sync Frequency" options were greyed out/disabled and not selectable. Under the "sync notes" option was the description "cannot modify when device master sync is disabled." 

 

It turns out that there is a phone-wide "sync toggle" that can suppress syncing for ALL apps, and if that is set to off (which is the default in Android 4.1 I think) then Evernote will not autosync no matter what. You have to enable the master Android sync option, then the "Sync Notes" and "Sync Frequency" options become available and you can do what you want.

 

To turn the sync toggle back to on, go to Settings->Data Usage->(menu button) and select the "Auto-sync data" option.

 

Alternatively, you can expose the Sync Toggle on the notification pulldown via Settings->System->Notification drawer->Widget Buttons->Toggle Sync.Once that setting is changed, pull down the notification bar and swipe left/right on the toggles to find the sync button.

 

Hopefully this will save someone else some hassle - Google searching the message "cannot modify when device master sync is disabled" was not finding anything useful.

 

Dennis

Share this post


Link to post

? I run Android 4.1.2 and there's no global sync switch in my Data settings at all.  Maybe it's a manufacturer thing.

Share this post


Link to post

Yeah -- I have a Motorola Razr Maxx HD (boy what a stupid name -- I feel like a dolt just typing it) -- it.s Android 4.1.2 as well, and there's no such setting that I can see. Don't recall anything like that on my Nexus 7 either (Android 4.2).

Share this post


Link to post

Thanks, Dennis! This is true for the HTC One as well.  

 

Here's how to fix it for this phone:

 

Settings>Account & sync> Toggle 'Auto sync' to 'On', then click on Evernote in the drop-down list. 

Click on your account name >  tick next to 'Sync notes'

Go back to the previous page.

Click on 'Sync', which takes you to the Evernote app's sync page. There you can change frequency and if you want to sync via WiFi only. 

 

I hope this helps anyone else who has the same issue. :)

 

I upgraded my Sprint Epic 4G to Android 4.1 Jelly Bean (via Cyanogenmod 10.0), and when I installed Evernote, I couldn't get automatic syncing to work. The "Sync Notes" and "Sync Frequency" options were greyed out/disabled and not selectable. Under the "sync notes" option was the description "cannot modify when device master sync is disabled." 

 

It turns out that there is a phone-wide "sync toggle" that can suppress syncing for ALL apps, and if that is set to off (which is the default in Android 4.1 I think) then Evernote will not autosync no matter what. You have to enable the master Android sync option, then the "Sync Notes" and "Sync Frequency" options become available and you can do what you want.

 

To turn the sync toggle back to on, go to Settings->Data Usage->(menu button) and select the "Auto-sync data" option.

 

Alternatively, you can expose the Sync Toggle on the notification pulldown via Settings->System->Notification drawer->Widget Buttons->Toggle Sync.Once that setting is changed, pull down the notification bar and swipe left/right on the toggles to find the sync button.

 

Hopefully this will save someone else some hassle - Google searching the message "cannot modify when device master sync is disabled" was not finding anything useful.

 

Dennis

  • Like 2

Share this post


Link to post

Here's how to fix it for this phone:

 

Settings>Account & sync> Toggle 'Auto sync' to 'On', then click on Evernote in the drop-down list. 

Click on your account name >  tick next to 'Sync notes'

Go back to the previous page.

Click on 'Sync', which takes you to the Evernote app's sync page. There you can change frequency and if you want to sync via WiFi only. 

 

I hope this helps anyone else who has the same issue. :)

Nice. Thanks.

Share this post


Link to post

Thanks, Dennis! This is true for the HTC One as well.  

 

Here's how to fix it for this phone:

 

Settings>Account & sync> Toggle 'Auto sync' to 'On', then click on Evernote in the drop-down list. 

Click on your account name >  tick next to 'Sync notes'

Go back to the previous page.

Click on 'Sync', which takes you to the Evernote app's sync page. There you can change frequency and if you want to sync via WiFi only. 

 

I hope this helps anyone else who has the same issue. :)

 

I upgraded my Sprint Epic 4G to Android 4.1 Jelly Bean (via Cyanogenmod 10.0), and when I installed Evernote, I couldn't get automatic syncing to work. The "Sync Notes" and "Sync Frequency" options were greyed out/disabled and not selectable. Under the "sync notes" option was the description "cannot modify when device master sync is disabled." 

 

It turns out that there is a phone-wide "sync toggle" that can suppress syncing for ALL apps, and if that is set to off (which is the default in Android 4.1 I think) then Evernote will not autosync no matter what. You have to enable the master Android sync option, then the "Sync Notes" and "Sync Frequency" options become available and you can do what you want.

 

To turn the sync toggle back to on, go to Settings->Data Usage->(menu button) and select the "Auto-sync data" option.

 

Alternatively, you can expose the Sync Toggle on the notification pulldown via Settings->System->Notification drawer->Widget Buttons->Toggle Sync.Once that setting is changed, pull down the notification bar and swipe left/right on the toggles to find the sync button.

 

Hopefully this will save someone else some hassle - Google searching the message "cannot modify when device master sync is disabled" was not finding anything useful.

 

Dennis

Thank you. I have a htc one v, and I was facing this sync problem. Thanks for your reply, and god bless the internet and this lovely forum.

Share this post


Link to post

I on the other hand, WANT to make the app to stop syncing. I deselected the "auto-sync data" option on the settings menu of my android phone, and saw that the "Sync Notes" and "Sync Frequency" options were greyed out (as the first poster says), but the app STILL syncs all my notes to the cloud.

 

Does anyone know if I can disable syncing from the android app?

Share this post


Link to post

It's not possible to prevent the app from syncing altogether,  because that's its purpose in life.  It's designed to sync the temporary notes stored in the phone with more permanent storage online.  You can delay the app syncing by going to Settings (in Evernote for Android) and Sync and ticking the Wireless Network sync only option,  but that's as good as it gets...

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...