Jump to content
Vishal Raheja

(Archived) Error Peer certificate cannot be authenticated with given CA certificates in OAuth

Recommended Posts

Hello,

I'm trying to run the oauth samples given on https://github.com/evernote/evernote-sdk-php on my localhost. But, I'm getting this error on step 1:

Error obtaining temporary credentials: making the request failed (Peer certificate cannot be authenticated with given CA certificates)

 

I've gone through the thread http://discussion.evernote.com/topic/24391-im-having-a-problem-to-use-oauth-in-php/ and tried to use the statement:

$oauth->disableSSLChecks();

in the getRequestToken() and getAccessToken() functions in Client.php. But, it still throws the same error. And I've not been able to find the variables NOTESTORE_PORT or NOTESTORE_PROTOCOL (the thread suggested to change these variables) in the config.php file.

 

I'm using XAMPP(with PHP 5.4.7) on Windows 7. Kindly help me with this.

 

Thanks in advance,

 

Vishal

Share this post


Link to post

I got it where the problem was and I've been able to solve the issue withthe $oauth->disableSSLChecks(); statement itself. I had just misplaced the statement somewhere.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...