Jump to content
mogf01

mac Embedded images not displayed anymore?

Recommended Posts

At some point in time, several of my notes that includes images have stopped displaying the embedded image contents. Instead, the images are displayed as a generic file attachement placeholder. This applies to both Mac and Windows versions.


 


The web client doesn't display the images either, but instead shows a placeholder.


 


The iPad client shows the images properly. (Yes, I've made sure I synched the notes… they display perfectly on the iPad).


 


I can fix this issue by editing the notes (I'm on a Mac in this case):


  • Open image in Preview (right-click and choose "Open With" and then "Other…" and select Preview)
  • Mark all and copy (Cmd-A, Cmd-C, in Preview)
  • Paste image into the note in the same spot as the placeholder graphic
  • …repeat for all ruined images…

Now sync and the edited note displays embedded images properly.


 


My guess is that Evernote changed some embedded image strategy/implementation at some point in the past, and that my notes became ruined at that time. I'm a bit disappointed in this behavior of course, but since I realize that bugs will occur now and then I don't want to make too big of an issue out of it (I could edit the notes and fix them, as stated above). What I'm mainly curious about is if there is a tip/idea on how I can avoid these types of problems in the future?

Share this post


Link to post

Yup. Regular backups.

 

There's no possible way to defend constructively against some random strategy change that might affect the content or presentation of your notes.  We kind've have to rely on Evernote 1) not to mess up and 2) to have some pretty comprehensive backups of its own.  But - stuff happens.  By some unusual combination of circumstances a routine change might have really bad consequences for your data.  Since no-one else loves it quite as much as you do, it makes sense to have a couple of local copies going back for as long as you have storage media space.

Share this post


Link to post

Yes, backups are necessary. In this case, however, backups didn't help all that much, since the data wasn't really lost, but rather didn't display as before. My local backups had the same problem.

 

I've not experienced any other such problems with Evernote, however, so I'm assuming this was a one-time thing. And, since I really didn't lose the data, I could fix my notes.

 

Thanks for the reply, cheers.

Share this post


Link to post

Ok, great. I've just sent some more info about the problem to the support thread I've opened. Good luck in finding and fixing this.

Share this post


Link to post

:) Might help if you post your support ticket number here too..

Share this post


Link to post

The Ticket# for this issue is 55471. As I've let the support people know, I have fixed my notes that were broken so I don't really need a fix to this. I've reported it mostly to see if there is a well known issue that one can avoid, and to let them know there is a problem hidden somewhere... :-)

Share this post


Link to post

I'm having the same problem. All synced up but on one Win desktop the image preview looks fine but the embedded image inside the note shows as a broken link icon.

Share this post


Link to post

I am on a Mac and the right click option on the broken image does not give me the option to open in other.

This is seriously a bunch of *****. I'm a premium user and can't believe this is happening. I images that had codes on them that I know can't access.

 

  • Like 1

Share this post


Link to post

Hello, I am having the same issue as someone described way back in 2013. My images appear properly on my MAC but when I try to access them on my iPhone they suddenly don't load and just show the generic .PNG icon. This is a major problem because I am using these notes all the time at work, I need them. Had no problem until a few weeks back.

Noticed that it had been noticed by Evernote employees as well in 2013, any development?

Thank you in advance.

Share this post


Link to post
On 24/02/2016 at 0:37 AM, Milchkuh said:

Hello, I am having the same issue as someone described way back in 2013. My images appear properly on my MAC but when I try to access them on my iPhone they suddenly don't load and just show the generic .PNG icon. This is a major problem because I am using these notes all the time at work, I need them. Had no problem until a few weeks back.

Noticed that it had been noticed by Evernote employees as well in 2013, any development?

Thank you in advance.

Hi.  Probably a good idea to contact support about this...

Share this post


Link to post

Found a way to correct this. I just had to switch to "Download all notes" on my iPhone.

Corrected the whole situation.

  • Like 1

Share this post


Link to post

I am seeing this issue and I have "Download all notes" selected. This is a huge issue because I can't force a re-sync on a note. I have to go back to my Mac, edit the note, and hope the re-sync fixes the issue with the bad image (image is just a PNG placeholder icon).

I ran into this issue when I needed an image file when I was out of coverage without my Mac - this is why I pay for the offline note option.

Is there a workaround? Am I still vulnerable even if current versions fix the issue because my data is old (should I blow away all data and re-sync)? Is there an existing bug Evernote is working on if this isn't fixed?

This is extremely frustrating an one never knows when its going to happen. If you are offline or can't edit a note from another device to force a re-sync you are stuck.

Thanks Evernote team!

Share this post


Link to post

I am having the same issue with the PNG images not showing (image is just a PNG placeholder) on my iPhone.   The images are viewable on the web version of Evernote.   This seems to occur when I do screen clips on my Mac and save them into the Mac Evernote Application. 

Is there a solution for this?

 

Share this post


Link to post

Suggestions would be:

  1. Make sure you have the latest version of Evernote
  2. Check all devices to see which (if any) will display images
  3. If an image is not visible on any device,  try Note History if you can (Premium feature) to get it back
  4. If an image is visible on one device but not another,  try saving the image to file and attaching the file to your note.
  5. If all else fails contact support directly if you can,  or message them on Twitter

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...