Jump to content
EdH

windows Evernote stutter in search box

Recommended Posts

Does anyone else experience this? I have EN 4.6.3 (latest beta, but has been going on for a while) and whenever I enter anything in the search bar, the EN UI locks up after the first 2 characters for 2-3 seconds. My disk activity light on my laptop doesn't come on, so I am not sure what is going on. Always after 2 chars. never the first, and once the stutter is done, I can type away freely.

 

I have Win7, 64bit, 8GB RAM, 256GB SSD.

Share this post


Link to post

I've noticed this since quite a while. My guess is that they have some sort of quick index pre-built; after two characters they need to switch over to an alternative, but I sure don't know that, and it's never been a big concern for me.

Share this post


Link to post

Long ago, I turned off the auto search. Having just turned it back on to see if I see the same (I had never really seen slowdowns when searching for whatever reason) I do see it.

So, another reason for me to keep it off. (I personally hate the flickering of the search changing as I type, and that is not just in EN - Google searches is another one...)

Share this post


Link to post

EdH,

Thanks for the report - ticket #6031 has been filed for this issue.

  • Like 1

Share this post


Link to post

So, it's been over a year since ticket #6031 was opened on this issue, I still have the problem on the current 5.4.0 Windows client -- it's enough to make me think twice before even starting to search in Evernote (or to make me type my query in another program, then paste it into the Evernote search box, which is hardly convenient).  spg Scott mentioned turning off auto-search, but I can't find an option for that in the Windows client.  Is there a way to do that?  Is a fix forthcoming?  Windows XP (yes, I know it's at end-of-life; it wasn't when the ticket was opened ;) ).

Share this post


Link to post

So, it's been over a year since ticket #6031 was opened on this issue, I still have the problem on the current 5.4.0 Windows client -- it's enough to make me think twice before even starting to search in Evernote (or to make me type my query in another program, then paste it into the Evernote search box, which is hardly convenient).  spg Scott mentioned turning off auto-search, but I can't find an option for that in the Windows client.  Is there a way to do that?  Is a fix forthcoming?  Windows XP (yes, I know it's at end-of-life; it wasn't when the ticekt was opened ;) ).

 

You need to access the registry to do this:

 

 

After revision 254440 (v4.5.7 beta3 and later) Evernote Windows client loads search-as-you-type delay time from registry value HKCU/Software/Evernote/Evernote/SearchAsYouTypeDelay which by default is set to 50 milliseconds. If you change this value to 0, search-as-you-type feature will be completely disabled, so you'll have to press Enter or click the Search button at the right of the search entry field to start search.

 
I changed it to 1250 Decimal so I have just over a second before it starts hassling me.

Please make sure you shut down Evernote with File/Exit before changing the application registry.

Share this post


Link to post

Same long-term problem for me.  I don't think I'll make the above changes (although very interesting!)  I'd really like an in-app solution to this problem.  Thanks for the post, it's nice to know I'm not alone.

Share this post


Link to post

×
×
  • Create New...