elziko

windows (Archived) Attachment Handling is Really Buggy

6 posts in this topic

I'm finding that attachment handling is very buggy under certain circumstances. Here are some examples using v4.6.2.7927 (268435):

 

Cannot rename a copy of an attachment:

  1. Create a new note.
  2. Drag and drop an attachment into the note. In my example: Test.docx.
  3. Select the attachment above and copy and paste it into the same note.
  4. You can right click and choose rename for the first attachment. I renamed to Test1.docx.
  5. If you try and rename the second attachment no "Rename Attachment" dialog appears after clicking the "Rename" menu item.

Renaming one attachment renames all copies of that attachment:

  1. After completing the above test - click on another note and then return to the note with the two attachments.
  2. Now both attachments are called Test1.docx even though I never renamed the second attachment.

Opening one attachment causes the other not to be found (this seems to only affect DOCX attachments and the failure is not consistent, for me):

  1. Using the note create above - open the first attachment.
  2. Close it and immediately open the second attachment.
  3. I get a message saying "This file could not be found..."
  4. If I wait a while between closing one and opening the other - the chances of success improve.

The failure of opening the second attachment loses all changes to the first  (this seems to only affect DOCX attachments and the failure is not consistent, for me):

  1. Using the note create above - open the first attachment.
  2. Add some text to the document.
  3. Close it and immediately open the second attachment.
  4. I get a message saying "This file could not be found..."
  5. Now open the first attachment - all the text I added in step (2) is lost.

Rename doesn't seem to take effect until you leave and return to a note:

  1. Create a new note.
  2. Drag and drop an attachment into the note. In my example: Test.docx.
  3. Rename attachment to Test1.docx.
  4. Nothing happens.
  5. Click on another note and then return to the newly created note.
  6. Now note's name has changed as expected.

Strange behaviour after deleting an attachment:

  1. In the note created above, delete Test1.docx.
  2. Now drag the original Test.docx back into the note.
  3. The dropped file is actually called Attachment.bin.

It seems that this is all related to creating a copy of one attachment within the same note. I have tested this on two separate machines. Anyone else seeing any of the same behaviours?

Share this post


Link to post

elziko,

 

Thanks for the reports - ticket #6038 has been filed for issues #1/#2, and ticket #4488 & #546 are already open for issues #5/#6. 

Share this post


Link to post
Guest
This topic is now closed to further replies.