Jump to content
crshortt

Windows (Archived) Multi-select in Windows client v4.6.1

Recommended Posts

Since the update for Evernote Windows this past Friday, the search feature is broken on my computer. I cannot select more than one tag. Control clicking a second simply clears the first one. Then, typing anything into the search box immediately clears the tag. Anyone else having this problem. It was an automatic update, but is there any way to revert back to the previous version until this is fixed?

Share this post


Link to post

Latest version is 4.6.1 (7860).

Something funky is going on; not really able to quite put my finger on it. Here's what I observe:

* If I select a notebook that I own or have had shared to me (a joined notebook), then tag multi-select via Ctrl+click seems to work fine.

* If I select the "Personal" branch in the notebook tree, then select a stack of owned notebooks, the tag tree shows "Tags from Personal", and shows the tags from the entire collection of owned + joined notebooks, while the search info shows the stack name and the filter is correct (this is misleading at best, and probably a bug). You can continue on and start playing with the tags tree, but it's not in sync with the search at this point.

* One more thing that I noticed (and this is weird): First, let me note that I have enough tags, notebooks and saved searches such that the vertical scroll bar on the left panel is showing; this may or may not be relevant, but it certainly highlights the problem. OK, so I select a notebook in a stack (can be joined or owned). Then I select its containing stack. Problem 1: the tag tree does not update properly to show all of the tags in the stack. Then I click on a tag in the tag tree. Problem 2: at this point, the scroll bar starts going a little crazy, cycling back and forth between two sizes. At this point, further clicking in the tag tree has no effect, however, I can pick a notebook, and everything goes back to normal.

There are probably other weird cases; I didn't go too far, or try out typing in the search box -- I only just clicked around in the notebook tree and the tag tree in left panel. There are definitely some issues with this.

  • Like 1

Share this post


Link to post

I am at build 268368, Win8Pro x64. I am not able to reproduce any actual problems - correct tags are displayed for the Notebook/Stack/Shared-Notebook that I select, but I do see the tag selection change names between "All my notes", "personal" and "Tags shared from <shared_notebook_name>".

The heading, "Tags from shared notebook" always display properly for the selected shared notebook. The tag heading seems to flitter between "All My Notes" and "Personal" for my own notebooks though.

I also could not reproduce any strangeness in multi-selecting tags. It all seemed to work okay, properly filtering and allowing me to ctrl-click multiple tags.

L

Share this post


Link to post

I haven't had time to work out all the specifics, but here are more observations.

I restarted the computer (just in case) and opened Evernote.

1) I don't think this was working correctly since the update - but I could be wrong. But now, I can select a notebook from the left side tree, then control click multiple tags, as well as type additional words in the search box and it seemingly works fine now.

2) If I select a notebook from the dropdown menu on the toolbar, then try to select a tag from the tree, it clears the notebook selection to All Notes and searches only the tag. Likewise if I select a tag from the toolbar dropdown menu. Trying to control click an additional tag from the tree clears the first tag selected. Likewise, regardless of what notebook or tag I select from the toolbar dropdown menus, as soon as I type a single letter in the search box, it immediately clears the selected notebook or tag and returns me to All Notes, searching only for whatever is typed in the search box and ignoring my tag or notebook selection.

3) I did not yet narrow down the specifics that cause it to happen, but like Jeff, I have a long list of notebooks and tags. Some combination of things I do now causes the scroll bar to start "going a little crazy, cycling back and forth between two sizes". Actually, a lot crazy! It rapidly jumps up and down continuously and will no longer allow me to select anything. I can grab the toggle and scroll to anywhere I like, but the instant I release the mouse button to actually select a tag or notebook, it instantly starts jumping up and down again, as do , thereby preventing me from selecting anything. Only by killing the application entirely with the task manager and restarting can I get this behavior to stop.

Rick

Share this post


Link to post

I have just upgraded to 4.6.1 and I appear to have lost the ability to multi-select tags. I understand there is a similar bug in the Mac version 5 but has the same happened in the Windows client?

Thanks

[Moderator: merged this post and its two replies to another post relating the same problem]

Share this post


Link to post

There does seem to be something not quite right. I have not been able to reproduce a cause but I have been unable to multi-select tags.

When it happens that I cannot select multiple tags by Ctrl-Click, if I click "All My Notes" and then try Ctrl-Clicking tags, it works again.

Win8x64, EN 4.6.1.7860

Share this post


Link to post

I cannot drag / reorganize tags since the upgrade. After reading the thread, my problems seem closely related.

I also have a very long list of tags and smaller list of notebooks.

Share this post


Link to post
I cannot drag / reorganize tags since the upgrade. After reading the thread, my problems seem closely related.

I'm not sure that this is the same problem, unless you're trying to drag tags from notebooks that you don't own (i.e., joined and business notebooks) . I can drag and reorganize my own tags with no problem.

Share this post


Link to post

Latest version is 4.6.1 (7860).

Something funky is going on; not really able to quite put my finger on it. Here's what I observe:

* If I select a notebook that I own or have had shared to me (a joined notebook), then tag multi-select via Ctrl+click seems to work fine.

*...

I can reproduce all of these symptoms, WIN XP. The problem seems to occur when filtering/searching on a stack rather than an individual notebook. Maybe the bug is related to EN's prohibition of searching on multiple notebooks?

Share this post


Link to post
I can reproduce all of these symptoms, WIN XP. The problem seems to occur when filtering/searching on a stack rather than an individual notebook. Maybe the bug is related to EN's prohibition of searching on multiple notebooks?

No, I don't think so. You can search the multiple notebooks in a stack, either via the UI or the search grammar (i.e., stack:<stack name> term), just fine, and this has been the case for some time now. But I think that there are some funky cases related to interacting with the left panel UI elements that seem to be causing this, possibly related to recent changes in the UI (and maybe underlying code) to accommodate business notebooks. The prohibition on searching more than one notebook at a time is a limitation of the search grammar (only one notebook:<notebook name> per search query is explicitly allowed), and probably the design of interacting with the notebook panel.

Share this post


Link to post

Thanks for posting. We're trying to work through some of these issues

Share this post


Link to post

Most likely related: Windows 7/64 client: I used left click to select one note, scrolled down and shift control on another note, expecting all in between to be selected (for merging). Unlike previous version, this time I got a fatal error and have not been able to run it since.

Note: I did have this release installed and working fine for several hours before it blew up when I tried the multi-select using shift click.

How safe would it be to install the beta .2?

Share this post


Link to post

Thanks for posting. We're trying to work through some of these issues

Thanks, dlu. Any idea when a fix for this might occur? I just noted this problem in another thread, before someone directed me to this one.

Share this post


Link to post

This is really weired. I installed 4.6.2.7927 yesterday on a new Windows 7 laptop, and could not multi-select tags for more than 24 hours. After reading the posts here I began to play around, selecting notebooks including both All Notes and individual ones, and all in a sudden I was able to CTRL select multiple tags on the sidebar. I then played around some more and was not able to reproduce the initial problem!

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...