Jump to content
ozaz

mac Clickable web links

Recommended Posts

Hello,

I am fairly new to Evernote.

When I paste, or type, a URL into Evernote (e.g. www.evernote.com), it does not appear as a clickable link

Is this normal behaviour?

If yes, is there a way to make Evernote create clickable links whenever a URL is typed or pasted?

I am using the Mac client (v. 5.0.4)

Share this post


Link to post

Hello,

I am fairly new to Evernote.

When I paste, or type, a URL into Evernote (e.g. www.evernote.com), it does not appear as a clickable link

Is this normal behaviour?

If yes, is there a way to make Evernote create clickable links whenever a URL is typed or pasted?

I am using the Mac client (v. 5.0.4)

Welcome to the forums!

Unfortunately, we lost this ability in the last update. I believe this is probably a bug, though, and will be fixed shortly.

Share this post


Link to post

@Grumpy: Thanks for the reply. Fingers crossed it gets fixed.

Me too. If you have Parallels installed, you can use the Windows client to activate the links. Alternatively, you can use the iOS clients if you have mobile devices.

Share this post


Link to post

This is a bug that will be fixed in our next release. For now, cmd-k -> cmd-v will work.

  • Like 1

Share this post


Link to post

How long to the next release please? links would be a good feature to have back

If you are signed up for the betas, you can download it now.

Share this post


Link to post

Frustratingly this isn't fixed in 5.0.5 when pasting in URLs from Firefox or even a plain text editor. A couple of versions ago the URL used to be made clickable after pressing return.

Share this post


Link to post

Frustratingly this isn't fixed in 5.0.5 when pasting in URLs from Firefox or even a plain text editor. A couple of versions ago the URL used to be made clickable after pressing return.

Hi! Thanks for reporting this. I think the developers know about the problem (http://discussion.ev...05/#entry185542), and hopefully the next update will finally get rid of the bug. For the moment, the best thing to do might be to use Chrome (Safari does not work) and/or CMD+K to activate links.

  • Like 1

Share this post


Link to post

I think this still hasn't been resolved, has it?

 

This is a bug that will be fixed in our next release. For now, cmd-k -> cmd-v will work.

 

I've tried cmd-k -> cmd-v, but the link in Evernote isn't clickable.

Share this post


Link to post

I can't believe this issue has been ignored by Evernote developers for so long.

Please give users the option to enable Auto-Hyperlinking - to turn http addresses into clickable hyperlinks automatically!

Share this post


Link to post

I can't believe this issue has been ignored by Evernote developers for so long.

Please give users the option to enable Auto-Hyperlinking - to turn http addresses into clickable hyperlinks automatically!

 

Links pasted into the Mac client should be clickable.

Is this failing for you with all urls, or only specific urls?

If it’s the latter, can you give an example?

Share this post


Link to post

I can't believe this issue has been ignored by Evernote developers for so long.

Please give users the option to enable Auto-Hyperlinking - to turn http addresses into clickable hyperlinks automatically!

 

 

I am running Evernote 5.5.2 on OSX 10.9.4 and all links that I have pasted or typed in the last few years are converted to proper clickable links.  I have several whole notes that are nothing but 100s of clickable links (and name of page or note in plain text) all typed or pasted over several versions/years.

 

 

Share this post


Link to post

 

I can't believe this issue has been ignored by Evernote developers for so long.

Please give users the option to enable Auto-Hyperlinking - to turn http addresses into clickable hyperlinks automatically!

 

Links pasted into the Mac client should be clickable.

Is this failing for you with all urls, or only specific urls?

If it’s the latter, can you give an example?

 

Hi, thank you for your reply. In the Windows version it's different. To demonstrate this for you, I have pasted the following YouTube link into a new note:

https://dl.dropboxusercontent.com/u/67563308/New%20Text%20Document.txt

(I had to post the link through the txt file because YouTube links are automatically converted into embedded videos here on this forum)

This is how it looks like:

http://www.dropbox.com/s/0p0j1i62gak7bxk/ScreenShot072.jpg

Share this post


Link to post

I just tested it on my windows machine and it works fine there as well, Evernote 5.4.1.3962 and Evernote 5.5.3.4236

 

You do need to tyoe a space or press enter after the link for it to be made clickable, have you done that?

Share this post


Link to post

I just tested it on my windows machine and it works fine there as well, Evernote 5.4.1.3962 and Evernote 5.5.3.4236

 

You do need to tyoe a space or press enter after the link for it to be made clickable, have you done that?

That's it! All I had to was typing space after the link! I didn't know that. Thank you Jim

My apologies to the developers.

  • Like 1

Share this post


Link to post

 

I just tested it on my windows machine and it works fine there as well, Evernote 5.4.1.3962 and Evernote 5.5.3.4236

 

You do need to tyoe a space or press enter after the link for it to be made clickable, have you done that?

That's it! All I had to was typing space after the link! I didn't know that. Thank you Jim

My apologies to the developers.

 

 

 

No problem, glad to help.

 

Share this post


Link to post

I've had this issue forever. URLs pasted or typed directly into Evernote's Mac app on my machine DO NOT convert into links. Been years since they have.

 

And no, adding a space or a return does not work.

 

Running Evernote 6.0.5 on Mac OS X 10.9.5.

 

Command-K, Command-V results in a clickable link. Still, shouldn't have to remember to do that.

Share this post


Link to post

I'm using the latest version of EN and running 10.10.1 on my Macbook Pro. I recently clipped a pdf document into the current EN app from Safari (using the current web clipper), and none of the URLs work. I sync'd the document with my iPad, and the links work fine on the iPad. I opened the pdf document in Preview, and all of the links work fine there as well.

 

I tried re-saving the document (about 30 pages) in EN, but the result was there same. Out of curiosity, I opened a previously saved EN document with URLs, and the URLs in that document worked fine.

 

I don't see how the document itself could be the problem because the URLs work on the iPad and in Preview on the Macbook Pro. I'd be grateful if anybody has a suggestion for resolving this issue because the document is full of useful links.

Share this post


Link to post

Is this fixed? Running 6.9 in Mac and urls being sent via Zapier aren't automatically clickable. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...