Jump to content
cctiger2

mac (Archived) Why are Note Links opening my Virtual Machine (not Evernote)?

Recommended Posts

Hey All - I've not been able to figure out what is going on here, and I'm hoping someone can help me out.

I am working on a Mac, and trying to use note links to link back to Evernote Notes from other programs on my Mac.

Creating the note link appears to work fine by either the "copy note link" or a simple click and drag. However, when I click the note link it launches my Windows Virtual Machine rather than launching Evernote and taking me to the note. Any idea what is going on here?

I get this same behavior no matter what program I put the note link into (Things, Text Editor, Mail, Etc.) The only exception is that note links within Evernote itself work flawlessly.

Any insight into what is happening here (and how to fix it!) would be most appreciated.

Smiles,

Laura

Share this post


Link to post

Evernote "Links" are actually just URIs (similar to URLs. see http://en.wikipedia.org/wiki/URI_scheme) that are preceeded by the evernote:// resource tag. When you click on these links they actually get sent to you're OS and you're OS decided what should happen. In the case of HTTP:// then the OS knows to open your default browser. VMWare's "Unity mode" gives you the luxury of abstracting your windows applications by pretending to be OSX Applications that get launched in your virtual machine. The most likely scenario is that your VM has evernote and it has managed to register it's URI to the abstracted application.

You can use the following command in terminal to see all registered URIs in your system

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -dump

You will get a lot of text but you can use the search function to find "evernote" and see if there is something fishy with it's registration. I dont know the specifics but you can unregister a URI using the same command. It is possible that your virtual machine just has higher priority and that your other linking will return once you unlink that bad one. You may also want to try removing all of these bindings and then reinstalling Evernote on you're mac to replace them.

I hope this helps.

  • Like 1

Share this post


Link to post

The question, or rather the answer, has to do with the implementation/integration with the virtual machine. The question should be posted at Parallels/VMWare/VirtualBox or whatever software you are using.

As @ErikW wrote: it is just a URL and one program is tagged for getting first shot at it.

Share this post


Link to post

Been to long in replying but wanted to say a huge THANK YOU to Eric & LosManos for the reply.  With the information you guys provided I was able to track down the problem, and after digging around in terminal for awhile I gave up on manually changing the link and found a little freeware program:  RCDefaultApp.  Worked liked a charm to let me re-map the Evernote URI's.

 

Thank you so much guys!

  • Like 2

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...