Jump to content
dpacker

windows (Archived) Unexpected saved search results

Recommended Posts

I'm having a problem with saved searches that appears to have just started as of today with the download of 4.6.0.7670

I have a series of saved searches, for example:

Today: notebook:_Current tag:@Today -tag:#*

This finds all notes tagged @Today less notes that have been classified (#closed, #deferred, #review60)

Action: notebook:_Current tag:@* tag:@Action -tag:@Future -tag:@Goals -tag:@Pending -tag:@Review -tag:@Today -tag:#*

This finds all my small taks items that are secondary to @Today immediate items

Prior to this release, if I clicked on Action it would pull up all my action items and then if I selected the Today saved search it would clear the previous search and show all items with the @Today tag, now those steps hold over the @Action tag, so the Today saved search contains @Today AND @Action and vice versa if I do it in reverse order, which of course filters out a lot of action items.

Was there some new functinality that was introduced? Some new syntax? How do I clear a previous search so there's no carry over?

Thanks

Dave

Share this post


Link to post

On further inspection I found where the problem resides, if you have you have saved searches linked in the tool bar and you click on the above Action and then the Today saved-search it doesn't reset and make Today a new search it keeps the @Action tag. Whereas if you do it in the saved-search listing area it works correctly. Is this a bug or expected behavior? I don't remember it doing this in the prior version.

** NOTE: I just checked this on my home machine running 4.5.10.7472 and it works, so this seems to be a bug introduced in 4.6.0.7670

Share this post


Link to post

I think that this bug or something very like it was reported in the 4.6 Beta 2 thread (pinned to the top of the forum).

Share this post


Link to post

Thanks for posting, we'll be looking into this

Share this post


Link to post

Started seeing the same exact thing after the last update. :(

I've opened a ticket. Guess support doesn't know about this - they told me to uninstall and re-install. Ah, yes, the good old Hail Mary. Of course, that didn't fix it. ;)

Dlu; glad you guys are looking into this. Thanks. :)

Share this post


Link to post

This problem sucks really bad. I have 8 saved searches in my toolbar and none of them work since the last update (symptoms are as described in this post). Is there any way to roll back to an earlier version?

Share this post


Link to post

Please try the latest beta. The thread for it is here:

Share this post


Link to post

:) Yay! Update came down today (4.6.1.7860 (268368) Public) that fixed this! Thanks for fixing that, Evernote. That was really driving me crazy.

Dlu - Unrelated question - do the Beta's not come down for download anymore? Today was the first update I've seen in a few weeks. Yet, I think if I'm reading the release notes right, there were beta's available earlier. The Beta's use to come in the update and one could optionally skip it. Thx.

Share this post


Link to post

Beta's should still come down from the downloads. I'll check on it for the next release

Share this post


Link to post

Two things regarding the betas:

1. Check your settings. (Yeah, I know :P)

2. The update notification conditions have changed somewhat, meaning that you may not have seen it:

We modified the automatic check for updates a bit for this release, which is probably why you're noticing some differences now. I didn't work on this component, but my understanding is that we now check for updates once per day and we perform this check only when the user has been idle for 3 or more minutes (we would previously pop up the update dialog even while the user was typing, which was annoying).

Share this post


Link to post

Thanks, Scott.

:o I didn't know that was a setting, but, sure enough, "Update to pre-release version when available" was un-checked / off.

It must have been on in the past as I used to get pre-releases all the time.

Thanks again for the tip. That probably fixed things.

Share this post


Link to post

:huh: So, I wonder if this may need to be a new thread or topic....

Saved Searches on the tool bar seem to be working pretty well. (I'd swear a couple of times I clicked on one and the whole notebook came up instead, but, can't see to consistently reproduce it.)

However...

Now, when you click "New Note," the Saved Search is "disengaged" and all notes for that notebook appear.

I don't remember it working that way before December. I used to live in my "Priority 1" Saved Search, be able to add a note, tag it as "Priority 1," and see it appear in / still have the "Priority 1" Saved Search displayed.

I also just tried * not * using the toolbar; clicking on the Saved Search to the left; I get the same result.

Comments?

Share this post


Link to post

Bump....

Monday morning ; kicking off my Monday morning with lots of notes creation. But, having to re-select the saved search every time.

dlu, any input? Just want to make sure you saw this.

Thanks.

Share this post


Link to post

There's no need to bump topics here. Thanks.

Share this post


Link to post

Thanks, Jeff, for the reply.

Curious why you say that? Would help me understand the forum better.

Share this post


Link to post

There's no need to bump topics because people who are logged in can see the topics that have new posts since they last read them. Posts that are made purely to "bump", but add no new information aren't much use to anyone. If dlu hasn't read the topic since 1/11 (which has useful information), then it will appear as unread to him, and he will most likely get to it at some point. If he has read it, then your "bump" post marks the topic as unread again, but adds no new information for him. And if he had anything new to say, then he would just say it, regardless of whether you bump or not.

By the way, he is "following" this topic.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...